aboutsummaryrefslogtreecommitdiffstats
path: root/net/zebra
diff options
context:
space:
mode:
authorsumikawa <sumikawa@FreeBSD.org>2004-05-19 09:45:04 +0800
committersumikawa <sumikawa@FreeBSD.org>2004-05-19 09:45:04 +0800
commite4c650e57dc1894061924f66b41707444a5c7f53 (patch)
tree78489c7b00ce83c8d4618580ee152b2a9dac3e16 /net/zebra
parent2e7c16bfc5f0c2e02bc41f2a2b0be2cb592a0c5c (diff)
downloadfreebsd-ports-gnome-e4c650e57dc1894061924f66b41707444a5c7f53.tar.gz
freebsd-ports-gnome-e4c650e57dc1894061924f66b41707444a5c7f53.tar.zst
freebsd-ports-gnome-e4c650e57dc1894061924f66b41707444a5c7f53.zip
Add knobs to sync with net/zebra-devel
Diffstat (limited to 'net/zebra')
-rw-r--r--net/zebra/Makefile53
-rw-r--r--net/zebra/pkg-plist26
2 files changed, 64 insertions, 15 deletions
diff --git a/net/zebra/Makefile b/net/zebra/Makefile
index 3ab4ad4f879a..d41ba2089d92 100644
--- a/net/zebra/Makefile
+++ b/net/zebra/Makefile
@@ -20,13 +20,62 @@ COMMENT= Free RIPv1, RIPv2, OSPFv2, BGP4 route software (server/reflector)
USE_SUBMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc/zebra --enable-vtysh
+CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc/zebra
SCRIPTS_ENV= WRKDIRPREFIX=${WRKDIRPREFIX}
MAN1= vtysh.1
MAN8= bgpd.8 ospf6d.8 ospfd.8 ripd.8 ripngd.8 zebra.8
INFO= zebra
+.if defined (WITHOUT_IPV6)
+CONFIGURE_ARGS+=--disable-ipv6
+WITHOUT_OSPF6D= yes
+WITHOUT_RIPNGD= yes
+.endif
+
+.if !defined(WITHOUT_BGPD)
+PLIST_SUB+= BGPD=""
+.else
+CONFIGURE_ARGS+=--disable-bgpd
+PLIST_SUB+= BGPD="@comment "
+.endif
+
+.if !defined(WITHOUT_OSPF6D)
+PLIST_SUB+= OSPF6D=""
+.else
+CONFIGURE_ARGS+=--disable-ospf6d
+PLIST_SUB+= OSPF6D="@comment "
+.endif
+
+.if !defined(WITHOUT_OSPFD)
+PLIST_SUB+= OSPF6D=""
+PLIST_SUB+= OSPFD=""
+.else
+CONFIGURE_ARGS+=--disable-ospfd
+PLIST_SUB+= OSPFD="@comment "
+.endif
+
+.if !defined(WITHOUT_RIPD)
+PLIST_SUB+= RIPD=""
+.else
+CONFIGURE_ARGS+=--disable-ripd
+PLIST_SUB+= RIPD="@comment "
+.endif
+
+.if !defined(WITHOUT_RIPNGD)
+PLIST_SUB+= RIPNGD=""
+.else
+CONFIGURE_ARGS+=--disable-ripngd
+PLIST_SUB+= RIPNGD="@comment "
+.endif
+
+.if !defined(WITHOUT_VTYSH)
+PLIST_SUB+= VTYSH=""
+CONFIGURE_ARGS+=--enable-vtysh
+.else
+PLIST_SUB+= VTYSH="@comment "
+.endif
+
.if !defined(BATCH)
pre-configure:
@${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
@@ -40,7 +89,7 @@ post-clean:
.endif
post-install:
- @( cd ${WRKSRC}/doc; rm -f zebra*info*; ${MAKE} zebra.info install )
+ @( cd ${WRKSRC}/doc; ${RM} -f zebra*info*; ${MAKE} zebra.info install )
@${ECHO} "===> installing zebra startup file..."
@${SED} -e "s=!!PREFIX!!=${PREFIX}=" \
< ${FILESDIR}/zebractl.sh \
diff --git a/net/zebra/pkg-plist b/net/zebra/pkg-plist
index 9c7ee1eeb14d..4deae73b4859 100644
--- a/net/zebra/pkg-plist
+++ b/net/zebra/pkg-plist
@@ -1,17 +1,17 @@
-sbin/bgpd
-sbin/ospf6d
-sbin/ospfd
-sbin/ripd
-sbin/ripngd
+%%BGPD%%sbin/bgpd
+%%OSPF6D%%sbin/ospf6d
+%%OSPFD%%sbin/ospfd
+%%RIPD%%sbin/ripd
+%%RIPNGD%%sbin/ripngd
sbin/zebra
sbin/zebractl
-bin/vtysh
-etc/zebra/bgpd.conf.sample
-etc/zebra/bgpd.conf.sample2
-etc/zebra/ospf6d.conf.sample
-etc/zebra/ospfd.conf.sample
-etc/zebra/ripd.conf.sample
-etc/zebra/ripngd.conf.sample
+%%VTYSH%%bin/vtysh
+%%BGPD%%etc/zebra/bgpd.conf.sample
+%%BGPD%%etc/zebra/bgpd.conf.sample2
+%%OSPF6D%%etc/zebra/ospf6d.conf.sample
+%%OSPFD%%etc/zebra/ospfd.conf.sample
+%%RIPD%%etc/zebra/ripd.conf.sample
+%%RIPNGD%%etc/zebra/ripngd.conf.sample
+%%VTYSH%%etc/zebra/vtysh.conf.sample
etc/zebra/zebra.conf.sample
-etc/zebra/vtysh.conf.sample
@dirrm etc/zebra