aboutsummaryrefslogtreecommitdiffstats
path: root/net/zephyr
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>1996-12-01 09:23:27 +0800
committerobrien <obrien@FreeBSD.org>1996-12-01 09:23:27 +0800
commit8efcf00b2e5836ef32baf7637535242a296a8c38 (patch)
tree6d6249f3f223daa0ca98c880b13d349c86a0942c /net/zephyr
parent238c02c9d9fee5aee4bb8357a9efa521b3d1364e (diff)
downloadfreebsd-ports-gnome-8efcf00b2e5836ef32baf7637535242a296a8c38.tar.gz
freebsd-ports-gnome-8efcf00b2e5836ef32baf7637535242a296a8c38.tar.zst
freebsd-ports-gnome-8efcf00b2e5836ef32baf7637535242a296a8c38.zip
General Makefile cleanup
Add MAINATERS mkdir -p ==> ${MKDIR} cp ==> ${CP} install ==> ${INSTALL}/${INSTALL_*} etc...
Diffstat (limited to 'net/zephyr')
-rw-r--r--net/zephyr/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/net/zephyr/Makefile b/net/zephyr/Makefile
index 94a021a8eb97..88ef28784611 100644
--- a/net/zephyr/Makefile
+++ b/net/zephyr/Makefile
@@ -3,13 +3,15 @@
# Date created: 1-Aug-1995
# Whom: pst
#
-# $Id: Makefile,v 1.4 1996/11/18 11:37:23 asami Exp $
+# $Id: Makefile,v 1.5 1996/11/18 14:09:56 asami Exp $
#
DISTNAME= zephyr-2.0.4
CATEGORIES= net
MASTER_SITES= ftp://athena-dist.mit.edu/pub/ATHENA/zephyr/dist/
+MAINTAINER= pst@FreeBSD.org
+
.if exists(/usr/lib/libkrb.a) && defined(MAKE_EBONES)
CONFIGURE_ARGS="--with-krb4"
.endif
@@ -25,11 +27,13 @@ ZEPHYR_DOCDIR= ${PREFIX}/share/doc/zephyr
ZEPHYR_DOCS= INSTALL NOTES OPERATING README USING
post-install:
- ${INSTALL} -c -m 755 -o bin -g bin ${FILESDIR}/zhm.sh ${ZEPHYR_RCDIR}
+ ${MKDIR} ${ZEPHYR_RCDIR}
+ ${INSTALL_SCRIPT} ${FILESDIR}/zhm.sh ${ZEPHYR_RCDIR}
+.if !defined(NOPORTDOCS)
${MKDIR} ${ZEPHYR_DOCDIR}
for file in ${ZEPHYR_DOCS} ; do \
- ${INSTALL} -c ${WRKSRC}/$$file ${ZEPHYR_DOCDIR} ; \
+ ${INSTALL_DATA} ${WRKSRC}/$$file ${ZEPHYR_DOCDIR} ; \
done
- ${MKDIR} ${ZEPHYR_RCDIR}
+.endif
.include <bsd.port.mk>