aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2016-10-19 01:45:48 +0800
committerfeld <feld@FreeBSD.org>2016-10-19 01:45:48 +0800
commit73efbe76f0d686acc0551d851b5a6ecee9505549 (patch)
tree98cb2c2855a07d2c5e0d5bfca09100112a352237 /net
parent7a3675c28c4c3bb3151b9019af6cc0eddd553115 (diff)
downloadfreebsd-ports-gnome-73efbe76f0d686acc0551d851b5a6ecee9505549.tar.gz
freebsd-ports-gnome-73efbe76f0d686acc0551d851b5a6ecee9505549.tar.zst
freebsd-ports-gnome-73efbe76f0d686acc0551d851b5a6ecee9505549.zip
net/netatalk3: Fix PAM option
Previous rollback of PAM changes didn't update pkg-plist, so the PAM option was broken. By using @sample if PAM option is enabled we can install a default PAM config that inherits the system PAM configuration while allowing custom configs to remain untouched. PR: 213349 MFH: 2016Q4
Diffstat (limited to 'net')
-rw-r--r--net/netatalk3/Makefile9
-rw-r--r--net/netatalk3/files/pam.conf17
-rw-r--r--net/netatalk3/pkg-message10
-rw-r--r--net/netatalk3/pkg-plist2
4 files changed, 26 insertions, 12 deletions
diff --git a/net/netatalk3/Makefile b/net/netatalk3/Makefile
index 624bf823a7e1..7b652e15910a 100644
--- a/net/netatalk3/Makefile
+++ b/net/netatalk3/Makefile
@@ -3,6 +3,7 @@
PORTNAME= netatalk
PORTVERSION= 3.1.10
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= SF
@@ -73,6 +74,8 @@ LIBWRAP_CONFIGURE_ENABLE=tcp-wrappers
CONFLICTS= bigloo-2.* cap-6.0.* tct-1.* netatalk-[12]* yudit-[0-9]*
+.include <bsd.port.pre.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|%%DB_NAME%%|${BDB_INCLUDE_DIR:T}| ; \
s|%%DB_LIB%%|-l${BDB_LIB_NAME}|g ; \
@@ -87,4 +90,8 @@ post-install:
${INSTALL_SCRIPT} ${WRKSRC}/contrib/macusers/macusers \
${STAGEDIR}${PREFIX}/bin/macusers
-.include <bsd.port.mk>
+.if ${PORT_OPTIONS:MPAM}
+ ${INSTALL_DATA} ${FILESDIR}/pam.conf ${STAGEDIR}${PREFIX}/etc/pam.d/netatalk.sample
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/netatalk3/files/pam.conf b/net/netatalk3/files/pam.conf
new file mode 100644
index 000000000000..c25b473c265e
--- /dev/null
+++ b/net/netatalk3/files/pam.conf
@@ -0,0 +1,17 @@
+#
+# $FreeBSD$
+#
+# PAM configuration for the "netatalk" service
+#
+
+# auth
+auth include system
+
+# account
+account include system
+
+# password
+password include system
+
+# session
+session include system
diff --git a/net/netatalk3/pkg-message b/net/netatalk3/pkg-message
deleted file mode 100644
index 20d4cee012ce..000000000000
--- a/net/netatalk3/pkg-message
+++ /dev/null
@@ -1,10 +0,0 @@
-###
-If you compiled with optional PAM support, you need to create a pam.d
-file called `netatalk'. With the following contents:
-
-%PAM-1.0
-auth include system
-account include system
-password include system
-session include system
-###
diff --git a/net/netatalk3/pkg-plist b/net/netatalk3/pkg-plist
index 4fad9a0076d9..c999f968333f 100644
--- a/net/netatalk3/pkg-plist
+++ b/net/netatalk3/pkg-plist
@@ -12,7 +12,7 @@ bin/netatalk-config
%%DBUS%%etc/dbus-1/system.d/netatalk-dbus.conf
%%DBUS%%etc/dbus-session.conf.netatalk
@sample etc/extmap.conf.sample
-%%PAM%%etc/pam.d/netatalk
+%%PAM%%@sample etc/pam.d/netatalk.sample
libexec/netatalk-uams/uams_clrtxt.so
libexec/netatalk-uams/uams_dhx.so
libexec/netatalk-uams/uams_dhx2.so