aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2016-06-25 03:06:49 +0800
committerpawel <pawel@FreeBSD.org>2016-06-25 03:06:49 +0800
commit382bd84b8acf2d8c18ad2670509558f53ffaed6d (patch)
tree6e120cdfea0f970b71490e4e3ec6eb38f03c7cc3 /net
parent9b05a34791a26726ab74cf8c7b1d1468b9749ebb (diff)
downloadfreebsd-ports-gnome-382bd84b8acf2d8c18ad2670509558f53ffaed6d.tar.gz
freebsd-ports-gnome-382bd84b8acf2d8c18ad2670509558f53ffaed6d.tar.zst
freebsd-ports-gnome-382bd84b8acf2d8c18ad2670509558f53ffaed6d.zip
IIPImage is an advanced high-performance feature-rich image
server system for web-based streamed viewing and zooming of ultra high-resolution images with low processor and memory requirements. The system can handle gigapixel size images as well as advanced image features such as 8/16/32 bits per channel, CIELAB colorimetric images and scientific imagery such as multispectral images and digital elevation maps. WWW: http://iipimage.sourceforge.net/ PR: 210437 Submitted by: me@skylord.ru
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/iipsrv/Makefile38
-rw-r--r--net/iipsrv/distinfo2
-rw-r--r--net/iipsrv/files/iipsrv.in99
-rw-r--r--net/iipsrv/pkg-descr9
5 files changed, 149 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 99d1a5f1459f..bab5dae86262 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -246,6 +246,7 @@
SUBDIR += ifstat
SUBDIR += ifstated
SUBDIR += igmpproxy
+ SUBDIR += iipsrv
SUBDIR += ilbc
SUBDIR += imapproxy
SUBDIR += intel-ixl-kmod
diff --git a/net/iipsrv/Makefile b/net/iipsrv/Makefile
new file mode 100644
index 000000000000..ad067fd221cb
--- /dev/null
+++ b/net/iipsrv/Makefile
@@ -0,0 +1,38 @@
+# $FreeBSD$
+
+PORTNAME= iipsrv
+PORTVERSION= 1.0
+DISTVERSIONPREFIX= ${PORTNAME}-
+CATEGORIES= net
+
+MAINTAINER= me@skylord.ru
+COMMENT= IIP (Internet Imaging Protocol) FastCGI server
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libtiff.so:graphics/tiff
+
+USE_GITHUB= yes
+GH_ACCOUNT= ruven
+
+USES= autoreconf jpeg libtool
+
+GNU_CONFIGURE= yes
+
+USE_RC_SUBR= ${PORTNAME}
+
+PLIST_FILES= bin/iipsrv.fcgi \
+ man/man8/iipsrv.8.gz
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|noinst_PROGRAMS|bin_PROGRAMS|g' \
+ ${WRKSRC}/src/Makefile.am
+ @${REINPLACE_CMD} -e 's|include_HEADERS|noinst_HEADERS|g' \
+ ${WRKSRC}/fcgi/Makefile.am
+ @${REINPLACE_CMD} -e 's|include_HEADERS|noinst_HEADERS|g' \
+ ${WRKSRC}/fcgi/include/Makefile.am
+
+pre-configure:
+ @(cd ${WRKSRC} && ./autogen.sh)
+
+.include <bsd.port.mk>
diff --git a/net/iipsrv/distinfo b/net/iipsrv/distinfo
new file mode 100644
index 000000000000..cc390513ed4e
--- /dev/null
+++ b/net/iipsrv/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ruven-iipsrv-iipsrv-1.0_GH0.tar.gz) = 9156e80a855b36c5c0eb0707a3ea0ba95ec3a52d118d548af51eb2ef9e5e2f85
+SIZE (ruven-iipsrv-iipsrv-1.0_GH0.tar.gz) = 553962
diff --git a/net/iipsrv/files/iipsrv.in b/net/iipsrv/files/iipsrv.in
new file mode 100644
index 000000000000..d51c1303413e
--- /dev/null
+++ b/net/iipsrv/files/iipsrv.in
@@ -0,0 +1,99 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: iipsrv
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add the following line to /etc/rc.conf to enable iipsrv:
+# iipsrv_(instance_)?enable (bool): Set to "NO" by default.
+# Set it to "YES" to enable iipsrv.
+# iipsrv_(instance_)?flags (str): Custom additional arguments to be passed
+# to iipsrv. Default to "--bind 127.0.0.1:9111".
+# iipsrv_(instance_)?pidfile (str): Custum PID file path and name.
+# Default to "/var/run/iipsrv.${instance}.pid".
+# iipsrv_(instance_)?user (str): User to run iipsrv as
+# Default to "nobody".
+# iipsrv_(instance_)?config (str): Config file with environment
+# variables (default empty).
+# iipsrv_instances (str): Set to "" by default.
+# If defined, list of instances to enable
+
+. /etc/rc.subr
+
+name="iipsrv"
+rcvar=iipsrv_enable
+
+load_rc_config $name
+
+: ${iipsrv_enable="NO"}
+: ${iipsrv_flags="--bind 127.0.0.1:9111"}
+: ${iipsrv_pidfile="/var/run/iipsrv.pid"}
+: ${iipsrv_user="nobody"}
+
+command="/usr/sbin/daemon"
+procname="%%PREFIX%%/bin/iipsrv.fcgi"
+start_precmd="${name}_prestart"
+
+if [ -n "$2" ]; then
+ instance="$2"
+ load_rc_config ${name}_${instance}
+ case "$iipsrv_instances" in
+ "$2 "*|*" $2 "*|*" $2"|"$2")
+ eval iipsrv_flags="\${iipsrv_${instance}_flags:-\"${iipsrv_flags}\"}"
+ eval iipsrv_config="\${iipsrv_${instance}_config:-\"${iipsrv_config}\"}"
+ eval iipsrv_user="\${iipsrv_${instance}_user:-\"${iipsrv_user}\"}"
+ eval iipsrv_pidfile="\${iipsrv_${instance}_pidfile:-\"/var/run/iipsrv.${instance}.pid\"}"
+ ;;
+ *)
+ err 1 "$2 not found in iipsrv_instances" ;;
+ esac
+else
+ if [ -n "${iipsrv_instances}" -a -n "$1" ]; then
+ for instance in ${iipsrv_instances}; do
+ eval _enable="\${iipsrv_${instance}_enable}"
+ case "${_enable:-${iipsrv_enable}}" in
+ [Nn][Oo]|[Ff][Aa][Ll][Ss][Ee]|[Oo][Ff][Ff]|0)
+ continue
+ ;;
+ [Yy][Ee][Ss]|[Tt][Rr][Uu][Ee]|[Oo][Nn]|1)
+ ;;
+ *)
+ if [ -z "$_enable" ]; then
+ _var=iipsrv_enable
+ else
+ _var=iipsrv_${instance}_enable
+ fi
+ warn "Bad value" \
+ "'${_enable:-${iipsrv_enable}}'" \
+ "for ${_var}. " \
+ "Instance ${instance} skipped."
+ continue
+ ;;
+ esac
+ echo "===> iipsrv instance: ${instance}"
+ if %%PREFIX%%/etc/rc.d/iipsrv $1 ${instance}; then
+ success="${instance} ${success}"
+ else
+ failed="${instance} (${retcode}) ${failed}"
+ fi
+ done
+ exit 0
+ fi
+fi
+
+
+pidfile=$iipsrv_pidfile
+daemon_user=$iipsrv_user
+iipsrv_flags="-p ${iipsrv_pidfile} -u ${daemon_user} ${procname} ${iipsrv_flags}"
+iipsrv_user=""
+
+iipsrv_prestart()
+{
+ if [ -n "${iipsrv_config}" -a -r ${iipsrv_config} ]; then
+ command="/usr/bin/env `grep -v '\s*#' ${iipsrv_config} | tr '\n' ' '` ${command}"
+ fi
+}
+
+run_rc_command "$1"
diff --git a/net/iipsrv/pkg-descr b/net/iipsrv/pkg-descr
new file mode 100644
index 000000000000..bb825d6cd61b
--- /dev/null
+++ b/net/iipsrv/pkg-descr
@@ -0,0 +1,9 @@
+IIPImage is an advanced high-performance feature-rich image
+server system for web-based streamed viewing and zooming of
+ultra high-resolution images with low processor and memory
+requirements. The system can handle gigapixel size images as
+well as advanced image features such as 8/16/32 bits per
+channel, CIELAB colorimetric images and scientific imagery
+such as multispectral images and digital elevation maps.
+
+WWW: http://iipimage.sourceforge.net/