aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-24 21:59:22 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-24 21:59:22 +0800
commit072d10b660237339ee3181e5a65f9b756fa43cb5 (patch)
tree0a0161b11372c87a41ad127d6ed7ac51db1c9281 /net
parentf51cd5672b51452b1ab19a69b2d798dce1bc3fca (diff)
downloadfreebsd-ports-gnome-072d10b660237339ee3181e5a65f9b756fa43cb5.tar.gz
freebsd-ports-gnome-072d10b660237339ee3181e5a65f9b756fa43cb5.tar.zst
freebsd-ports-gnome-072d10b660237339ee3181e5a65f9b756fa43cb5.zip
Support staging
Diffstat (limited to 'net')
-rw-r--r--net/pathneck/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/net/pathneck/Makefile b/net/pathneck/Makefile
index 2941677e6acc..a3b605124a2b 100644
--- a/net/pathneck/Makefile
+++ b/net/pathneck/Makefile
@@ -17,20 +17,20 @@ PLIST_FILES= sbin/pathneck \
PORTDOCS= COPYING ChangeLog README
MAKEFILE= Makefile.bsd
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e 's,^CC .=,CC ?=,' \
-e 's,^CFLAGS .=,CFLAGS +=,' \
${WRKSRC}/Makefile.bsd
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/pathneck ${PREFIX}/sbin/pathneck
- ${INSTALL_PROGRAM} ${WRKSRC}/get-choke ${PREFIX}/sbin/get-choke
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/pathneck ${STAGEDIR}${PREFIX}/sbin/pathneck
+ ${INSTALL_PROGRAM} ${WRKSRC}/get-choke \
+ ${STAGEDIR}${PREFIX}/sbin/get-choke
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>