aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorjadawin <jadawin@FreeBSD.org>2016-05-31 20:37:33 +0800
committerjadawin <jadawin@FreeBSD.org>2016-05-31 20:37:33 +0800
commit15ea4bb8c4b74864a572c6249e38813d8c223c4d (patch)
treea9b517b806e6047b56ff67294a32c06a98ab3c2a /net
parent15fbacb7c69693e22f2e39753ace4003a9cd278c (diff)
downloadfreebsd-ports-gnome-15ea4bb8c4b74864a572c6249e38813d8c223c4d.tar.gz
freebsd-ports-gnome-15ea4bb8c4b74864a572c6249e38813d8c223c4d.tar.zst
freebsd-ports-gnome-15ea4bb8c4b74864a572c6249e38813d8c223c4d.zip
- Update to 1.0.1
- Add GUI support as an option, enabled by default PR: 209755 Submitted by: mjl@luckie.org.nz
Diffstat (limited to 'net')
-rw-r--r--net/spoofer/Makefile38
-rw-r--r--net/spoofer/distinfo5
-rw-r--r--net/spoofer/files/spoofer.in31
-rw-r--r--net/spoofer/pkg-descr2
-rw-r--r--net/spoofer/pkg-plist4
5 files changed, 65 insertions, 15 deletions
diff --git a/net/spoofer/Makefile b/net/spoofer/Makefile
index 32aa39c7e6a3..8b1d7c40edb6 100644
--- a/net/spoofer/Makefile
+++ b/net/spoofer/Makefile
@@ -1,23 +1,37 @@
# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
# $FreeBSD$
-PORTNAME= spoofer
-PORTVERSION= 0.8e
-CATEGORIES= net
-MASTER_SITES= http://spoofer.caida.org/
+PORTNAME= spoofer
+PORTVERSION= 1.0.1
+CATEGORIES= net
+MASTER_SITES= http://www.caida.org/projects/spoofer/downloads/
-MAINTAINER= jadawin@FreeBSD.org
-COMMENT= Spoofer Project testing software
+MAINTAINER= jadawin@FreeBSD.org
+COMMENT= Spoofer Project testing software
-PLIST_FILES= bin/spoofer
-PORTDOCS= README
+LICENSE= GPLv3
-HAS_CONFIGURE= yes
+BUILD_DEPENDS= protoc:devel/protobuf
+LIB_DEPENDS= libprotobuf-lite.so:devel/protobuf
-OPTIONS_DEFINE= DOCS
+PORTDOCS= README
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/prober/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --disable-development
+
+OPTIONS_DEFINE= DOCS GUI
+OPTIONS_DEFAULT= GUI
+OPTIONS_SUB= yes
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGUI}
+USE_QT5= buildtools_build qmake_build core network gui widgets
+USE_GL+= gl
+USE_RC_SUBR= ${PORTNAME}
+.else
+CONFIGURE_ARGS+= --disable-manager
+.endif
do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/net/spoofer/distinfo b/net/spoofer/distinfo
index ae7732ebe775..95fcd4ea3f81 100644
--- a/net/spoofer/distinfo
+++ b/net/spoofer/distinfo
@@ -1,2 +1,3 @@
-SHA256 (spoofer-0.8e.tar.gz) = 2bd653531399a24a3da60c75627a2ca6bc6fce9a5266ea3e6be7f83ff224741b
-SIZE (spoofer-0.8e.tar.gz) = 253702
+TIMESTAMP = 1464210224
+SHA256 (spoofer-1.0.1.tar.gz) = a70997223f075c1b3834a6bde8fdb7d8179b0dd49b960e915e1ffb1392711e2d
+SIZE (spoofer-1.0.1.tar.gz) = 361056
diff --git a/net/spoofer/files/spoofer.in b/net/spoofer/files/spoofer.in
new file mode 100644
index 000000000000..982cd995bb51
--- /dev/null
+++ b/net/spoofer/files/spoofer.in
@@ -0,0 +1,31 @@
+# $FreeBSD$
+#!/bin/sh
+#
+# PROVIDE: spoofer
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf to enable spoofer:
+#
+# spoofer_enable="YES"
+#
+
+. /etc/rc.subr
+
+name=spoofer
+rcvar=spoofer_enable
+
+command="%%PREFIX%%/bin/spoofer-scheduler"
+command_args="-D"
+
+load_rc_config $name
+
+: ${spoofer_enable="NO"}
+: ${spoofer_flags="-s 1"}
+
+spoofer_stop()
+{
+ %%PREFIX%%/bin/spoofer-cli shutdown
+}
+
+run_rc_command "$1"
diff --git a/net/spoofer/pkg-descr b/net/spoofer/pkg-descr
index c2c13866e52d..0a55972c1d29 100644
--- a/net/spoofer/pkg-descr
+++ b/net/spoofer/pkg-descr
@@ -1,4 +1,4 @@
-Spoofer helps ANA Spoofer Project better understand the current state of
+Spoofer helps the CAIDA Spoofer Project better understand the current state of
filtering in the Internet. It attempts to send a series of spoofed UDP packets
to a central server which logs and summarizes the results.
diff --git a/net/spoofer/pkg-plist b/net/spoofer/pkg-plist
new file mode 100644
index 000000000000..f6cf3ef5076c
--- /dev/null
+++ b/net/spoofer/pkg-plist
@@ -0,0 +1,4 @@
+%%GUI%%bin/spoofer-cli
+%%GUI%%bin/spoofer-gui
+bin/spoofer-prober
+%%GUI%%bin/spoofer-scheduler