aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2017-04-15 02:58:44 +0800
committerswills <swills@FreeBSD.org>2017-04-15 02:58:44 +0800
commit19e86971b0d50cd9488d35a250d94dec1ba1aff7 (patch)
treef93567b34d62d2688ff7bf5853323969091c3dea /net
parentc6a90c45bec4882709275c167d3967495964a38f (diff)
downloadfreebsd-ports-gnome-19e86971b0d50cd9488d35a250d94dec1ba1aff7.tar.gz
freebsd-ports-gnome-19e86971b0d50cd9488d35a250d94dec1ba1aff7.tar.zst
freebsd-ports-gnome-19e86971b0d50cd9488d35a250d94dec1ba1aff7.zip
net/s3ql: create port
S3QL is a file system that stores all its data online using storage services like Google Storage, Amazon S3, or OpenStack. S3QL effectively provides a hard disk of dynamic, infinite capacity that can be accessed from any computer with internet access running Linux, FreeBSD or OS-X. WWW: https://bitbucket.org/nikratio/s3ql PR: 203760 Submitted by: Niklaas Baudet von Gersdorff <stdin@niklaas.eu> (with changes)
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/s3ql/Makefile30
-rw-r--r--net/s3ql/distinfo3
-rw-r--r--net/s3ql/pkg-descr18
4 files changed, 52 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index ff3258ca297d..653a04b641d2 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1238,6 +1238,7 @@
SUBDIR += rubygem-uri-redis
SUBDIR += rubygem-whois
SUBDIR += rude
+ SUBDIR += s3ql
SUBDIR += samba42
SUBDIR += samba43
SUBDIR += samba44
diff --git a/net/s3ql/Makefile b/net/s3ql/Makefile
new file mode 100644
index 000000000000..5cdb406c6460
--- /dev/null
+++ b/net/s3ql/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= s3ql
+PORTVERSION= 2.21
+CATEGORIES= net
+MASTER_SITES= https://bitbucket.org/nikratio/s3ql/downloads/
+
+MAINTAINER= stdin@niklaas.eu
+COMMENT= File system that stores all its data in the cloud
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}apsw>=3.7:databases/py3-apsw \
+ ${PYTHON_PKGNAMEPREFIX}defusedxml>=0:devel/py3-defusedxml \
+ ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py3-requests \
+ ${PYTHON_PKGNAMEPREFIX}pycrypto>=0:security/py3-pycrypto \
+ ${PYTHON_PKGNAMEPREFIX}llfuse>=0:devel/py3-llfuse \
+ ${PYTHON_PKGNAMEPREFIX}dugong>=0:net/py-dugong \
+ psmisc>=0:sysutils/psmisc \
+ ca_root_nss>=0:security/ca_root_nss
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= localbase python:3.3+ sqlite tar:bz2
+USE_PYTHON= autoplist distutils
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/s3ql/deltadump.so
+
+.include <bsd.port.mk>
diff --git a/net/s3ql/distinfo b/net/s3ql/distinfo
new file mode 100644
index 000000000000..bad923976a82
--- /dev/null
+++ b/net/s3ql/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1490814559
+SHA256 (s3ql-2.21.tar.bz2) = 6db886d9cd0fc54fb7aaf9f88241282097e6242b7a8bd97c6659b0ae57af2ed6
+SIZE (s3ql-2.21.tar.bz2) = 726450
diff --git a/net/s3ql/pkg-descr b/net/s3ql/pkg-descr
new file mode 100644
index 000000000000..57372d76efe1
--- /dev/null
+++ b/net/s3ql/pkg-descr
@@ -0,0 +1,18 @@
+S3QL is a file system that stores all its data online using storage
+services like Google Storage, Amazon S3, or OpenStack. S3QL effectively
+provides a hard disk of dynamic, infinite capacity that can be accessed
+from any computer with internet access running Linux, FreeBSD or OS-X.
+
+S3QL is a standard conforming, full featured UNIX file system that is
+conceptually indistinguishable from any local file system. Furthermore,
+S3QL has additional features like compression, encryption, data
+de-duplication, immutable trees and snapshotting which make it
+especially suitable for online backup and archival.
+
+S3QL is designed to favor simplicity and elegance over performance and
+feature-creep. Care has been taken to make the source code as readable and
+serviceable as possible. Solid error detection and error handling have been
+included from the very first line, and S3QL comes with extensive automated test
+cases for all its components.
+
+WWW: https://bitbucket.org/nikratio/s3ql