aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-05 17:45:36 +0800
committerbapt <bapt@FreeBSD.org>2014-05-05 17:45:36 +0800
commit1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184 (patch)
tree96cc94ba02edcc043c52eb3f26adbc632bbe44d8 /net
parentd8575795a2106dcbddc552f756cb3916f113f9e0 (diff)
downloadfreebsd-ports-gnome-1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184.tar.gz
freebsd-ports-gnome-1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184.tar.zst
freebsd-ports-gnome-1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184.zip
Convert all :U to :tu and :L to :tl
Since FreeBSD 8.4 and FreeBSD 9.1 make(1) do support :tu and :tl as a replacement for :U and :L (which has been marked as deprecated) bmake which is the default on FreeBSD 10+ only support by default :tu/:tl a hack has been added at the time to support :U and :L to ease migration. This hack is now not necessary anymore Note that this makes the ports tree incompatible with make(1) from FreeBSD 8.3 or earlier With hat: portmgr
Diffstat (limited to 'net')
-rw-r--r--net/liveMedia/Makefile4
-rw-r--r--net/mpich/Makefile6
-rw-r--r--net/netcat/Makefile2
-rw-r--r--net/openldap24-server/Makefile4
-rw-r--r--net/py-zsi/Makefile2
-rw-r--r--net/samba4/Makefile2
-rw-r--r--net/samba41/Makefile2
-rw-r--r--net/seda/Makefile4
-rw-r--r--net/udt/files/BSDmakefile2
-rw-r--r--net/wireshark/Makefile8
10 files changed, 18 insertions, 18 deletions
diff --git a/net/liveMedia/Makefile b/net/liveMedia/Makefile
index 16a16d78d2da..a485d5c5051f 100644
--- a/net/liveMedia/Makefile
+++ b/net/liveMedia/Makefile
@@ -21,7 +21,7 @@ WRKSRC= ${WRKDIR}/live
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= genMakefiles
-CONFIGURE_ARGS= fixed-${OPSYS:L}
+CONFIGURE_ARGS= fixed-${OPSYS:tl}
USES= gmake
USE_LDCONFIG= yes
@@ -39,6 +39,6 @@ BROKEN= Does not compile
.endif
post-extract:
- ${CP} ${FILESDIR}/config.fixed-${OPSYS:L} ${WRKSRC}/
+ ${CP} ${FILESDIR}/config.fixed-${OPSYS:tl} ${WRKSRC}/
.include <bsd.port.post.mk>
diff --git a/net/mpich/Makefile b/net/mpich/Makefile
index 9866c37bae63..85fdb76076a3 100644
--- a/net/mpich/Makefile
+++ b/net/mpich/Makefile
@@ -44,11 +44,11 @@ CONFIGURE_ARGS= --with-hwloc-prefix=${LOCALBASE} ac_cv_path_BASH_SHELL=""
.for pm in ${OPTIONS_GROUP_PM}
. if ${PORT_OPTIONS:M${pm}}
. if empty(PMLIST)
-PMLIST= ${pm:L}
+PMLIST= ${pm:tl}
. elif ${PORT_OPTIONS:MD${pm}}
-PMLIST:= ${pm:L},${PMLIST}
+PMLIST:= ${pm:tl},${PMLIST}
. else
-PMLIST:= ${PMLIST},${pm:L}
+PMLIST:= ${PMLIST},${pm:tl}
. endif
. endif
.endfor
diff --git a/net/netcat/Makefile b/net/netcat/Makefile
index a4886a4780a3..643dcf904297 100644
--- a/net/netcat/Makefile
+++ b/net/netcat/Makefile
@@ -25,7 +25,7 @@ GAPING_DESC= Enable GAPING_SECURITY_HOLE support
NO_WRKSUBDIR= yes
-CFLAGS+= -D${OPSYS:U}
+CFLAGS+= -D${OPSYS:tu}
LDFLAGS+= -static
PORTDOCS= README
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index 5dbe9f524913..15f4ad051253 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -429,9 +429,9 @@ CONFIGURE_ARGS+= --enable-spasswd
CONFIGURE_ARGS+= --enable-sql=${BACKEND_ENABLE}
PLIST_SUB+= BACK_SQL=${BACKEND_PLIST}
WITH_ODBC_TYPE?= iODBC
-.if ${WITH_ODBC_TYPE:L} == iodbc
+.if ${WITH_ODBC_TYPE:tl} == iodbc
LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
-.elif ${WITH_ODBC_TYPE:L} == unixodbc
+.elif ${WITH_ODBC_TYPE:tl} == unixodbc
LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
.else
BROKEN= choose either iODBC or unixODBC for WITH_ODBC_TYPE
diff --git a/net/py-zsi/Makefile b/net/py-zsi/Makefile
index 915bfaa4daf9..d20c65fee171 100644
--- a/net/py-zsi/Makefile
+++ b/net/py-zsi/Makefile
@@ -8,7 +8,7 @@ PORTEPOCH= 1
CATEGORIES= net python
MASTER_SITES= SF/pywebsvcs/ZSI/ZSI-${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= ${PORTNAME:U}-${PORTVERSION}
+DISTNAME= ${PORTNAME:tu}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Pure Python module that provides an implementation of SOAP 1.1
diff --git a/net/samba4/Makefile b/net/samba4/Makefile
index c0a329f178bd..ce0cc2f3a8a6 100644
--- a/net/samba4/Makefile
+++ b/net/samba4/Makefile
@@ -362,7 +362,7 @@ CONFIGURE_ARGS+= --bundled-libraries="${SAMBA4_BUNDLED_LIBS:Q:C|(\\\\ )+|,|g:S|\
# XXX
.for m in ${SAMBA4_MODULES}
PLIST_REINPLACE+= ${m}
-PLIST_REINPLACE_${m:U}= s|^@comment ${m} ||g
+PLIST_REINPLACE_${m:tu}= s|^@comment ${m} ||g
.endfor
##############################################################################
# !SAMBA4_SUBPORT
diff --git a/net/samba41/Makefile b/net/samba41/Makefile
index 79d5f55a1585..a8e0beea0629 100644
--- a/net/samba41/Makefile
+++ b/net/samba41/Makefile
@@ -357,7 +357,7 @@ CONFIGURE_ARGS+= --bundled-libraries="${SAMBA4_BUNDLED_LIBS:Q:C|(\\\\ )+|,|g:S|\
# XXX
.for m in ${SAMBA4_MODULES}
PLIST_REINPLACE+= ${m}
-PLIST_REINPLACE_${m:U}= s|^@comment ${m} ||g
+PLIST_REINPLACE_${m:tu}= s|^@comment ${m} ||g
.endfor
##############################################################################
# !SAMBA4_SUBPORT
diff --git a/net/seda/Makefile b/net/seda/Makefile
index 117d6430fea6..673d25bbe013 100644
--- a/net/seda/Makefile
+++ b/net/seda/Makefile
@@ -36,7 +36,7 @@ PORTDOCS= ${DOC_FILES} \
javadoc
PLIST_FILES= \
- %%JAVAJARDIR%%/${PORTNAME:L}.jar
+ %%JAVAJARDIR%%/${PORTNAME:tl}.jar
NO_STAGE= yes
pre-build:
@@ -46,7 +46,7 @@ pre-build:
do-install:
# jar
@${MKDIR} ${JAVAJARDIR}
- @${INSTALL_DATA} ${WRKSRC}/dist/lib/${PORTNAME:L}.jar \
+ @${INSTALL_DATA} ${WRKSRC}/dist/lib/${PORTNAME:tl}.jar \
${JAVAJARDIR}/
# docs
.ifndef(NOPORTDOCS)
diff --git a/net/udt/files/BSDmakefile b/net/udt/files/BSDmakefile
index 1ebebc00aa70..c0d5c5111ca5 100644
--- a/net/udt/files/BSDmakefile
+++ b/net/udt/files/BSDmakefile
@@ -11,7 +11,7 @@ LDADD= -lmd -lpthread
SRCS= common.cpp window.cpp list.cpp buffer.cpp packet.cpp channel.cpp \
queue.cpp ccc.cpp cache.cpp core.cpp epoll.cpp api.cpp
-CXXFLAGS+= -D${MACHINE_ARCH:U:S/I386/IA32/:S/SPARC64/SPARC/} -DBSD
+CXXFLAGS+= -D${MACHINE_ARCH:tu:S/I386/IA32/:S/SPARC64/SPARC/} -DBSD
CXXFLAGS+= -Wno-system-headers -Wall -W \
-Wpointer-arith -Wreturn-type \
-Wwrite-strings -Wswitch -Wno-cast-align \
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index 997e504b901d..d34136bdc988 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -42,12 +42,12 @@ WIRESHARK_LIBS=
.for x in capinfos editcap mergecap rawshark text2pcap dftest randpkt \
reordercap
.if defined(LITE)
-PLIST_SUB+= ${x:U}="@comment $x not installed" \
- ${x:U}_MAN="@comment $x not installed "
+PLIST_SUB+= ${x:tu}="@comment $x not installed" \
+ ${x:tu}_MAN="@comment $x not installed "
CONFIGURE_ARGS+= --enable-$x=no
.else
-PLIST_SUB+= ${x:U}=bin/$x \
- ${x:U}_MAN=""
+PLIST_SUB+= ${x:tu}=bin/$x \
+ ${x:tu}_MAN=""
.endif
.endfor