aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2014-04-22 09:28:18 +0800
committerzi <zi@FreeBSD.org>2014-04-22 09:28:18 +0800
commit2495a90b917782a2fbb614dd84a643ca6245638e (patch)
tree03e74590c7fccbf6dd5be698bf903d7b9439e593 /net
parent486453abccfca4991a8b8dec43cd6f3cd267911c (diff)
downloadfreebsd-ports-gnome-2495a90b917782a2fbb614dd84a643ca6245638e.tar.gz
freebsd-ports-gnome-2495a90b917782a2fbb614dd84a643ca6245638e.tar.zst
freebsd-ports-gnome-2495a90b917782a2fbb614dd84a643ca6245638e.zip
- Pull in fix for p5-Moose warnings
- Pacify portlint(1) - Bump PORTREVISION
Diffstat (limited to 'net')
-rw-r--r--net/p5-Net-Amazon-S3/Makefile5
-rw-r--r--net/p5-Net-Amazon-S3/files/patch-moosefix41
2 files changed, 45 insertions, 1 deletions
diff --git a/net/p5-Net-Amazon-S3/Makefile b/net/p5-Net-Amazon-S3/Makefile
index f0b79658fa80..9b7dafa20bd8 100644
--- a/net/p5-Net-Amazon-S3/Makefile
+++ b/net/p5-Net-Amazon-S3/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Net-Amazon-S3
PORTVERSION= 0.59
+PORTREVISION= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -28,7 +29,6 @@ BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
p5-Test-Pod>=1.14:${PORTSDIR}/devel/p5-Test-Pod \
p5-Test-Pod-Coverage>=1:${PORTSDIR}/devel/p5-Test-Pod-Coverage
@@ -36,4 +36,7 @@ TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
USES= perl5
USE_PERL5= configure
+pre-install:
+ @${FIND} ${WRKSRC} -name \*.orig -delete
+
.include <bsd.port.mk>
diff --git a/net/p5-Net-Amazon-S3/files/patch-moosefix b/net/p5-Net-Amazon-S3/files/patch-moosefix
new file mode 100644
index 000000000000..1456ef7df098
--- /dev/null
+++ b/net/p5-Net-Amazon-S3/files/patch-moosefix
@@ -0,0 +1,41 @@
+diff --git a/lib/Net/Amazon/S3/Client/Object.pm b/lib/Net/Amazon/S3/Client/Object.pm
+index d10cba7..3d70d33 100755
+--- lib/Net/Amazon/S3/Client/Object.pm
++++ lib/Net/Amazon/S3/Client/Object.pm
+@@ -13,7 +13,7 @@ use IO::File 1.14;
+ # ABSTRACT: An easy-to-use Amazon S3 client object
+
+ enum 'AclShort' =>
+- qw(private public-read public-read-write authenticated-read);
++ [ qw(private public-read public-read-write authenticated-read) ];
+
+ has 'client' =>
+ ( is => 'ro', isa => 'Net::Amazon::S3::Client', required => 1 );
+diff --git a/lib/Net/Amazon/S3/HTTPRequest.pm b/lib/Net/Amazon/S3/HTTPRequest.pm
+index 69c6327..eeb9584 100755
+--- lib/Net/Amazon/S3/HTTPRequest.pm
++++ lib/Net/Amazon/S3/HTTPRequest.pm
+@@ -13,7 +13,7 @@ use URI;
+ my $METADATA_PREFIX = 'x-amz-meta-';
+ my $AMAZON_HEADER_PREFIX = 'x-amz-';
+
+-enum 'HTTPMethod' => qw(DELETE GET HEAD PUT POST);
++enum 'HTTPMethod' => [ qw(DELETE GET HEAD PUT POST) ];
+
+ has 's3' => ( is => 'ro', isa => 'Net::Amazon::S3', required => 1 );
+ has 'method' => ( is => 'ro', isa => 'HTTPMethod', required => 1 );
+diff --git a/lib/Net/Amazon/S3/Request.pm b/lib/Net/Amazon/S3/Request.pm
+index 9dded27..0415880 100644
+--- lib/Net/Amazon/S3/Request.pm
++++ lib/Net/Amazon/S3/Request.pm
+@@ -7,8 +7,8 @@ use Regexp::Common qw /net/;
+ # ABSTRACT: Base class for request objects
+
+ enum 'AclShort' =>
+- qw(private public-read public-read-write authenticated-read);
+-enum 'LocationConstraint' => ( 'US', 'EU' );
++ [ qw(private public-read public-read-write authenticated-read) ];
++enum 'LocationConstraint' => [ 'US', 'EU' ];
+
+ # To comply with Amazon S3 requirements, bucket names must:
+ # Contain lowercase letters, numbers, periods (.), underscores (_), and dashes (-)