aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-10-24 04:46:11 +0800
committermarcus <marcus@FreeBSD.org>2003-10-24 04:46:11 +0800
commit290fdb93a32df4d3f7f186f510345059a874cc68 (patch)
tree7f0238e0a619027e0730d2937a49d7bd917265f8 /net
parent57198d603ed60320bb75c84c276c284db318e6a3 (diff)
downloadfreebsd-ports-gnome-290fdb93a32df4d3f7f186f510345059a874cc68.tar.gz
freebsd-ports-gnome-290fdb93a32df4d3f7f186f510345059a874cc68.tar.zst
freebsd-ports-gnome-290fdb93a32df4d3f7f186f510345059a874cc68.zip
* Document two more options available in the Makefile
* Remove the Oscar IP address patch. It does not appear to be needed anymore, and may actually cause breakage Submitted by: Matthew Luckie <mjl@luckie.org.nz>
Diffstat (limited to 'net')
-rw-r--r--net/gaim/Makefile6
-rw-r--r--net/gaim/files/patch-src::protocols::oscar.c19
2 files changed, 4 insertions, 21 deletions
diff --git a/net/gaim/Makefile b/net/gaim/Makefile
index 8e8bed19c42c..dfc077cda9fd 100644
--- a/net/gaim/Makefile
+++ b/net/gaim/Makefile
@@ -6,7 +6,7 @@
PORTNAME= gaim
PORTVERSION= 0.71
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES?= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -116,8 +116,10 @@ pre-everything::
@${ECHO_MSG} " WITHOUT_GTKSPELL Turns off spell checking"
@${ECHO_MSG} " WITHOUT_AUDIO Disable audio support"
@${ECHO_MSG} " WITHOUT_OPENSSL Disable OpenSSL encryption support"
- @${ECHO_MSG} " WITH_GNUTLS Enable TLS encryption support"
+ @${ECHO_MSG} " WITH_GNUTLS Enable GNUTLS encryption support"
+ @${ECHO_MSG} " WITHOUT_GNUTLS Disable GNUTLS encryption support"
@${ECHO_MSG} " WITH_NSS Enable Mozilla NSS encryption support"
+ @${ECHO_MSG} " WITHOUT_NSS Disable Mozilla NSS encryption support"
@${ECHO_MSG} " TCL_VER Use Tcl/Tk (version)"
@${ECHO_MSG} ""
.if !defined(WITH_GNUTLS) && !defined(WITH_NSS) && defined(WITHOUT_OPENSSL)
diff --git a/net/gaim/files/patch-src::protocols::oscar.c b/net/gaim/files/patch-src::protocols::oscar.c
deleted file mode 100644
index 17c6017ccaed..000000000000
--- a/net/gaim/files/patch-src::protocols::oscar.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/protocols/oscar/oscar.c.orig Sat Oct 11 00:10:06 2003
-+++ src/protocols/oscar/oscar.c Sat Oct 11 00:13:51 2003
-@@ -5391,11 +5391,11 @@
- }
-
- if ((bi != NULL) && (bi->ipaddr)) {
-- char *tstr = g_strdup_printf("%hhd.%hhd.%hhd.%hhd",
-- (bi->ipaddr & 0xff000000) >> 24,
-- (bi->ipaddr & 0x00ff0000) >> 16,
-- (bi->ipaddr & 0x0000ff00) >> 8,
-- (bi->ipaddr & 0x000000ff));
-+ char *tstr = g_strdup_printf("%hhu.%hhu.%hhu.%hhu",
-+ (char)(bi->ipaddr >> 24),
-+ (char)(bi->ipaddr >> 16),
-+ (char)(bi->ipaddr >> 8),
-+ (char)bi->ipaddr);
- tmp = ret;
- ret = g_strconcat(tmp, _("<b>IP Address:</b> "), tstr, "\n", NULL);
- g_free(tmp);