aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-02-28 04:21:58 +0800
committermarcus <marcus@FreeBSD.org>2004-02-28 04:21:58 +0800
commit34a495d4ecec6621ce7da215a7c07a6a5db05001 (patch)
tree1066310fd4f92875a81caaecd316815aca2a01d6 /net
parent138df9c59bfdb67834d716fd9986c247dc08a027 (diff)
downloadfreebsd-ports-gnome-34a495d4ecec6621ce7da215a7c07a6a5db05001.tar.gz
freebsd-ports-gnome-34a495d4ecec6621ce7da215a7c07a6a5db05001.tar.zst
freebsd-ports-gnome-34a495d4ecec6621ce7da215a7c07a6a5db05001.zip
The Perl module was broken in gaim since perl.h defined STATIC which
broke the plug-in initialization. To fix this, check for a namespace friendly GAIM_STATIC_PRPL macro definition to decide if we need to build modules statically. Obtained from: GAIM CVS
Diffstat (limited to 'net')
-rw-r--r--net/gaim/Makefile2
-rw-r--r--net/gaim/files/patch-src_plugin.h20
2 files changed, 21 insertions, 1 deletions
diff --git a/net/gaim/Makefile b/net/gaim/Makefile
index 100c251b7e0e..573aec85bf67 100644
--- a/net/gaim/Makefile
+++ b/net/gaim/Makefile
@@ -6,7 +6,7 @@
PORTNAME= gaim
PORTVERSION= 0.75
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES?= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/net/gaim/files/patch-src_plugin.h b/net/gaim/files/patch-src_plugin.h
new file mode 100644
index 000000000000..520ce2ba991f
--- /dev/null
+++ b/net/gaim/files/patch-src_plugin.h
@@ -0,0 +1,20 @@
+--- src/plugin.h.orig Fri Feb 27 15:18:51 2004
++++ src/plugin.h Fri Feb 27 15:19:15 2004
+@@ -117,7 +117,7 @@
+ /**
+ * Handles the initialization of modules.
+ */
+-#if !defined(GAIM_PLUGINS) || defined(STATIC)
++#if !defined(GAIM_PLUGINS) || defined(GAIM_STATIC_PRPL)
+ # define GAIM_INIT_PLUGIN(pluginname, initfunc, plugininfo) \
+ gboolean gaim_init_##pluginname##_plugin(void) { \
+ GaimPlugin *plugin = gaim_plugin_new(TRUE, NULL); \
+@@ -125,7 +125,7 @@
+ initfunc((plugin)); \
+ return gaim_plugin_register(plugin); \
+ }
+-#else /* GAIM_PLUGINS && !STATIC */
++#else /* GAIM_PLUGINS && !GAIM_STATIC_PRPL */
+ # define GAIM_INIT_PLUGIN(pluginname, initfunc, plugininfo) \
+ G_MODULE_EXPORT gboolean gaim_init_plugin(GaimPlugin *plugin) { \
+ plugin->info = &(plugininfo); \