aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2012-11-19 11:21:07 +0800
committerglewis <glewis@FreeBSD.org>2012-11-19 11:21:07 +0800
commit45eee9d5301d18d4fc1b4c2c6905d93e29c32766 (patch)
treed4e2cde5f49cbd194ee416c2cdefaf50c1823508 /net
parent95ae9d6e3ac25aec6c29a471a4b09bc433d5bd30 (diff)
downloadfreebsd-ports-gnome-45eee9d5301d18d4fc1b4c2c6905d93e29c32766.tar.gz
freebsd-ports-gnome-45eee9d5301d18d4fc1b4c2c6905d93e29c32766.tar.zst
freebsd-ports-gnome-45eee9d5301d18d4fc1b4c2c6905d93e29c32766.zip
. Migrate to OptionsNG.
Reminded by: jgh@ Feature safe: yes
Diffstat (limited to 'net')
-rw-r--r--net/dgd/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/net/dgd/Makefile b/net/dgd/Makefile
index 0ff03b9f51f1..a89589586eed 100644
--- a/net/dgd/Makefile
+++ b/net/dgd/Makefile
@@ -15,9 +15,11 @@ COMMENT= Dworkin\'s Game Driver
LICENSE= GPLv3
-OPTIONS= NETWORKING "With networking kfuns" off \
- CLOSURES "With function pointer support" off \
- CPLUSPLUS_COMMENTS "With C++ style comment support" on
+OPTIONS_DEFINE= NETWORKING CLOSURES CPLUSPLUS_COMMENTS
+NETWORKING_DESC=Enable networking kfuns
+CLOSURES_DESC= Enable function pointer support
+CPLUSPLUS_COMMENTS_DESC= Allow C++ style comments in LPC
+OPTIONS_DEFAULT=CPLUSPLUS_COMMENTS
USE_GMAKE= yes
@@ -39,15 +41,15 @@ GROUPS= mud
EXTRA_DEFINES=
-.if defined(WITH_CLOSURES)
+.if ${PORT_OPTIONS:MCLOSURES}
EXTRA_DEFINES+= -DCLOSURES
.endif
-.if defined(WITH_CPLUSPLUS_COMMENTS)
+.if ${PORT_OPTIONS:MCPLUSPLUS_COMMENTS}
EXTRA_DEFINES+= -DSLASHSLASH
.endif
-.if defined(WITH_NETWORKING)
+.if ${PORT_OPTIONS:MNETWORKING}
EXTRA_DEFINES+= -DNETWORK_EXTENSIONS
.endif