aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2003-10-28 21:57:58 +0800
committersergei <sergei@FreeBSD.org>2003-10-28 21:57:58 +0800
commit46e9f8b36a75e4c87db16207b279cece3b897100 (patch)
tree1422b79683a94c25c9b13a770e19dc2b0143eefb /net
parent00b33799d9e6a3c2dcb381750ee813dd4a8f5a47 (diff)
downloadfreebsd-ports-gnome-46e9f8b36a75e4c87db16207b279cece3b897100.tar.gz
freebsd-ports-gnome-46e9f8b36a75e4c87db16207b279cece3b897100.tar.zst
freebsd-ports-gnome-46e9f8b36a75e4c87db16207b279cece3b897100.zip
Add knowlan 0.1, ARP-based LAN IP and MAC Address Extractor.
It sends ARP REQUEST packets to the LAN and waits for ARP REPLY packets from network nodes that are up, producing a table of currently active IP and MAC addresses. Knowlan uses libpcap and libnet libraries for easy source code review and maintenance. WWW: http://www.enderunix.org/knowlan PR: 58592 Submitted by: Omer Faruk Sen <ofsen@enderunix.org> Approved by: krion (implicit)
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/knowlan/Makefile24
-rw-r--r--net/knowlan/distinfo1
-rw-r--r--net/knowlan/files/patch-configure44
-rw-r--r--net/knowlan/pkg-descr8
-rw-r--r--net/knowlan/pkg-plist2
6 files changed, 80 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 4739073a599b..0977928b0a33 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -253,6 +253,7 @@
SUBDIR += kmerlin
SUBDIR += kmess
SUBDIR += kmldonkey
+ SUBDIR += knowlan
SUBDIR += konverse
SUBDIR += kopete
SUBDIR += kpopup
diff --git a/net/knowlan/Makefile b/net/knowlan/Makefile
new file mode 100644
index 000000000000..0ad13a15c0b3
--- /dev/null
+++ b/net/knowlan/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: knowlan
+# Date Created: 2003-10-27
+# Whom: Omer Faruk Sen <ofsen@enderunix.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= knowlan
+PORTVERSION= 0.1
+CATEGORIES= net
+MASTER_SITES= http://www.enderunix.org/knowlan/
+
+MAINTAINER= ofsen@enderunix.org
+COMMENT= ARP-based LAN IP and MAC Address Extractor
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
+
+HAS_CONFIGURE= yes
+CONFIGURE_ENV= PREFIX="${PREFIX}" LOCALBASE="${LOCALBASE}"
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/knowlan ${PREFIX}/sbin
+
+.include <bsd.port.mk>
diff --git a/net/knowlan/distinfo b/net/knowlan/distinfo
new file mode 100644
index 000000000000..c74191e1364c
--- /dev/null
+++ b/net/knowlan/distinfo
@@ -0,0 +1 @@
+MD5 (knowlan-0.1.tar.gz) = 8e64bf32fc721740b4b4548da8fe4f36
diff --git a/net/knowlan/files/patch-configure b/net/knowlan/files/patch-configure
new file mode 100644
index 000000000000..24e1c0ff9df5
--- /dev/null
+++ b/net/knowlan/files/patch-configure
@@ -0,0 +1,44 @@
+--- configure.orig Tue Sep 23 15:43:13 2003
++++ configure Tue Oct 28 16:44:31 2003
+@@ -95,8 +95,8 @@
+ exit
+ fi
+ elif test "$OS" = FreeBSD || test "$OS" = OpenBSD || test "$OS" = NetBSD; then
+- echo -n "testing /usr/local/include/libnet.h..."
+- if(test -f /usr/local/include/libnet.h); then
++ echo -n "testing ${LOCALBASE}/include/libnet.h..."
++ if(test -f ${LOCALBASE}/include/libnet.h); then
+ echo "ok"
+ else
+ exit
+@@ -109,8 +109,8 @@
+
+
+ if test "$OS" = FreeBSD || test "$OS" = OpenBSD || test "$OS" = NetBSD; then
+- echo -n "testing /usr/local/lib/libnet.a..."
+- if(test -f /usr/local/lib/libnet.a); then
++ echo -n "testing ${LOCALBASE}/lib/libnet.a..."
++ if(test -f ${LOCALBASE}/lib/libnet.a); then
+ echo "ok"
+ else
+ echo "can't find required libnet.a static library"
+@@ -152,7 +152,7 @@
+ echo " " >> Makefile
+ echo " " >> Makefile
+ echo "all: kn_arp.c kn_main.c kn_defs.h" >> Makefile
+-echo " gcc -Wall -c kn_main.c" >> Makefile
++echo " gcc ${CFLAGS} -c kn_main.c" >> Makefile
+
+ if test "$OS" = Linux; then
+ echo " gcc -Wall \$(LIBNETDEFS) -c kn_arp.c" >> Makefile
+@@ -164,8 +164,8 @@
+ echo " /bin/chown root.root /usr/sbin/knowlan" >> Makefile
+ echo " /bin/chmod 755 /usr/sbin/knowlan" >> Makefile
+ elif test "$OS" = FreeBSD || test "$OS" = OpenBSD || test "$OS" = NetBSD; then
+- echo " gcc -Wall -D__BSD__=1 -D__GLIBC__=1 -I/usr/local/include/ \$(LIBNETDEFS) -c kn_arp.c" >> Makefile
+- echo " gcc -o knowlan kn_main.o kn_arp.o /usr/local/lib/libnet.a -lpcap" >> Makefile
++ echo " gcc ${CFLAGS} -D__BSD__=1 -D__GLIBC__=1 -I${LOCALBASE}/include/ \$(LIBNETDEFS) -c kn_arp.c" >> Makefile
++ echo " gcc -o knowlan kn_main.o kn_arp.o ${LOCALBASE}/lib/libnet.a -lpcap" >> Makefile
+ echo " " >> Makefile
+ echo " " >> Makefile
+ echo "install: knowlan" >> Makefile
diff --git a/net/knowlan/pkg-descr b/net/knowlan/pkg-descr
new file mode 100644
index 000000000000..a262965e7447
--- /dev/null
+++ b/net/knowlan/pkg-descr
@@ -0,0 +1,8 @@
+Knowlan is ARP-based Local Area Network IP and MAC Address Extractor.
+It sends ARP REQUEST packets to the LAN and waits for ARP REPLY packets
+from network nodes that are up, producing a table of currently
+active IP and MAC addresses.
+Knowlan uses libpcap and libnet libraries for easy source code review
+and maintenance.
+
+WWW: http://www.enderunix.org/knowlan
diff --git a/net/knowlan/pkg-plist b/net/knowlan/pkg-plist
new file mode 100644
index 000000000000..a7989ab26039
--- /dev/null
+++ b/net/knowlan/pkg-plist
@@ -0,0 +1,2 @@
+@comment $FreeBSD$
+sbin/knowlan