aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-10-07 21:11:20 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-10-07 21:11:20 +0800
commit4be5033524f5bf9d22e33d45932e17b1063d91ca (patch)
tree906f4fb766ed2806968ad57c9f2ea72f1a20285a /net
parenta2e72afe5ae66b71f977ec4d78d675d633279fbe (diff)
downloadfreebsd-ports-gnome-4be5033524f5bf9d22e33d45932e17b1063d91ca.tar.gz
freebsd-ports-gnome-4be5033524f5bf9d22e33d45932e17b1063d91ca.tar.zst
freebsd-ports-gnome-4be5033524f5bf9d22e33d45932e17b1063d91ca.zip
- Pet portlint: remove ABI version number from LIB_DEPENDS
- Convert to new options framework - Cleanup Makefile header
Diffstat (limited to 'net')
-rw-r--r--net/tintin++/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/net/tintin++/Makefile b/net/tintin++/Makefile
index ea2da016cf7d..e4466a22ddf9 100644
--- a/net/tintin++/Makefile
+++ b/net/tintin++/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tintin++
-# Date created: 15 Nov 1994
-# Whom: ache
-#
+# Created by: ache
# $FreeBSD$
-#
PORTNAME= tintin++
PORTVERSION= 2.00.8
@@ -17,9 +13,10 @@ COMMENT= A client program to help playing MUDs
LICENSE= GPLv2
-LIB_DEPENDS= pcre.1:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
-OPTIONS= BIG5 "Big5 support" off
+OPTIONS_DEFINE= BIG5 DOCS
+BIG5_DESC= Big5 support
CONFIGURE_ARGS= --includedir=${LOCALBASE}/include \
--libdir=${LOCALBASE}/lib \
@@ -37,7 +34,7 @@ PORTDOCS= ${DOCS:T}
.include <bsd.port.options.mk>
-.if defined(WITH_BIG5)
+.if ${PORT_OPTIONS:MBIG5}
CONFIGURE_ARGS+=--enable-big5
.endif
@@ -46,7 +43,7 @@ post-configure:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tt++ ${PREFIX}/bin/
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${INSTALL} -d ${DOCSDIR}/
cd ${WRKSRC}/../ && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}/
.endif