aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorscheidell <scheidell@FreeBSD.org>2012-02-16 10:32:15 +0800
committerscheidell <scheidell@FreeBSD.org>2012-02-16 10:32:15 +0800
commit4ef64d55a3b45ef774f75cf864739c87ea92e7e9 (patch)
tree8f39bfcbd866d8e1b2d4a5b2c930de7ed17e0cd5 /net
parentfb14d73dc76cb9de0b3f7e2c768a617e1c468344 (diff)
downloadfreebsd-ports-gnome-4ef64d55a3b45ef774f75cf864739c87ea92e7e9.tar.gz
freebsd-ports-gnome-4ef64d55a3b45ef774f75cf864739c87ea92e7e9.tar.zst
freebsd-ports-gnome-4ef64d55a3b45ef774f75cf864739c87ea92e7e9.zip
Add port net/drawterm: a program that users of non-Plan 9 systems can use to establish graphical cpu(1) connections with
Plan 9 CPU servers PR: ports/163886 Submitted by: Winston Weinert <winstonw@lavabit.com> (maintainer) Approved by: gabor (mentor, implicit) Feature safe: Yes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/drawterm/Makefile34
-rw-r--r--net/drawterm/distinfo2
-rw-r--r--net/drawterm/files/patch-Make.pthread22
-rw-r--r--net/drawterm/pkg-descr9
5 files changed, 68 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 4a84e11c26dc..8e6634e7f84d 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -119,6 +119,7 @@
SUBDIR += dimes
SUBDIR += diradmin
SUBDIR += dosdetector
+ SUBDIR += drawterm
SUBDIR += dropbox-api-command
SUBDIR += dtcp
SUBDIR += dtcpclient
diff --git a/net/drawterm/Makefile b/net/drawterm/Makefile
new file mode 100644
index 000000000000..e43ab7879dbd
--- /dev/null
+++ b/net/drawterm/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: drawterm
+# Date created: January 07, 2012
+# Whom: Winston Weinert <winstonw@lavabit.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= drawterm
+PORTVERSION= 20110822
+CATEGORIES= net
+MASTER_SITES= http://swtch.com/drawterm/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= winstonw@lavabit.com
+COMMENT= Plan9 cpu client
+
+USE_XORG= x11 xt
+
+PLIST_FILES= bin/drawterm
+PORTDOCS= LICENSE README
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+MAKE_ARGS= CONF=pthread
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/drawterm ${PREFIX}/bin
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${WRKSRC}/LICENSE ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/drawterm/distinfo b/net/drawterm/distinfo
new file mode 100644
index 000000000000..6345091cb607
--- /dev/null
+++ b/net/drawterm/distinfo
@@ -0,0 +1,2 @@
+SHA256 (drawterm-20110822.tgz) = 457dddbd4719f6de912e06004f1f23136bed5364994904dd4a121d65b7bd1b6e
+SIZE (drawterm-20110822.tgz) = 1191196
diff --git a/net/drawterm/files/patch-Make.pthread b/net/drawterm/files/patch-Make.pthread
new file mode 100644
index 000000000000..d3c7433c9dfa
--- /dev/null
+++ b/net/drawterm/files/patch-Make.pthread
@@ -0,0 +1,22 @@
+--- Make.pthread.orig 2009-08-26 00:44:41.000000000 -0500
++++ Make.pthread 2012-02-15 14:04:26.020899861 -0600
+@@ -4,14 +4,14 @@
+ AR=ar
+ AS=no-as-here
+ RANLIB=ranlib
+-X11=/usr/X11R6
+-CC=gcc
+-CFLAGS=-Wall -Wno-missing-braces -ggdb -I$(ROOT) -I$(ROOT)/include -I$(ROOT)/kern -c -I$(X11)/include -D_THREAD_SAFE $(PTHREAD) -O2
++X11=$(LOCALBASE)
++CC?=cc
++CFLAGS=-Wall -Wno-missing-braces -I$(ROOT) -I$(ROOT)/include -I$(ROOT)/kern -c -I$(X11)/include -D_THREAD_SAFE $(PTHREAD)
+ O=o
+ OS=posix
+ GUI=x11
+-LDADD=-L$(X11)/lib64 -L$(X11)/lib -lX11 -ggdb
+-LDFLAGS=$(PTHREAD)
++LDADD=-L$(X11)/lib64 -L$(X11)/lib -lX11
++LDFLAGS+=$(PTHREAD)
+ TARG=drawterm
+ # AUDIO=none
+ AUDIO=unix
diff --git a/net/drawterm/pkg-descr b/net/drawterm/pkg-descr
new file mode 100644
index 000000000000..f37a7b684bda
--- /dev/null
+++ b/net/drawterm/pkg-descr
@@ -0,0 +1,9 @@
+Drawterm(8) is not a Plan 9 program. It is a program that users of
+non-Plan 9 systems can use to establish graphical cpu(1) connections with
+Plan 9 CPU servers. Just as a real Plan 9 terminal does, drawterm serves
+its local name space as well as some devices (the keyboard, mouse, and
+screen) to a remote CPU server, which mounts this name space on /mnt/term
+and starts a shell. Typically, either explicitly or via the profile, one
+uses the shell to start rio(1).
+
+WWW: http://swtch.com/drawterm/