aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-01-13 09:53:00 +0800
committerwen <wen@FreeBSD.org>2010-01-13 09:53:00 +0800
commit5052e5787c85ea37de617137f8368c769fbb700f (patch)
treee2ee6ed1ccb3562950aff0750bf4c8ff7ee2a1df /net
parenta0b66e3004ee3ea246169bcc372df5d83171c970 (diff)
downloadfreebsd-ports-gnome-5052e5787c85ea37de617137f8368c769fbb700f.tar.gz
freebsd-ports-gnome-5052e5787c85ea37de617137f8368c769fbb700f.tar.zst
freebsd-ports-gnome-5052e5787c85ea37de617137f8368c769fbb700f.zip
- Update to 2.1.4
- Remove unneeded patch
Diffstat (limited to 'net')
-rw-r--r--net/Sockets/Makefile22
-rw-r--r--net/Sockets/distinfo6
-rw-r--r--net/Sockets/files/extra-patch-SocketHandler.h10
-rw-r--r--net/Sockets/files/patch-Makefile25
-rw-r--r--net/Sockets/files/patch-MinderHandler.cpp22
-rw-r--r--net/Sockets/files/patch-Sockets-config.cpp26
-rw-r--r--net/Sockets/pkg-plist26
7 files changed, 50 insertions, 87 deletions
diff --git a/net/Sockets/Makefile b/net/Sockets/Makefile
index c161eb433aab..5087106797b1 100644
--- a/net/Sockets/Makefile
+++ b/net/Sockets/Makefile
@@ -1,18 +1,23 @@
-# New ports collection makefile for: C++ Sockets
-# Date created: Sat Jan 15 16:17:20 UTC 2005
+# New ports collection makefile for: C++ Sockets
+# Date created: Sat Jan 15 16:17:20 UTC 2005
# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= Sockets
-PORTVERSION= 1.8.7
+PORTVERSION= 2.1.4
CATEGORIES= net ipv6
MASTER_SITES= http://www.alhem.net/Sockets/
MAINTAINER= ports@FreeBSD.org
COMMENT= A C++ wrapper for BSD-style sockets
+LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
USE_GMAKE= yes
USE_OPENSSL= yes
WITH_OPENSSL_BASE= yes
@@ -31,12 +36,9 @@ post-patch:
@${FIND} ${WRKSRC} -type f | \
${XARGS} -n 5 -x \
${REINPLACE_CMD} -E \
- -e 's|"StdLog.h"|<StdLog.h>|'
-
-.include <bsd.port.pre.mk>
+ -e 's|"StdLog.h"|<StdLog.h>|'
-.if ${OSVERSION} >= 700042
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-SocketHandler.h
-.endif
+ @${REINPLACE_CMD} -e 's#pthread#(unsigned long)pthread#g' \
+ ${WRKSRC}/Utility.cpp
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/Sockets/distinfo b/net/Sockets/distinfo
index 88b1abeb358d..c5bd39a56620 100644
--- a/net/Sockets/distinfo
+++ b/net/Sockets/distinfo
@@ -1,3 +1,3 @@
-MD5 (Sockets-1.8.7.tar.gz) = 361cc81cb5eaf5aa77a476de827aee80
-SHA256 (Sockets-1.8.7.tar.gz) = 98d0e15f0628b50579374d36de18fd2abc68efeb7004e63dbfd2de48ae7be553
-SIZE (Sockets-1.8.7.tar.gz) = 77760
+MD5 (Sockets-2.1.4.tar.gz) = b58dbe074eeacf2a885914141c9f73a5
+SHA256 (Sockets-2.1.4.tar.gz) = a90d4e1a735f315ad3adde70bf64c67a01ff44687be2b32836dfef51504bb630
+SIZE (Sockets-2.1.4.tar.gz) = 123138
diff --git a/net/Sockets/files/extra-patch-SocketHandler.h b/net/Sockets/files/extra-patch-SocketHandler.h
deleted file mode 100644
index 5fe04cf4ecd6..000000000000
--- a/net/Sockets/files/extra-patch-SocketHandler.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- SocketHandler.h.orig 2008-11-30 02:32:59.000000000 -0200
-+++ SocketHandler.h 2008-11-30 02:33:51.000000000 -0200
-@@ -36,6 +36,7 @@
-
- class SocketHandler
- {
-+protected:
- /** Map type for holding file descriptors/socket object pointers. */
- typedef std::map<SOCKET,Socket *> socket_m;
-
diff --git a/net/Sockets/files/patch-Makefile b/net/Sockets/files/patch-Makefile
index b43c5c0e39e6..63e1a7ab321e 100644
--- a/net/Sockets/files/patch-Makefile
+++ b/net/Sockets/files/patch-Makefile
@@ -1,20 +1,25 @@
---- Makefile.orig Sun Sep 25 02:39:49 2005
-+++ Makefile Sun Sep 25 02:40:28 2005
-@@ -75,13 +75,11 @@
- ranlib $@
+--- Makefile.orig 2010-01-12 15:22:03.000000000 +0800
++++ Makefile 2010-01-12 15:24:19.000000000 +0800
+@@ -70,18 +70,17 @@
- install: all
-- @mkdir -p $(PREFIX)/lib
+ install: all
+ @mkdir -p $(PREFIX)/lib
- cp libSockets.a $(PREFIX)/lib
- cp libSocketsEx.a $(PREFIX)/lib
+ @${BSD_INSTALL_DATA} libSockets.a $(PREFIX)/lib
+ @${BSD_INSTALL_DATA} libSocketsEx.a $(PREFIX)/lib
@mkdir -p $(PREFIX)/include/Sockets
- cp -a *.h $(PREFIX)/include/Sockets
++ @${BSD_INSTALL_DATA} *.h $(PREFIX)/include/Sockets
+ @rm -f $(PREFIX)/include/Sockets/SSLSocket.*
+ @rm -f $(PREFIX)/include/Sockets/HttpsGetSocket.*
+ @rm -f $(PREFIX)/include/Sockets/HttpsSocket.*
+ @rm -f $(PREFIX)/include/Sockets/EventSocket.*
+ @rm -f $(PREFIX)/include/Sockets/PoolSocket.*
+ @rm -f $(PREFIX)/include/Sockets/SocketThread.*
- @mkdir -p $(PREFIX)/bin
- install Sockets-config $(PREFIX)/bin
-+ @${BSD_INSTALL_DATA} *.h $(PREFIX)/include/Sockets
-+ @${BSD_INSTALL_PROGRAM} Sockets-config $(PREFIX)/bin
++ @${BSD_INSTALL_DATA} Sockets-config $(PREFIX)/bin
- clean:
- rm -f *.o *~ slask *.d $(PROGS) *.a */*~
+ # no binary files, zip will translate lf to cr lf
+ FILES = *.h *.cpp Makefile Makefile.* Project/*.ds* \
diff --git a/net/Sockets/files/patch-MinderHandler.cpp b/net/Sockets/files/patch-MinderHandler.cpp
deleted file mode 100644
index e0a6732bb40d..000000000000
--- a/net/Sockets/files/patch-MinderHandler.cpp
+++ /dev/null
@@ -1,22 +0,0 @@
---- MinderHandler.cpp.orig Sun Sep 25 02:40:57 2005
-+++ MinderHandler.cpp Sun Sep 25 02:41:49 2005
-@@ -20,6 +20,10 @@
- along with this program; if not, write to the Free Software
- Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
- */
-+#if (defined(__unix__) || defined(unix)) && !defined(USG)
-+#include <sys/param.h>
-+#endif
-+
- #ifdef _WIN32
- #pragma warning(disable:4786)
- #endif
-@@ -428,6 +432,8 @@
- msg += ":" + tmp;
- #ifdef _WIN32
- msg += ":Win32";
-+#elif defined __FreeBSD__
-+ msg += ":FreeBSD";
- #else
- msg += ":Linux";
- #endif
diff --git a/net/Sockets/files/patch-Sockets-config.cpp b/net/Sockets/files/patch-Sockets-config.cpp
deleted file mode 100644
index f6362cf7c538..000000000000
--- a/net/Sockets/files/patch-Sockets-config.cpp
+++ /dev/null
@@ -1,26 +0,0 @@
---- Sockets-config.cpp.orig Sun Sep 25 02:42:19 2005
-+++ Sockets-config.cpp Sun Sep 25 02:44:08 2005
-@@ -1,8 +1,12 @@
- #include <stdio.h>
- /*
--CFLAGS = -Wall -g -O2 $(INCLUDE) -MD -D_VERSION='"$(VERSION)"'
-+CFLAGS = -Wall -g $(INCLUDE) -MD -D_VERSION='"$(VERSION)"'
- # manual autoconf ....
-
-+#if (defined(__unix__) || defined(unix)) && !defined(USG)
-+#include <sys/param.h>
-+#endif
-+
- # uncomment if your operating system is linux, mac os x, or solaris
- #CFLAGS += -DLINUX
- #CFLAGS += -DMACOSX
-@@ -19,6 +23,9 @@
- printf(" -D_VERSION='\"%s\"'", _VERSION);
- #ifdef LINUX
- printf(" -DLINUX");
-+#endif
-+#if defined __FreeBSD__
-+ printf(" -DFREEBSD");
- #endif
- #ifdef MACOSX
- printf(" -DMACOSX");
diff --git a/net/Sockets/pkg-plist b/net/Sockets/pkg-plist
index 166f5d5e2e8b..e0d2362c8ad9 100644
--- a/net/Sockets/pkg-plist
+++ b/net/Sockets/pkg-plist
@@ -2,8 +2,13 @@ bin/Sockets-config
include/Sockets/Base64.h
include/Sockets/CTcpSocket.h
include/Sockets/CircularBuffer.h
+include/Sockets/Debug.h
+include/Sockets/Event.h
+include/Sockets/EventHandler.h
+include/Sockets/EventTime.h
include/Sockets/File.h
include/Sockets/HTTPSocket.h
+include/Sockets/HttpClientSocket.h
include/Sockets/HttpDebugSocket.h
include/Sockets/HttpGetSocket.h
include/Sockets/HttpPostSocket.h
@@ -11,24 +16,32 @@ include/Sockets/HttpPutSocket.h
include/Sockets/HttpdCookies.h
include/Sockets/HttpdForm.h
include/Sockets/HttpdSocket.h
-include/Sockets/HttpsGetSocket.h
-include/Sockets/HttpsSocket.h
include/Sockets/ICrypt.h
+include/Sockets/IEventHandler.h
+include/Sockets/IEventOwner.h
include/Sockets/IFile.h
+include/Sockets/ISocketHandler.h
+include/Sockets/Ipv4Address.h
+include/Sockets/Ipv6Address.h
include/Sockets/ListenSocket.h
+include/Sockets/Lock.h
include/Sockets/MemFile.h
-include/Sockets/MinderHandler.h
include/Sockets/MinderSocket.h
+include/Sockets/MinderHandler.h
include/Sockets/MinionSocket.h
+include/Sockets/Mutex.h
include/Sockets/NullCrypt.h
+include/Sockets/RandomNumber.h
include/Sockets/Parse.h
-include/Sockets/PoolSocket.h
include/Sockets/ResolvServer.h
include/Sockets/ResolvSocket.h
-include/Sockets/SSLSocket.h
+include/Sockets/SSLInitializer.h
+include/Sockets/SctpSocket.h
+include/Sockets/Semaphore.h
+include/Sockets/SmtpdSocket.h
include/Sockets/Socket.h
+include/Sockets/SocketAddress.h
include/Sockets/SocketHandler.h
-include/Sockets/SocketThread.h
include/Sockets/StdLog.h
include/Sockets/StdoutLog.h
include/Sockets/TcpSocket.h
@@ -37,6 +50,7 @@ include/Sockets/UdpSocket.h
include/Sockets/Uid.h
include/Sockets/Utility.h
include/Sockets/socket_include.h
+include/Sockets/sockets-config.h
lib/libSockets.a
lib/libSocketsEx.a
@dirrm include/Sockets