aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormich <mich@FreeBSD.org>2003-06-04 22:34:24 +0800
committermich <mich@FreeBSD.org>2003-06-04 22:34:24 +0800
commit506cd273a9eda613d37027b294879a69d8e7f813 (patch)
treea8410b2a7c4da82f8a0b121aa0aac55eeec8db6c /net
parent7cf0e3c669f26abf6332a07d3f7ed3270784c8da (diff)
downloadfreebsd-ports-gnome-506cd273a9eda613d37027b294879a69d8e7f813.tar.gz
freebsd-ports-gnome-506cd273a9eda613d37027b294879a69d8e7f813.tar.zst
freebsd-ports-gnome-506cd273a9eda613d37027b294879a69d8e7f813.zip
Unbreak sendip build on -CURRENT.
PR: 52584 Submitted by: maintainer Approved by: roberto (mentor)
Diffstat (limited to 'net')
-rw-r--r--net/sendip/Makefile8
-rw-r--r--net/sendip/files/patch-gnugetopt.c10
2 files changed, 11 insertions, 7 deletions
diff --git a/net/sendip/Makefile b/net/sendip/Makefile
index 76be1bce8c22..c846afd9f6b5 100644
--- a/net/sendip/Makefile
+++ b/net/sendip/Makefile
@@ -13,12 +13,6 @@ MASTER_SITES= http://www.earth.li/projectpurple/files/
MAINTAINER= joseph@randomnetworks.com
COMMENT= SendIP is a commandline tool to allow sending arbitrary IP packets
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
USE_GMAKE= yes
USE_REINPLACE= yes
USE_PERL5= yes
@@ -26,4 +20,4 @@ INSTALLS_SHLIB= yes
MAN1= sendip.1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/sendip/files/patch-gnugetopt.c b/net/sendip/files/patch-gnugetopt.c
new file mode 100644
index 000000000000..65ec257ae5ad
--- /dev/null
+++ b/net/sendip/files/patch-gnugetopt.c
@@ -0,0 +1,10 @@
+--- gnugetopt.c.orig Thu May 22 08:35:25 2003
++++ gnugetopt.c Thu May 22 08:35:37 2003
+@@ -45,6 +45,7 @@
+ #endif
+
+ #include <stdio.h>
++#include <string.h>
+
+ /* Comment out all this code if we are using the GNU C Library, and are not
+ actually compiling the library itself. This code is part of the GNU C