aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2014-06-02 03:20:33 +0800
committerrm <rm@FreeBSD.org>2014-06-02 03:20:33 +0800
commit52d202bfe5ea1feb018d15b2e66c06b5c2e7e63c (patch)
treea21216122187c008ddcb257dfb5824e917df5588 /net
parent2c252202c2237fc3578783974877b8a32fd6ce02 (diff)
downloadfreebsd-ports-gnome-52d202bfe5ea1feb018d15b2e66c06b5c2e7e63c.tar.gz
freebsd-ports-gnome-52d202bfe5ea1feb018d15b2e66c06b5c2e7e63c.tar.zst
freebsd-ports-gnome-52d202bfe5ea1feb018d15b2e66c06b5c2e7e63c.zip
net/spread: fix staging
- fix staging - simplify config samples handling - bump PORTREVISION Submitted by: swills (private email) Approved by: portmgr (blanket)
Diffstat (limited to 'net')
-rw-r--r--net/spread/Makefile3
-rw-r--r--net/spread/pkg-plist9
2 files changed, 5 insertions, 7 deletions
diff --git a/net/spread/Makefile b/net/spread/Makefile
index 39e50c972795..59d2dab755f8 100644
--- a/net/spread/Makefile
+++ b/net/spread/Makefile
@@ -3,7 +3,7 @@
PORTNAME= spread
PORTVERSION= 3.17.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net perl5
MASTER_SITES= http://bsdforge.com/projects/source/apache2/
DISTNAME= ${PORTNAME}-src-${PORTVERSION}
@@ -73,5 +73,6 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/Readme.txt ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/license.txt ${STAGEDIR}${DOCSDIR}/LICENSE
${INSTALL} -m 750 -d ${STAGEDIR}${RUNDIR}
+ ${SED} -i '' 's|^${STAGEDIR}||' ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Spread/.packlist
.include <bsd.port.post.mk>
diff --git a/net/spread/pkg-plist b/net/spread/pkg-plist
index 5ed3fa2d27a5..9128859b542a 100644
--- a/net/spread/pkg-plist
+++ b/net/spread/pkg-plist
@@ -2,12 +2,8 @@ bin/spflooder
bin/spmonitor
bin/sptuser
bin/spuser
-@unexec if cmp -s %D/etc/spread.access_ip.sample %D/etc/spread.access_ip; then rm -f %D/etc/spread.access_ip; fi
-etc/spread.access_ip.sample
-@exec if [ ! -f %D/etc/spread.access_ip ] ; then cp -p %D/%F %B/spread.access_ip; fi
-@unexec if cmp -s %D/etc/spread.conf.sample %D/etc/spread.conf; then rm -f %D/etc/spread.conf; fi
-etc/spread.conf.sample
-@exec if [ ! -f %D/etc/spread.conf ] ; then cp -p %D/%F %B/spread.conf; fi
+@sample etc/spread.access_ip.sample
+@sample etc/spread.conf.sample
include/sp.h
include/sp_events.h
include/sp_func.h
@@ -36,6 +32,7 @@ man/man3/SP_poll.3.gz
man/man3/SP_receive.3.gz
man/man3/SP_scat_multicast.3.gz
man/man3/SP_scat_receive.3.gz
+%%PERL5_MAN3%%/Spread.3.gz
%%SITE_PERL%%/%%PERL_ARCH%%/Spread.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Spread/.packlist
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Spread/Spread.bs