aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2006-04-30 02:41:39 +0800
committermnag <mnag@FreeBSD.org>2006-04-30 02:41:39 +0800
commit5377c4c780e2bfe0e8a298602322de0157902387 (patch)
treeb65b0725913ee670d4f1d18d5d2d17f1b9cd750b /net
parent6d8099225f3f4bf67c88e8f35ffddff4d2094c0b (diff)
downloadfreebsd-ports-gnome-5377c4c780e2bfe0e8a298602322de0157902387.tar.gz
freebsd-ports-gnome-5377c4c780e2bfe0e8a298602322de0157902387.tar.zst
freebsd-ports-gnome-5377c4c780e2bfe0e8a298602322de0157902387.zip
- Patches to make libwrap usage functional
- Bump PORTREVISION - portlint(1) PR: 93708 Submitted by: Rudolf Cejka <cejkar___fit.vutbr.cz> Approved by: maintainer timeout (66 days)
Diffstat (limited to 'net')
-rw-r--r--net/socat/Makefile7
-rw-r--r--net/socat/files/patch-xio-listen.c10
-rw-r--r--net/socat/files/patch-xio-udp.c10
3 files changed, 25 insertions, 2 deletions
diff --git a/net/socat/Makefile b/net/socat/Makefile
index 7b99a6805eae..3c6866b0e3ae 100644
--- a/net/socat/Makefile
+++ b/net/socat/Makefile
@@ -8,6 +8,7 @@
PORTNAME= socat
PORTVERSION= 1.4.3.1
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.dest-unreach.org/socat/download/
@@ -20,9 +21,11 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
MAN1= socat.1
+
.if !defined(NOPORTDOCS)
PORTDOCS= EXAMPLES README SECURITY FAQ
.endif
+
PLIST_FILES= bin/filan bin/procan bin/socat
OPTIONS= SSL "OpenSSL support" on
@@ -36,9 +39,9 @@ OPTIONS= SSL "OpenSSL support" on
CONFIGURE_ARGS+= --disable-openssl
.endif
-.if !defined(NOPORTDOCS)
post-install:
- ${MKDIR} ${DOCSDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
diff --git a/net/socat/files/patch-xio-listen.c b/net/socat/files/patch-xio-listen.c
new file mode 100644
index 000000000000..d9801d4c8842
--- /dev/null
+++ b/net/socat/files/patch-xio-listen.c
@@ -0,0 +1,10 @@
+--- ./xio-listen.c.orig Sun Jan 29 14:33:07 2006
++++ ./xio-listen.c Sat Apr 29 15:33:10 2006
+@@ -311,6 +311,7 @@
+ &ri, xfd->fd, &la->soa, pa, libwrapname);
+ request_init(&ri, RQ_FILE, xfd->fd, RQ_CLIENT_SIN, &la->soa,
+ RQ_SERVER_SIN, pa, RQ_DAEMON, libwrapname, 0);
++ sock_methods(&ri);
+ Debug("request_init() ->");
+
+ Debug1("hosts_access(%p)", &ri);
diff --git a/net/socat/files/patch-xio-udp.c b/net/socat/files/patch-xio-udp.c
new file mode 100644
index 000000000000..8740ba4b128a
--- /dev/null
+++ b/net/socat/files/patch-xio-udp.c
@@ -0,0 +1,10 @@
+--- ./xio-udp.c.orig Sat Apr 29 15:34:17 2006
++++ ./xio-udp.c Sat Apr 29 15:34:32 2006
+@@ -226,6 +226,7 @@
+ &ri, fd->stream.fd, &la->soa, them, libwrapname);
+ request_init(&ri, RQ_FILE, fd->stream.fd, RQ_CLIENT_SIN, &la->soa,
+ RQ_SERVER_SIN, them, RQ_DAEMON, libwrapname, 0);
++ sock_methods(&ri);
+ Debug("request_init() ->");
+
+ Debug1("hosts_access(%p)", &ri);