aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-03-13 14:44:13 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-03-13 14:44:13 +0800
commit6017d55f4089f1b2f9c2b635de4252409e5d915f (patch)
tree0e7c9d0347ad7b1020c40ce92dc4cb31e698ee2c /net
parent838a073a37677a7f3610b4ee1beb40740206a79c (diff)
downloadfreebsd-ports-gnome-6017d55f4089f1b2f9c2b635de4252409e5d915f.tar.gz
freebsd-ports-gnome-6017d55f4089f1b2f9c2b635de4252409e5d915f.tar.zst
freebsd-ports-gnome-6017d55f4089f1b2f9c2b635de4252409e5d915f.zip
- Add p5-Net-HTTPS-NB 0.12
Net::HTTPS::NB provides same interface as Net::HTTPS but it will never try multiple reads when the read_response_headers() or read_entity_body() methods are invoked. In addition allows non-blocking connect. If read_response_headers() did not see enough data to complete the headers an empty list is returned. If read_entity_body() did not see new entity data in its read the value -1 is returned. WWW: http://search.cpan.org/dist/Net-HTTPS-NB/ Feature safe: yes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-HTTPS-NB/Makefile32
-rw-r--r--net/p5-Net-HTTPS-NB/distinfo2
-rw-r--r--net/p5-Net-HTTPS-NB/pkg-descr11
-rw-r--r--net/p5-Net-HTTPS-NB/pkg-plist7
5 files changed, 53 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index c6daa884aa5a..6eca0e2ac6b4 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -572,6 +572,7 @@
SUBDIR += p5-Net-GrowlClient
SUBDIR += p5-Net-HL7
SUBDIR += p5-Net-HTTP
+ SUBDIR += p5-Net-HTTPS-NB
SUBDIR += p5-Net-Hiveminder
SUBDIR += p5-Net-INET6Glue
SUBDIR += p5-Net-IP-Minimal
diff --git a/net/p5-Net-HTTPS-NB/Makefile b/net/p5-Net-HTTPS-NB/Makefile
new file mode 100644
index 000000000000..27affa6ae91c
--- /dev/null
+++ b/net/p5-Net-HTTPS-NB/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Net-HTTPS-NB
+# Date created: 2012-03-13
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-HTTPS-NB
+PORTVERSION= 0.12
+CATEGORIES= net www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Non-blocking HTTPS client
+
+BUILD_DEPENDS= p5-IO-Socket-SSL>=0.98:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ p5-Net-HTTP>=0:${PORTSDIR}/net/p5-Net-HTTP
+RUN_DEPENDS= p5-IO-Socket-SSL>=0.98:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ p5-Net-HTTP>=0:${PORTSDIR}/net/p5-Net-HTTP
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::HTTPS::NB.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-HTTPS-NB/distinfo b/net/p5-Net-HTTPS-NB/distinfo
new file mode 100644
index 000000000000..2c755396e000
--- /dev/null
+++ b/net/p5-Net-HTTPS-NB/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-HTTPS-NB-0.12.tar.gz) = 16c12fc3d6bd957ce8d29896826101f77a8e4711e6cb5e06aec699f2cb6dc575
+SIZE (Net-HTTPS-NB-0.12.tar.gz) = 4808
diff --git a/net/p5-Net-HTTPS-NB/pkg-descr b/net/p5-Net-HTTPS-NB/pkg-descr
new file mode 100644
index 000000000000..ffd0279bb0a3
--- /dev/null
+++ b/net/p5-Net-HTTPS-NB/pkg-descr
@@ -0,0 +1,11 @@
+Net::HTTPS::NB provides same interface as Net::HTTPS but it will never try
+multiple reads when the read_response_headers() or read_entity_body() methods
+are invoked. In addition allows non-blocking connect.
+
+If read_response_headers() did not see enough data to complete the headers an
+empty list is returned.
+
+If read_entity_body() did not see new entity data in its read the value -1 is
+returned.
+
+WWW: http://search.cpan.org/dist/Net-HTTPS-NB/
diff --git a/net/p5-Net-HTTPS-NB/pkg-plist b/net/p5-Net-HTTPS-NB/pkg-plist
new file mode 100644
index 000000000000..84d6b95d71dc
--- /dev/null
+++ b/net/p5-Net-HTTPS-NB/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Net/HTTPS/NB.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/HTTPS/NB/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/HTTPS/NB
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/HTTPS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/HTTPS
+@dirrmtry %%SITE_PERL%%/Net