aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-04-06 03:59:10 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-04-06 03:59:10 +0800
commit68f25c812bcdbbb12729bc03dd920a90fdffc653 (patch)
tree039aed9eb8fb4231eaab45a48d4fc46f3cff121c /net
parente29dd8e91189f859cf0f3e209549a1f68eed6727 (diff)
downloadfreebsd-ports-gnome-68f25c812bcdbbb12729bc03dd920a90fdffc653.tar.gz
freebsd-ports-gnome-68f25c812bcdbbb12729bc03dd920a90fdffc653.tar.zst
freebsd-ports-gnome-68f25c812bcdbbb12729bc03dd920a90fdffc653.zip
Convert to options helper and test framework
Approved by: portmgr (blanket)
Diffstat (limited to 'net')
-rw-r--r--net/rsync/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index 2b4a260cb759..f0ec030e4df9 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -29,6 +29,7 @@ USE_RC_SUBR= rsyncd
SUB_LIST= NAME=rsyncd
INSTALL_TARGET= install-strip
+TEST_TARGET= check
CONFIGURE_ARGS= --disable-debug --enable-ipv6 \
--with-rsyncd-conf=${ETCDIR}/rsyncd.conf
@@ -79,9 +80,14 @@ POPT_PORT_CONFIGURE_OFF= --with-included-popt
SSH_CONFIGURE_ON= --with-rsh=ssh
SSH_CONFIGURE_OFF= --with-rsh=rsh
-.include <bsd.port.options.mk>
+ACL_DISTFILES= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
+ATIMES_DISTFILES= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
+FLAGS_DISTFILES= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
+ICONV_DISTFILES= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
+RENAMED_DISTFILES= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
+TIMELIMIT_DISTFILES= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
-.if ${PORT_OPTIONS:MICONV} || ${PORT_OPTIONS:MFLAGS} || ${PORT_OPTIONS:MACL} || make(makesum) || ${PORT_OPTIONS:MTIMELIMIT} || ${PORT_OPTIONS:MATIMES} || ${PORT_OPTIONS:MRENAMED}
+.if make(makesum)
DISTFILES+= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
.endif
@@ -102,7 +108,4 @@ post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
-test: build
- @(cd ${WRKSRC} && ${MAKE_CMD} check)
-
.include <bsd.port.post.mk>