aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2013-05-25 22:37:02 +0800
committerzeising <zeising@FreeBSD.org>2013-05-25 22:37:02 +0800
commit715298b528f23a6a763e28623a4c98f1365c81ce (patch)
treecf13f962932aab3646f0af684b2923c4e0f0825b /net
parent0f8e632e50d273ba38d9d13f7e446a4a10d95cd4 (diff)
downloadfreebsd-ports-gnome-715298b528f23a6a763e28623a4c98f1365c81ce.tar.gz
freebsd-ports-gnome-715298b528f23a6a763e28623a4c98f1365c81ce.tar.zst
freebsd-ports-gnome-715298b528f23a6a763e28623a4c98f1365c81ce.zip
The FreeBSD x11 team proudly presents
an zeising, kwm, miwi, bapt, eadler production: Xorg 7.7 Starring: xserver 1.12.4 (new xorg only) Mesa 8.0.4, including libGL, libGLU and dri (new xorg only) libX11 1.5.0 libxcb 1.9 libdrm 2.4.42 (new xorg only) freeglut 2.8.1 Also starring: Updates to drivers and other libraries and utilities Additional notes: Change pkgconf to be a build dependency. Add a new USE_XORG, xcb, to depend on libxcb and update all ports to use this. Trim makefile headers. Take maintanership of x11/xcb-proto, ok'd by ashish. If you are running WITH_NEW_XORG=, you need to rebuild all installed drivers, see UPDATING for more information. Various fixes to make ports compile. PR: ports/177942 Exp-run by: miwi Approved by: portmgr (miwi) Thanks to all who helped testing!
Diffstat (limited to 'net')
-rw-r--r--net/tigervnc/Makefile5
-rw-r--r--net/x11vnc/Makefile4
2 files changed, 7 insertions, 2 deletions
diff --git a/net/tigervnc/Makefile b/net/tigervnc/Makefile
index c05dc0c45fac..8860dcd2f1aa 100644
--- a/net/tigervnc/Makefile
+++ b/net/tigervnc/Makefile
@@ -15,7 +15,12 @@ COMMENT= TigerVNC is an advanced VNC implementation
LISENCE= GPLv2
LISENCE_FILE= ${WRKSRC}/LICENCE.TXT
+.if defined(WITH_NEW_XORG)
+BROKEN= Does not build
+.endif
+
PATCH_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/x11-servers/xorg-server:patch
+BUILD_DEPENDS= ${LOCALBASE}/include/GL/internal/dri_interface.h:${PORTSDIR}/graphics/dri
# almost equivalent to x11-servers/xorg-server's
RUN_DEPENDS= ${LOCALBASE}/share/X11/xkb/rules/base:${PORTSDIR}/x11/xkeyboard-config \
xkbcomp:${PORTSDIR}/x11/xkbcomp
diff --git a/net/x11vnc/Makefile b/net/x11vnc/Makefile
index 28b9cd78bba9..da1116fd144e 100644
--- a/net/x11vnc/Makefile
+++ b/net/x11vnc/Makefile
@@ -14,10 +14,10 @@ LICENSE= GPLv2
LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
dbus:${PORTSDIR}/devel/dbus \
- xcb:${PORTSDIR}/x11/libxcb \
pthread-stubs:${PORTSDIR}/devel/libpthread-stubs
-USE_XORG= x11 xdamage xfixes xrandr xinerama xext xtst xau xrender xdmcp recordproto
+USE_XORG= x11 xcb xdamage xfixes xrandr xinerama xext xtst xau xrender \
+ xdmcp recordproto
# Sets LDFLAGS and adds to CONFIGURE_ENV, therefore we set LDFLAGS
LDFLAGS+= -L${LOCALBASE}/lib