aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-11-25 00:10:35 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-11-25 00:10:35 +0800
commit734e1f5e2509451f1f39a279be9b35551424a20e (patch)
treef38938107dc1567963a8e978470c30bd2ac66620 /net
parentf5b2abb7801a6183019f3b0bb7cc2eecc86bcdb3 (diff)
downloadfreebsd-ports-gnome-734e1f5e2509451f1f39a279be9b35551424a20e.tar.gz
freebsd-ports-gnome-734e1f5e2509451f1f39a279be9b35551424a20e.tar.zst
freebsd-ports-gnome-734e1f5e2509451f1f39a279be9b35551424a20e.zip
- Add LICENSE
- Add NO_ARCH - Use DESTDIRNAME - Cosmetic fixes - Regenerate patches
Diffstat (limited to 'net')
-rw-r--r--net/smm++/Makefile17
-rw-r--r--net/smm++/files/patch-Makefile8
2 files changed, 14 insertions, 11 deletions
diff --git a/net/smm++/Makefile b/net/smm++/Makefile
index bbe414991706..fc84e2b59641 100644
--- a/net/smm++/Makefile
+++ b/net/smm++/Makefile
@@ -11,6 +11,9 @@ DISTNAME= smm611
MAINTAINER= ports@FreeBSD.org
COMMENT= Graphical mudclient with mapper
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/../docu/GPL
+
RUN_DEPENDS= iwidgets>0:x11-toolkits/iwidgets
BUILD_DEPENDS= ${LOCALBASE}/lib/libitk.so:x11-toolkits/itk \
${LOCALBASE}/lib/libitcl.so:lang/itcl
@@ -18,16 +21,16 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libitk.so:x11-toolkits/itk \
WRKSRC= ${WRKDIR}/smm/Install.unix
USES= gmake tk tar:tgz
EXTRACT_AFTER_ARGS=--exclude CVS
-
-MAKE_ENV+= STAGEDIR=${STAGEDIR}
+DESTDIRNAME= STAGEDIR
+NO_ARCH= yes
post-patch:
- ${REINPLACE_CMD} -e 's,itkarray=.*,itkarray=${WISH},' ${WRKSRC}/itk.sh
+ @${REINPLACE_CMD} -e 's,itkarray=.*,itkarray=${WISH},' ${WRKSRC}/itk.sh
post-install:
- ${FIND} ${STAGEDIR}${PREFIX}/lib/smm -type f | ${XARGS} \
- ${CHMOD} ${SHAREMODE}
- ${FIND} ${STAGEDIR}${PREFIX}/lib/smm -type d | ${XARGS} \
- ${CHMOD} 755
+ @${FIND} ${STAGEDIR}${PREFIX}/lib/smm -type f | ${XARGS} \
+ ${CHMOD} ${SHAREMODE}
+ @${FIND} ${STAGEDIR}${PREFIX}/lib/smm -type d | ${XARGS} \
+ ${CHMOD} 755
.include <bsd.port.mk>
diff --git a/net/smm++/files/patch-Makefile b/net/smm++/files/patch-Makefile
index abe0a9b273b5..1ff1972bf627 100644
--- a/net/smm++/files/patch-Makefile
+++ b/net/smm++/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2002-05-01 23:15:20.000000000 +0200
-+++ Makefile 2014-01-14 17:56:34.000000000 +0100
+--- Makefile.orig 2002-05-01 21:15:20 UTC
++++ Makefile
@@ -11,8 +11,8 @@
# --- The default settings will install SMM++ nicely into an
@@ -11,7 +11,7 @@
# --- If you don't have root access, you could choose to install
# SMM++ locally in your home directory. Therefore use the
-@@ -58,6 +58,8 @@
+@@ -58,6 +58,8 @@ TROUBLEoptionmenu=0
# this Makefile. If you can read Makefiles, feel free
# to do whatever you like.
@@ -20,7 +20,7 @@
smm: Makefile
@echo "--- Building startup file."
@if [ -z ${ITKWISH} ] ; then \
-@@ -80,18 +82,18 @@
+@@ -80,18 +82,18 @@ install-bin:
@echo "--- Installing startup file to '${BIN}'."
@echo " Please make sure, that '${BIN}' is part of your PATH variable."
@echo " Or start SMM++ with ${BIN}/smm."