aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2006-03-28 01:23:47 +0800
committerfjoe <fjoe@FreeBSD.org>2006-03-28 01:23:47 +0800
commit73616b73cea2716ed4da3ee3390344f330e34a9f (patch)
tree5ffcb19dcaed5458ca9e2065ac07f4798d5f0764 /net
parent97550f7191712244650440b911df408176be1c40 (diff)
downloadfreebsd-ports-gnome-73616b73cea2716ed4da3ee3390344f330e34a9f.tar.gz
freebsd-ports-gnome-73616b73cea2716ed4da3ee3390344f330e34a9f.tar.zst
freebsd-ports-gnome-73616b73cea2716ed4da3ee3390344f330e34a9f.zip
New port: asterisk addons
This package contains additional modules for the Asterisk Open Source PBX which are, for one reason or another, not included in the normal base distribution. Many of these modules are experimental. Submitted by: Fabian Gast
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/asterisk-addons/Makefile38
-rw-r--r--net/asterisk-addons/distinfo3
-rw-r--r--net/asterisk-addons/files/patch-Makefile23
-rw-r--r--net/asterisk-addons/pkg-descr5
-rw-r--r--net/asterisk-addons/pkg-plist11
-rw-r--r--net/asterisk12-addons/Makefile38
-rw-r--r--net/asterisk12-addons/distinfo3
-rw-r--r--net/asterisk12-addons/files/patch-Makefile23
-rw-r--r--net/asterisk12-addons/pkg-descr5
-rw-r--r--net/asterisk12-addons/pkg-plist11
-rw-r--r--net/asterisk14-addons/Makefile38
-rw-r--r--net/asterisk14-addons/distinfo3
-rw-r--r--net/asterisk14-addons/files/patch-Makefile23
-rw-r--r--net/asterisk14-addons/pkg-descr5
-rw-r--r--net/asterisk14-addons/pkg-plist11
-rw-r--r--net/asterisk16-addons/Makefile38
-rw-r--r--net/asterisk16-addons/distinfo3
-rw-r--r--net/asterisk16-addons/files/patch-Makefile23
-rw-r--r--net/asterisk16-addons/pkg-descr5
-rw-r--r--net/asterisk16-addons/pkg-plist11
21 files changed, 321 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index e5db09e4cdac..652beb75d945 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -28,6 +28,7 @@
SUBDIR += asfrecorder
SUBDIR += aslookup
SUBDIR += asterisk
+ SUBDIR += asterisk-addons
SUBDIR += asterisk-devel
SUBDIR += asterisk-oh323
SUBDIR += atmsupport
diff --git a/net/asterisk-addons/Makefile b/net/asterisk-addons/Makefile
new file mode 100644
index 000000000000..5e6173ef5a4a
--- /dev/null
+++ b/net/asterisk-addons/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: asterisk-addons
+# Date created: 23 March 2006
+# Whom: Fabian Gast <fgast@only640k.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= asterisk-addons
+PORTVERSION= 1.2.2
+CATEGORIES= net
+MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
+ http://ftp.digium.com/pub/asterisk/old-releases/ \
+ ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
+ ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
+
+MAINTAINER= fgast@only640k.org
+COMMENT= Additional modules for the Asterisk Open Source PBX
+
+BUILD_DEPENDS= asterisk:${PORTSDIR}/net/asterisk
+LIB_DEPENDS= mysqlclient:${PORTSDIR}/databases/mysql41-client
+RUN_DEPENDS= asterisk:${PORTSDIR}/net/asterisk
+
+ONLY_FOR_ARCHS= i386 sparc64 amd64
+USE_GMAKE= yes
+
+CONF_SAMPLES= cdr_mysql.conf.sample res_mysql.conf.sample
+ASTETCDIR= ${PREFIX}/etc/asterisk
+
+post-patch:
+ @${REINPLACE_CMD} 's,^CFLAGS+=-I../asterisk,CFLAGS+=-I${LOCALBASE}/include,' ${WRKSRC}/Makefile
+
+post-install:
+ ${MKDIR} ${ASTETCDIR}
+.for f in ${CONF_SAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/configs/$f ${ASTETCDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/net/asterisk-addons/distinfo b/net/asterisk-addons/distinfo
new file mode 100644
index 000000000000..7e337e0bace5
--- /dev/null
+++ b/net/asterisk-addons/distinfo
@@ -0,0 +1,3 @@
+MD5 (asterisk-addons-1.2.2.tar.gz) = a22b05117a2f8c8b25d504d0d01f8823
+SHA256 (asterisk-addons-1.2.2.tar.gz) = 9b9681a9b8282604687257cb0468f43d9ab5268622746eae6546cd092ce90c81
+SIZE (asterisk-addons-1.2.2.tar.gz) = 749501
diff --git a/net/asterisk-addons/files/patch-Makefile b/net/asterisk-addons/files/patch-Makefile
new file mode 100644
index 000000000000..cfd4ba9c1c67
--- /dev/null
+++ b/net/asterisk-addons/files/patch-Makefile
@@ -0,0 +1,23 @@
+--- Makefile.orig Fri Dec 2 05:14:28 2005
++++ Makefile Tue Mar 28 00:15:47 2006
+@@ -20,8 +20,8 @@
+ CFLAGS+=-D_GNU_SOURCE
+
+ INSTALL=install
+-INSTALL_PREFIX=
+-ASTLIBDIR=$(INSTALL_PREFIX)/usr/lib/asterisk
++INSTALL_PREFIX=$(PREFIX)
++ASTLIBDIR=$(INSTALL_PREFIX)/lib/asterisk
+ MODULES_DIR=$(ASTLIBDIR)/modules
+
+ #
+@@ -56,7 +56,8 @@
+ $(MAKE) -C format_mp3 all
+
+ install: all
+- for x in $(MODS); do $(INSTALL) -m 755 $$x $(DESTDIR)$(MODULES_DIR) ; done
++ mkdir -p $(DESTDIR)$(MODULES_DIR)
++ for x in $(MODS); do $(BSD_INSTALL_PROGRAM) $$x $(DESTDIR)$(MODULES_DIR) ; done
+
+ clean:
+ rm -f *.so *.o .depend
diff --git a/net/asterisk-addons/pkg-descr b/net/asterisk-addons/pkg-descr
new file mode 100644
index 000000000000..797a19b3c61f
--- /dev/null
+++ b/net/asterisk-addons/pkg-descr
@@ -0,0 +1,5 @@
+This package contains additional modules for the Asterisk Open Source PBX
+which are, for one reason or another, not included in the normal base
+distribution. Many of these modules are experimental.
+
+WWW: http://www.asteriskpbx.com
diff --git a/net/asterisk-addons/pkg-plist b/net/asterisk-addons/pkg-plist
new file mode 100644
index 000000000000..09713ed4936e
--- /dev/null
+++ b/net/asterisk-addons/pkg-plist
@@ -0,0 +1,11 @@
+@unexec if cmp -s %D/etc/asterisk/cdr_mysql.conf %D/etc/asterisk/cdr_mysql.conf.sample; then rm -f %D/etc/asterisk/cdr_mysql.conf; fi
+etc/asterisk/cdr_mysql.conf.sample
+@exec [-f %B/cdr_mysql.conf ] || cp %B/%f %B/cdr_mysql.conf
+@unexec if cmp -s %D/etc/asterisk/res_mysql.conf %D/etc/asterisk/res_mysql.conf.sample; then rm -f %D/etc/asterisk/res_mysql.conf; fi
+etc/asterisk/res_mysql.conf.sample
+@exec [-f %B/res_mysql.conf ] || cp $B/%f %B/res_mysql.conf
+lib/asterisk/modules/app_addon_sql_mysql.so
+lib/asterisk/modules/app_saycountpl.so
+lib/asterisk/modules/cdr_addon_mysql.so
+lib/asterisk/modules/format_mp3.so
+lib/asterisk/modules/res_config_mysql.so
diff --git a/net/asterisk12-addons/Makefile b/net/asterisk12-addons/Makefile
new file mode 100644
index 000000000000..5e6173ef5a4a
--- /dev/null
+++ b/net/asterisk12-addons/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: asterisk-addons
+# Date created: 23 March 2006
+# Whom: Fabian Gast <fgast@only640k.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= asterisk-addons
+PORTVERSION= 1.2.2
+CATEGORIES= net
+MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
+ http://ftp.digium.com/pub/asterisk/old-releases/ \
+ ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
+ ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
+
+MAINTAINER= fgast@only640k.org
+COMMENT= Additional modules for the Asterisk Open Source PBX
+
+BUILD_DEPENDS= asterisk:${PORTSDIR}/net/asterisk
+LIB_DEPENDS= mysqlclient:${PORTSDIR}/databases/mysql41-client
+RUN_DEPENDS= asterisk:${PORTSDIR}/net/asterisk
+
+ONLY_FOR_ARCHS= i386 sparc64 amd64
+USE_GMAKE= yes
+
+CONF_SAMPLES= cdr_mysql.conf.sample res_mysql.conf.sample
+ASTETCDIR= ${PREFIX}/etc/asterisk
+
+post-patch:
+ @${REINPLACE_CMD} 's,^CFLAGS+=-I../asterisk,CFLAGS+=-I${LOCALBASE}/include,' ${WRKSRC}/Makefile
+
+post-install:
+ ${MKDIR} ${ASTETCDIR}
+.for f in ${CONF_SAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/configs/$f ${ASTETCDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/net/asterisk12-addons/distinfo b/net/asterisk12-addons/distinfo
new file mode 100644
index 000000000000..7e337e0bace5
--- /dev/null
+++ b/net/asterisk12-addons/distinfo
@@ -0,0 +1,3 @@
+MD5 (asterisk-addons-1.2.2.tar.gz) = a22b05117a2f8c8b25d504d0d01f8823
+SHA256 (asterisk-addons-1.2.2.tar.gz) = 9b9681a9b8282604687257cb0468f43d9ab5268622746eae6546cd092ce90c81
+SIZE (asterisk-addons-1.2.2.tar.gz) = 749501
diff --git a/net/asterisk12-addons/files/patch-Makefile b/net/asterisk12-addons/files/patch-Makefile
new file mode 100644
index 000000000000..cfd4ba9c1c67
--- /dev/null
+++ b/net/asterisk12-addons/files/patch-Makefile
@@ -0,0 +1,23 @@
+--- Makefile.orig Fri Dec 2 05:14:28 2005
++++ Makefile Tue Mar 28 00:15:47 2006
+@@ -20,8 +20,8 @@
+ CFLAGS+=-D_GNU_SOURCE
+
+ INSTALL=install
+-INSTALL_PREFIX=
+-ASTLIBDIR=$(INSTALL_PREFIX)/usr/lib/asterisk
++INSTALL_PREFIX=$(PREFIX)
++ASTLIBDIR=$(INSTALL_PREFIX)/lib/asterisk
+ MODULES_DIR=$(ASTLIBDIR)/modules
+
+ #
+@@ -56,7 +56,8 @@
+ $(MAKE) -C format_mp3 all
+
+ install: all
+- for x in $(MODS); do $(INSTALL) -m 755 $$x $(DESTDIR)$(MODULES_DIR) ; done
++ mkdir -p $(DESTDIR)$(MODULES_DIR)
++ for x in $(MODS); do $(BSD_INSTALL_PROGRAM) $$x $(DESTDIR)$(MODULES_DIR) ; done
+
+ clean:
+ rm -f *.so *.o .depend
diff --git a/net/asterisk12-addons/pkg-descr b/net/asterisk12-addons/pkg-descr
new file mode 100644
index 000000000000..797a19b3c61f
--- /dev/null
+++ b/net/asterisk12-addons/pkg-descr
@@ -0,0 +1,5 @@
+This package contains additional modules for the Asterisk Open Source PBX
+which are, for one reason or another, not included in the normal base
+distribution. Many of these modules are experimental.
+
+WWW: http://www.asteriskpbx.com
diff --git a/net/asterisk12-addons/pkg-plist b/net/asterisk12-addons/pkg-plist
new file mode 100644
index 000000000000..09713ed4936e
--- /dev/null
+++ b/net/asterisk12-addons/pkg-plist
@@ -0,0 +1,11 @@
+@unexec if cmp -s %D/etc/asterisk/cdr_mysql.conf %D/etc/asterisk/cdr_mysql.conf.sample; then rm -f %D/etc/asterisk/cdr_mysql.conf; fi
+etc/asterisk/cdr_mysql.conf.sample
+@exec [-f %B/cdr_mysql.conf ] || cp %B/%f %B/cdr_mysql.conf
+@unexec if cmp -s %D/etc/asterisk/res_mysql.conf %D/etc/asterisk/res_mysql.conf.sample; then rm -f %D/etc/asterisk/res_mysql.conf; fi
+etc/asterisk/res_mysql.conf.sample
+@exec [-f %B/res_mysql.conf ] || cp $B/%f %B/res_mysql.conf
+lib/asterisk/modules/app_addon_sql_mysql.so
+lib/asterisk/modules/app_saycountpl.so
+lib/asterisk/modules/cdr_addon_mysql.so
+lib/asterisk/modules/format_mp3.so
+lib/asterisk/modules/res_config_mysql.so
diff --git a/net/asterisk14-addons/Makefile b/net/asterisk14-addons/Makefile
new file mode 100644
index 000000000000..5e6173ef5a4a
--- /dev/null
+++ b/net/asterisk14-addons/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: asterisk-addons
+# Date created: 23 March 2006
+# Whom: Fabian Gast <fgast@only640k.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= asterisk-addons
+PORTVERSION= 1.2.2
+CATEGORIES= net
+MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
+ http://ftp.digium.com/pub/asterisk/old-releases/ \
+ ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
+ ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
+
+MAINTAINER= fgast@only640k.org
+COMMENT= Additional modules for the Asterisk Open Source PBX
+
+BUILD_DEPENDS= asterisk:${PORTSDIR}/net/asterisk
+LIB_DEPENDS= mysqlclient:${PORTSDIR}/databases/mysql41-client
+RUN_DEPENDS= asterisk:${PORTSDIR}/net/asterisk
+
+ONLY_FOR_ARCHS= i386 sparc64 amd64
+USE_GMAKE= yes
+
+CONF_SAMPLES= cdr_mysql.conf.sample res_mysql.conf.sample
+ASTETCDIR= ${PREFIX}/etc/asterisk
+
+post-patch:
+ @${REINPLACE_CMD} 's,^CFLAGS+=-I../asterisk,CFLAGS+=-I${LOCALBASE}/include,' ${WRKSRC}/Makefile
+
+post-install:
+ ${MKDIR} ${ASTETCDIR}
+.for f in ${CONF_SAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/configs/$f ${ASTETCDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/net/asterisk14-addons/distinfo b/net/asterisk14-addons/distinfo
new file mode 100644
index 000000000000..7e337e0bace5
--- /dev/null
+++ b/net/asterisk14-addons/distinfo
@@ -0,0 +1,3 @@
+MD5 (asterisk-addons-1.2.2.tar.gz) = a22b05117a2f8c8b25d504d0d01f8823
+SHA256 (asterisk-addons-1.2.2.tar.gz) = 9b9681a9b8282604687257cb0468f43d9ab5268622746eae6546cd092ce90c81
+SIZE (asterisk-addons-1.2.2.tar.gz) = 749501
diff --git a/net/asterisk14-addons/files/patch-Makefile b/net/asterisk14-addons/files/patch-Makefile
new file mode 100644
index 000000000000..cfd4ba9c1c67
--- /dev/null
+++ b/net/asterisk14-addons/files/patch-Makefile
@@ -0,0 +1,23 @@
+--- Makefile.orig Fri Dec 2 05:14:28 2005
++++ Makefile Tue Mar 28 00:15:47 2006
+@@ -20,8 +20,8 @@
+ CFLAGS+=-D_GNU_SOURCE
+
+ INSTALL=install
+-INSTALL_PREFIX=
+-ASTLIBDIR=$(INSTALL_PREFIX)/usr/lib/asterisk
++INSTALL_PREFIX=$(PREFIX)
++ASTLIBDIR=$(INSTALL_PREFIX)/lib/asterisk
+ MODULES_DIR=$(ASTLIBDIR)/modules
+
+ #
+@@ -56,7 +56,8 @@
+ $(MAKE) -C format_mp3 all
+
+ install: all
+- for x in $(MODS); do $(INSTALL) -m 755 $$x $(DESTDIR)$(MODULES_DIR) ; done
++ mkdir -p $(DESTDIR)$(MODULES_DIR)
++ for x in $(MODS); do $(BSD_INSTALL_PROGRAM) $$x $(DESTDIR)$(MODULES_DIR) ; done
+
+ clean:
+ rm -f *.so *.o .depend
diff --git a/net/asterisk14-addons/pkg-descr b/net/asterisk14-addons/pkg-descr
new file mode 100644
index 000000000000..797a19b3c61f
--- /dev/null
+++ b/net/asterisk14-addons/pkg-descr
@@ -0,0 +1,5 @@
+This package contains additional modules for the Asterisk Open Source PBX
+which are, for one reason or another, not included in the normal base
+distribution. Many of these modules are experimental.
+
+WWW: http://www.asteriskpbx.com
diff --git a/net/asterisk14-addons/pkg-plist b/net/asterisk14-addons/pkg-plist
new file mode 100644
index 000000000000..09713ed4936e
--- /dev/null
+++ b/net/asterisk14-addons/pkg-plist
@@ -0,0 +1,11 @@
+@unexec if cmp -s %D/etc/asterisk/cdr_mysql.conf %D/etc/asterisk/cdr_mysql.conf.sample; then rm -f %D/etc/asterisk/cdr_mysql.conf; fi
+etc/asterisk/cdr_mysql.conf.sample
+@exec [-f %B/cdr_mysql.conf ] || cp %B/%f %B/cdr_mysql.conf
+@unexec if cmp -s %D/etc/asterisk/res_mysql.conf %D/etc/asterisk/res_mysql.conf.sample; then rm -f %D/etc/asterisk/res_mysql.conf; fi
+etc/asterisk/res_mysql.conf.sample
+@exec [-f %B/res_mysql.conf ] || cp $B/%f %B/res_mysql.conf
+lib/asterisk/modules/app_addon_sql_mysql.so
+lib/asterisk/modules/app_saycountpl.so
+lib/asterisk/modules/cdr_addon_mysql.so
+lib/asterisk/modules/format_mp3.so
+lib/asterisk/modules/res_config_mysql.so
diff --git a/net/asterisk16-addons/Makefile b/net/asterisk16-addons/Makefile
new file mode 100644
index 000000000000..5e6173ef5a4a
--- /dev/null
+++ b/net/asterisk16-addons/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: asterisk-addons
+# Date created: 23 March 2006
+# Whom: Fabian Gast <fgast@only640k.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= asterisk-addons
+PORTVERSION= 1.2.2
+CATEGORIES= net
+MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
+ http://ftp.digium.com/pub/asterisk/old-releases/ \
+ ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
+ ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
+
+MAINTAINER= fgast@only640k.org
+COMMENT= Additional modules for the Asterisk Open Source PBX
+
+BUILD_DEPENDS= asterisk:${PORTSDIR}/net/asterisk
+LIB_DEPENDS= mysqlclient:${PORTSDIR}/databases/mysql41-client
+RUN_DEPENDS= asterisk:${PORTSDIR}/net/asterisk
+
+ONLY_FOR_ARCHS= i386 sparc64 amd64
+USE_GMAKE= yes
+
+CONF_SAMPLES= cdr_mysql.conf.sample res_mysql.conf.sample
+ASTETCDIR= ${PREFIX}/etc/asterisk
+
+post-patch:
+ @${REINPLACE_CMD} 's,^CFLAGS+=-I../asterisk,CFLAGS+=-I${LOCALBASE}/include,' ${WRKSRC}/Makefile
+
+post-install:
+ ${MKDIR} ${ASTETCDIR}
+.for f in ${CONF_SAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/configs/$f ${ASTETCDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/net/asterisk16-addons/distinfo b/net/asterisk16-addons/distinfo
new file mode 100644
index 000000000000..7e337e0bace5
--- /dev/null
+++ b/net/asterisk16-addons/distinfo
@@ -0,0 +1,3 @@
+MD5 (asterisk-addons-1.2.2.tar.gz) = a22b05117a2f8c8b25d504d0d01f8823
+SHA256 (asterisk-addons-1.2.2.tar.gz) = 9b9681a9b8282604687257cb0468f43d9ab5268622746eae6546cd092ce90c81
+SIZE (asterisk-addons-1.2.2.tar.gz) = 749501
diff --git a/net/asterisk16-addons/files/patch-Makefile b/net/asterisk16-addons/files/patch-Makefile
new file mode 100644
index 000000000000..cfd4ba9c1c67
--- /dev/null
+++ b/net/asterisk16-addons/files/patch-Makefile
@@ -0,0 +1,23 @@
+--- Makefile.orig Fri Dec 2 05:14:28 2005
++++ Makefile Tue Mar 28 00:15:47 2006
+@@ -20,8 +20,8 @@
+ CFLAGS+=-D_GNU_SOURCE
+
+ INSTALL=install
+-INSTALL_PREFIX=
+-ASTLIBDIR=$(INSTALL_PREFIX)/usr/lib/asterisk
++INSTALL_PREFIX=$(PREFIX)
++ASTLIBDIR=$(INSTALL_PREFIX)/lib/asterisk
+ MODULES_DIR=$(ASTLIBDIR)/modules
+
+ #
+@@ -56,7 +56,8 @@
+ $(MAKE) -C format_mp3 all
+
+ install: all
+- for x in $(MODS); do $(INSTALL) -m 755 $$x $(DESTDIR)$(MODULES_DIR) ; done
++ mkdir -p $(DESTDIR)$(MODULES_DIR)
++ for x in $(MODS); do $(BSD_INSTALL_PROGRAM) $$x $(DESTDIR)$(MODULES_DIR) ; done
+
+ clean:
+ rm -f *.so *.o .depend
diff --git a/net/asterisk16-addons/pkg-descr b/net/asterisk16-addons/pkg-descr
new file mode 100644
index 000000000000..797a19b3c61f
--- /dev/null
+++ b/net/asterisk16-addons/pkg-descr
@@ -0,0 +1,5 @@
+This package contains additional modules for the Asterisk Open Source PBX
+which are, for one reason or another, not included in the normal base
+distribution. Many of these modules are experimental.
+
+WWW: http://www.asteriskpbx.com
diff --git a/net/asterisk16-addons/pkg-plist b/net/asterisk16-addons/pkg-plist
new file mode 100644
index 000000000000..09713ed4936e
--- /dev/null
+++ b/net/asterisk16-addons/pkg-plist
@@ -0,0 +1,11 @@
+@unexec if cmp -s %D/etc/asterisk/cdr_mysql.conf %D/etc/asterisk/cdr_mysql.conf.sample; then rm -f %D/etc/asterisk/cdr_mysql.conf; fi
+etc/asterisk/cdr_mysql.conf.sample
+@exec [-f %B/cdr_mysql.conf ] || cp %B/%f %B/cdr_mysql.conf
+@unexec if cmp -s %D/etc/asterisk/res_mysql.conf %D/etc/asterisk/res_mysql.conf.sample; then rm -f %D/etc/asterisk/res_mysql.conf; fi
+etc/asterisk/res_mysql.conf.sample
+@exec [-f %B/res_mysql.conf ] || cp $B/%f %B/res_mysql.conf
+lib/asterisk/modules/app_addon_sql_mysql.so
+lib/asterisk/modules/app_saycountpl.so
+lib/asterisk/modules/cdr_addon_mysql.so
+lib/asterisk/modules/format_mp3.so
+lib/asterisk/modules/res_config_mysql.so