aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordhn <dhn@FreeBSD.org>2009-12-14 01:53:44 +0800
committerdhn <dhn@FreeBSD.org>2009-12-14 01:53:44 +0800
commit7796507a24a0a7e020e1174e170ded6997b521b4 (patch)
tree32e01c7289c24fc5a18ef06933aacf1548eae167 /net
parent1cd8e681dd931436c63a17360b5a799832e9f044 (diff)
downloadfreebsd-ports-gnome-7796507a24a0a7e020e1174e170ded6997b521b4.tar.gz
freebsd-ports-gnome-7796507a24a0a7e020e1174e170ded6997b521b4.tar.zst
freebsd-ports-gnome-7796507a24a0a7e020e1174e170ded6997b521b4.zip
- Fix security bug, see http://forums.humdi.net/viewtopic.php?p=1655#p1655
- Bump PORTREVISION
Diffstat (limited to 'net')
-rw-r--r--net/vnstat/Makefile1
-rw-r--r--net/vnstat/files/patch-src__image.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/net/vnstat/Makefile b/net/vnstat/Makefile
index c8017863de73..b259b26d65cb 100644
--- a/net/vnstat/Makefile
+++ b/net/vnstat/Makefile
@@ -7,6 +7,7 @@
PORTNAME= vnstat
PORTVERSION= 1.9
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://humdi.net/vnstat/ \
http://mirror.mcx2.org/
diff --git a/net/vnstat/files/patch-src__image.c b/net/vnstat/files/patch-src__image.c
new file mode 100644
index 000000000000..95dd6f77270e
--- /dev/null
+++ b/net/vnstat/files/patch-src__image.c
@@ -0,0 +1,11 @@
+--- ./src/image.c.orig 2009-12-13 18:45:05.000000000 +0100
++++ ./src/image.c 2009-12-13 18:45:26.000000000 +0100
+@@ -1398,7 +1398,7 @@
+
+ char *getimagescale(uint64_t kb, int rate)
+ {
+- static char buffer[6];
++ static char buffer[7];
+ uint32_t limit[3];
+ int unit;
+