aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-08-18 14:47:28 +0800
committerijliao <ijliao@FreeBSD.org>2001-08-18 14:47:28 +0800
commit78950e8f1056810543bc154aa9172fa952728864 (patch)
tree4a170aadae911846987d7771335eefb1ca3cfd11 /net
parent6cee97c866785342da3215edd4d5a63f70366ac5 (diff)
downloadfreebsd-ports-gnome-78950e8f1056810543bc154aa9172fa952728864.tar.gz
freebsd-ports-gnome-78950e8f1056810543bc154aa9172fa952728864.tar.zst
freebsd-ports-gnome-78950e8f1056810543bc154aa9172fa952728864.zip
add tvark
GUI network monitoring tool, tied to a MySQL database PR: 29082 Submitted by: Matthew West <mwest@uct.ac.za>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/tvark/Makefile25
-rw-r--r--net/tvark/distinfo1
-rw-r--r--net/tvark/pkg-comment1
-rw-r--r--net/tvark/pkg-descr15
-rw-r--r--net/tvark/pkg-plist3
6 files changed, 46 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 491fe8539c52..babc3ea6ecf6 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -397,6 +397,7 @@
SUBDIR += ttcp
SUBDIR += ttt
SUBDIR += tund
+ SUBDIR += tvark
SUBDIR += unison
SUBDIR += urlendec
SUBDIR += vchat
diff --git a/net/tvark/Makefile b/net/tvark/Makefile
new file mode 100644
index 000000000000..ee629f61b09f
--- /dev/null
+++ b/net/tvark/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: tvark
+# Date created: 19 July 2001
+# Whom: mwest@uct.ac.za
+#
+# $FreeBSD$
+#
+
+PORTNAME= tvark
+PORTVERSION= 0.2
+CATEGORIES= net
+MASTER_SITES= http://www.tvark.com/
+
+MAINTAINER= mwest@uct.ac.za
+
+LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+
+USE_X_PREFIX= yes
+USE_GTK= yes
+
+post-patch:
+ @${PERL} -pi -e "s|/usr/local/bin|${PREFIX}/bin|" ${WRKSRC}/Makefile
+ @${PERL} -pi -e "s|gtk-config|${GTK_CONFIG}|" ${WRKSRC}/Makefile
+ @${PERL} -pi -e "s|-ggdb|${CFLAGS}|" ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/net/tvark/distinfo b/net/tvark/distinfo
new file mode 100644
index 000000000000..c7805b921c7d
--- /dev/null
+++ b/net/tvark/distinfo
@@ -0,0 +1 @@
+MD5 (tvark-0.2.tar.gz) = 491312842a2a8b97e8082d3aa8faf797
diff --git a/net/tvark/pkg-comment b/net/tvark/pkg-comment
new file mode 100644
index 000000000000..baa9f4a61f1c
--- /dev/null
+++ b/net/tvark/pkg-comment
@@ -0,0 +1 @@
+GUI network monitoring tool, tied to a MySQL database
diff --git a/net/tvark/pkg-descr b/net/tvark/pkg-descr
new file mode 100644
index 000000000000..df9dbbb4c383
--- /dev/null
+++ b/net/tvark/pkg-descr
@@ -0,0 +1,15 @@
+Tvark is a network monitoring tool (sniffer) with a GUI front end and
+is tied to a MySQL database. The GUI provides a view of traffic
+activity that can be seen from the machine/interface that Tvark is run
+on. What you see is a list of source nodes on the left, destination
+nodes on the right, and lines drawn, left to right, showing traffic
+flow. Tvark runs in "realtime", meaning you see the traffic roughly
+as it happens. There is a small delay between actual traffic flow and
+the display because buffering of traffic information was necessary to
+be able to determine rate information. The color of the nodes, and
+the lines between them, provide an indication of rate of traffic.
+
+WWW: http://www.tvark.com/
+
+--
+mwest@uct.ac.za
diff --git a/net/tvark/pkg-plist b/net/tvark/pkg-plist
new file mode 100644
index 000000000000..d199fca2301c
--- /dev/null
+++ b/net/tvark/pkg-plist
@@ -0,0 +1,3 @@
+bin/tvark
+bin/tvark-grad.xpm
+bin/tvark-resolver