aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-06-03 01:01:05 +0800
committerbapt <bapt@FreeBSD.org>2012-06-03 01:01:05 +0800
commit7a357b80062e5ab4d94a01bfd4854b13ccf14b66 (patch)
tree64c1b6829fa61c4b75af6834a27a0b3647df1ef2 /net
parentab2c2bc4d9152aaa048966cc98ccf3c29e55f27e (diff)
downloadfreebsd-ports-gnome-7a357b80062e5ab4d94a01bfd4854b13ccf14b66.tar.gz
freebsd-ports-gnome-7a357b80062e5ab4d94a01bfd4854b13ccf14b66.tar.zst
freebsd-ports-gnome-7a357b80062e5ab4d94a01bfd4854b13ccf14b66.zip
Convert to new options framework
Diffstat (limited to 'net')
-rw-r--r--net/libvncserver/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/net/libvncserver/Makefile b/net/libvncserver/Makefile
index 0043dc1983d1..77d3334ca3ad 100644
--- a/net/libvncserver/Makefile
+++ b/net/libvncserver/Makefile
@@ -26,27 +26,29 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --without-x
-OPTIONS= GNUTLS "Adds GnuTLS support" Off \
- OPENSSL "Adds OpenSSL support" on \
- GCRYPT "Adds Libgcrypt support" Off
+OPTIONS_DEFINE= GNUTLS OPENSSL GCRYPT
+OPTIONS_DEFAULT= OPENSSL
+GNUTLS_DESC= Enable GnuTLS support
+OPENSSL_DESC= Enable OpenSSL support
+GCRYPT_DESC= Enable libgcrypt support
.include <bsd.port.options.mk>
-.if defined(WITH_GNUTLS)
+.if ${PORT_OPTIONS:MGNUTLS}
LIB_DEPENDS+= gnutls.47:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+= --with-gnutls
.else
CONFIGURE_ARGS+= --without-gnutls
.endif
-.if defined(WITH_OPENSSL)
+.if ${PORT_OPTIONS:MOPENSSL}
USE_OPENSSL= yes
CONFIGURE_ARGS= --with-ssl
.else
CONFIGURE_ARGS+= --without-crypto --without-ssl
.endif
-.if defined(WITH_GCRYPT)
+.if ${PORT_OPTIONS:MGCRYPT}
LIB_DEPENDS+= gcrypt.18:${PORTSDIR}/security/libgcrypt
CONFIGURE_ARGS+= --with-gcrypt
.else