aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-24 21:12:13 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-24 21:12:13 +0800
commit7ab6130ef8e1f7c6eab90600fed6d7a061307bd8 (patch)
tree5f487bd5d78ad6f504e95d66102e71645d77628a /net
parenteaa323871a340faccaa35bc1fb5b45363acb5448 (diff)
downloadfreebsd-ports-gnome-7ab6130ef8e1f7c6eab90600fed6d7a061307bd8.tar.gz
freebsd-ports-gnome-7ab6130ef8e1f7c6eab90600fed6d7a061307bd8.tar.zst
freebsd-ports-gnome-7ab6130ef8e1f7c6eab90600fed6d7a061307bd8.zip
Support staging
Diffstat (limited to 'net')
-rw-r--r--net/bounce/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/net/bounce/Makefile b/net/bounce/Makefile
index aaacdb2ea7c5..47e51ce2386e 100644
--- a/net/bounce/Makefile
+++ b/net/bounce/Makefile
@@ -19,15 +19,14 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PLIST_FILES= sbin/bounce
-NO_STAGE= yes
do-extract:
@${MKDIR} ${WRKSRC}
@${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}
do-build:
- (cd ${WRKSRC} && ${CC} ${CFLAGS} -o ${DISTNAME} ${DISTNAME}.c)
+ ${CC} ${CFLAGS} -o ${WRKSRC}/${DISTNAME} ${WRKSRC}/${DISTNAME}.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${DISTNAME} ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${DISTNAME} ${STAGEDIR}${PREFIX}/sbin
.include <bsd.port.mk>