aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-10-09 16:01:45 +0800
committerclsung <clsung@FreeBSD.org>2006-10-09 16:01:45 +0800
commit7ddedb44541cdb040bfdf8bdf5514478500567c4 (patch)
treeb6f35484af0e4ec4f0593b0eff26f336a7311cc6 /net
parenta155036da075f483b4ccb9b3b4a0192375250114 (diff)
downloadfreebsd-ports-gnome-7ddedb44541cdb040bfdf8bdf5514478500567c4.tar.gz
freebsd-ports-gnome-7ddedb44541cdb040bfdf8bdf5514478500567c4.tar.zst
freebsd-ports-gnome-7ddedb44541cdb040bfdf8bdf5514478500567c4.zip
Add p5-Net-Amazon-S3 0.36, use the Amazon S3 - Simple Storage Service.
PR: ports/104138 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-Amazon-S3/Makefile40
-rw-r--r--net/p5-Net-Amazon-S3/distinfo3
-rw-r--r--net/p5-Net-Amazon-S3/pkg-descr3
-rw-r--r--net/p5-Net-Amazon-S3/pkg-plist8
5 files changed, 55 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 5e72f0cf030d..d2b579da8812 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -421,6 +421,7 @@
SUBDIR += p5-Net-Address-Ethernet
SUBDIR += p5-Net-Address-IPv4-Local
SUBDIR += p5-Net-Amazon
+ SUBDIR += p5-Net-Amazon-S3
SUBDIR += p5-Net-Analysis
SUBDIR += p5-Net-BGP
SUBDIR += p5-Net-Blogger
diff --git a/net/p5-Net-Amazon-S3/Makefile b/net/p5-Net-Amazon-S3/Makefile
new file mode 100644
index 000000000000..a0a590232cdf
--- /dev/null
+++ b/net/p5-Net-Amazon-S3/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: p5-Net-Amazon-S3
+# Date created: 2006-10-08
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Amazon-S3
+PORTVERSION= 0.36
+CATEGORIES= net
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Use the Amazon S3 - Simple Storage Service
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
+ ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/DateTime/Format/Strptime.pm:${PORTSDIR}/devel/p5-DateTime-Format-Strptime \
+ ${SITE_PERL}/Digest/HMAC_SHA1.pm:${PORTSDIR}/security/p5-Digest-HMAC \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Amazon::S3.3 Net::Amazon::S3::Bucket.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # Inherited from www/p5-libwww
+IGNORE= requires Perl 5.6 or later. Install lang/perl5.8 and try again
+.endif
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-Amazon-S3/distinfo b/net/p5-Net-Amazon-S3/distinfo
new file mode 100644
index 000000000000..227816328620
--- /dev/null
+++ b/net/p5-Net-Amazon-S3/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Amazon-S3-0.36.tar.gz) = 296bb9cf759a9bda49d6758ec22bdd8f
+SHA256 (Net-Amazon-S3-0.36.tar.gz) = aa57287a9120a1a43c2e1cbb99b34c8ae43b78246fb94fee80a8cf548d72ec38
+SIZE (Net-Amazon-S3-0.36.tar.gz) = 14808
diff --git a/net/p5-Net-Amazon-S3/pkg-descr b/net/p5-Net-Amazon-S3/pkg-descr
new file mode 100644
index 000000000000..becc87cc7958
--- /dev/null
+++ b/net/p5-Net-Amazon-S3/pkg-descr
@@ -0,0 +1,3 @@
+This module provides a Perlish interface to Amazon S3.
+
+WWW: http://search.cpan.org/dist/Net-Amazon-S3/
diff --git a/net/p5-Net-Amazon-S3/pkg-plist b/net/p5-Net-Amazon-S3/pkg-plist
new file mode 100644
index 000000000000..aa94437a4c2d
--- /dev/null
+++ b/net/p5-Net-Amazon-S3/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Amazon/S3/.packlist
+%%SITE_PERL%%/Net/Amazon/S3.pm
+%%SITE_PERL%%/Net/Amazon/S3/Bucket.pm
+@dirrmtry %%SITE_PERL%%/Net/Amazon/S3
+@dirrmtry %%SITE_PERL%%/Net/Amazon
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Amazon/S3
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Amazon