aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-09-27 23:42:54 +0800
committergarga <garga@FreeBSD.org>2005-09-27 23:42:54 +0800
commit8ba3623fda4ceeccb2ded97c2c2e15557f7c54a4 (patch)
tree92276693414e3a025f2ff2896de26ef312e93fea /net
parent7a395b55ebca65ff8786668be9a77f869a2c2192 (diff)
downloadfreebsd-ports-gnome-8ba3623fda4ceeccb2ded97c2c2e15557f7c54a4.tar.gz
freebsd-ports-gnome-8ba3623fda4ceeccb2ded97c2c2e15557f7c54a4.tar.zst
freebsd-ports-gnome-8ba3623fda4ceeccb2ded97c2c2e15557f7c54a4.zip
Add recvnet 0.0.1, recvnet (inverse telnet) is a utility for debugging
tcp connections. PR: ports/86633 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/recvnet/Makefile30
-rw-r--r--net/recvnet/distinfo2
-rw-r--r--net/recvnet/pkg-descr8
4 files changed, 41 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 6375f23f7cb9..0970f0b950b5 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -713,6 +713,7 @@
SUBDIR += rboot
SUBDIR += rdesktop
SUBDIR += rdist6
+ SUBDIR += recvnet
SUBDIR += redir
SUBDIR += relay
SUBDIR += rexx-sock
diff --git a/net/recvnet/Makefile b/net/recvnet/Makefile
new file mode 100644
index 000000000000..3204d1bcd868
--- /dev/null
+++ b/net/recvnet/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: recvnet
+# Date created: 27 Sep 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= recvnet
+PORTVERSION= 0.0.1
+CATEGORIES= net
+MASTER_SITES= http://www.vanheusden.com/Linux/ \
+ http://critical.ch/distfiles/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= Recvnet (inverse telnet) is a utility for debugging tcp connections
+
+CFLAGS+= -DVERSION=\"${PORTVERSION}\"
+LDFLAGS+= -lcurses
+
+PLIST_FILES= bin/recvnet
+
+do-build:
+ ${CC} ${CFLAGS} -c ${WRKSRC}/${PORTNAME}.c -o ${WRKSRC}/${PORTNAME}.o
+ ${CC} ${LDFLAGS} ${WRKSRC}/${PORTNAME}.o -o ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/recvnet/distinfo b/net/recvnet/distinfo
new file mode 100644
index 000000000000..1e56a2dbe942
--- /dev/null
+++ b/net/recvnet/distinfo
@@ -0,0 +1,2 @@
+MD5 (recvnet-0.0.1.tgz) = d8d52cc17ffc1288316ac54ca2bf5d0e
+SIZE (recvnet-0.0.1.tgz) = 2116
diff --git a/net/recvnet/pkg-descr b/net/recvnet/pkg-descr
new file mode 100644
index 000000000000..03f273ce5408
--- /dev/null
+++ b/net/recvnet/pkg-descr
@@ -0,0 +1,8 @@
+Recvnet is the inverse of telnet. Instead of connecting to some host,
+it listens on a port for incoming connections. When a connection is made,
+you can type a response which will be sent to the client.
+
+This tool has proven to be very useful while debugging Web browsers, httping,
+and others.
+
+WWW: http://www.vanheusden.com/Linux/#recvnet