aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-03-20 22:20:32 +0800
committermiwi <miwi@FreeBSD.org>2010-03-20 22:20:32 +0800
commit8f8385125ddfcf06ce4371ad8f512aeeedb0bccb (patch)
tree0d81245af6ff3929205cda3b458d31553bfe62f4 /net
parentb9ef8a77931f95fa56367fa0285966fc0082055d (diff)
downloadfreebsd-ports-gnome-8f8385125ddfcf06ce4371ad8f512aeeedb0bccb.tar.gz
freebsd-ports-gnome-8f8385125ddfcf06ce4371ad8f512aeeedb0bccb.tar.zst
freebsd-ports-gnome-8f8385125ddfcf06ce4371ad8f512aeeedb0bccb.zip
- Mark BROKEN on HEAD: fails to build with new utmpx
Reported by: pointyhat
Diffstat (limited to 'net')
-rw-r--r--net/clusterit/Makefile8
-rw-r--r--net/fspclient/Makefile8
-rw-r--r--net/fspd/Makefile4
3 files changed, 18 insertions, 2 deletions
diff --git a/net/clusterit/Makefile b/net/clusterit/Makefile
index cb19d5b85855..3c22b9b4bfea 100644
--- a/net/clusterit/Makefile
+++ b/net/clusterit/Makefile
@@ -18,6 +18,12 @@ GNU_CONFIGURE= yes
MAN1= barrier.1 barrierd.1 clustersed.1 dsh.1 dshbak.1 \
dtop.1 jsh.1 jsd.1 pcp.1 pdf.1 prm.1 rseq.1 run.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
.if defined (WITHOUT_X11)
PLIST_SUB+= X11='@comment '
.else
@@ -31,4 +37,4 @@ post-patch:
${REINPLACE_CMD} -E 's,^(SUBDIRS) = .*,\1 = barrier dsh jsd pcp dtop tools,' ${WRKSRC}/Makefile.in
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/fspclient/Makefile b/net/fspclient/Makefile
index e39fa26e5bf5..e49cacc184bc 100644
--- a/net/fspclient/Makefile
+++ b/net/fspclient/Makefile
@@ -21,4 +21,10 @@ MAN1= fsp.1
MANCOMPRESSED= yes
PLIST_FILES= bin/fsp
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/fspd/Makefile b/net/fspd/Makefile
index 0fb89e11d8af..ca91d84c7979 100644
--- a/net/fspd/Makefile
+++ b/net/fspd/Makefile
@@ -43,6 +43,10 @@ OPTIONS= NOCLIENTS "Omit client commands" off \
.include <bsd.port.pre.mk>
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
.if defined(WITH_INFINITE)
SCONS_ARGS+= disable-timeout=yes
.endif