aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-03-14 14:19:43 +0800
committerpat <pat@FreeBSD.org>2002-03-14 14:19:43 +0800
commit949ccf1388bba6b7de8083436824a1eb5b1f7bc5 (patch)
treede59864273b757890af371654e7b2ebeea7e6045 /net
parent328e00d46c4fbf1168b57e06902be42d117ee25d (diff)
downloadfreebsd-ports-gnome-949ccf1388bba6b7de8083436824a1eb5b1f7bc5.tar.gz
freebsd-ports-gnome-949ccf1388bba6b7de8083436824a1eb5b1f7bc5.tar.zst
freebsd-ports-gnome-949ccf1388bba6b7de8083436824a1eb5b1f7bc5.zip
Correct include and lib paths
PR: 35847 Submitted by: maintainer
Diffstat (limited to 'net')
-rw-r--r--net/gnu-radius/Makefile3
-rw-r--r--net/gnu-radius/Makefile.inc5
-rw-r--r--net/gnu-radius/scripts/configure2
3 files changed, 4 insertions, 6 deletions
diff --git a/net/gnu-radius/Makefile b/net/gnu-radius/Makefile
index da8c3ed333f7..8086c4b572c9 100644
--- a/net/gnu-radius/Makefile
+++ b/net/gnu-radius/Makefile
@@ -16,7 +16,8 @@ MAINTAINER= lance@evitel.net
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-include-path="${PREFIX}"
+CONFIGURE_ARGS= --with-include-path="${LOCALBASE}/include/" \
+ --with-lib-path="${LOCALBASE}/lib/"
MAN1= radgrep.1 radlast.1 raduse.1 radwho.1
MAN8= builddbm.8 radctl.8 radiusd.8 radping.8 radzap.8
diff --git a/net/gnu-radius/Makefile.inc b/net/gnu-radius/Makefile.inc
deleted file mode 100644
index 25ba22cfd95a..000000000000
--- a/net/gnu-radius/Makefile.inc
+++ /dev/null
@@ -1,5 +0,0 @@
-CONFIGURE_ARGS+= --with-client
-LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client:install
-CONFIGURE_ARGS+= --with-mysql
-CONFIGURE_ARGS+= --enable-snmp
-BUILD_DEPENDS+= guile:${PORTSDIR}/lang/guile
diff --git a/net/gnu-radius/scripts/configure b/net/gnu-radius/scripts/configure
index cb41950eaf8f..dbfb5a312f20 100644
--- a/net/gnu-radius/scripts/configure
+++ b/net/gnu-radius/scripts/configure
@@ -52,10 +52,12 @@ while [ "$1" ]; do
\"MySQL\")
echo "LIB_DEPENDS+= mysqlclient.10:\${PORTSDIR}/databases/mysql323-client:install"
echo "CONFIGURE_ARGS+= --with-mysql"
+ echo "CONFIGURE_ARGS+= --with-lib-path=${LOCALBASE}/lib/mysql/"
;;
\"PostgreSQL\")
echo "LIB_DEPENDS+= pq.2:\${PORTSDIR}/databases/postgresql7:install"
echo "CONFIGURE_ARGS+= --with-postgres"
+ echo "CONFIGURE_ARGS+= --with-include-path=${LOCALBASE}/include/pgsql/"
;;
\"SNMP\")
echo "CONFIGURE_ARGS+= --enable-snmp"