aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2012-01-21 05:25:59 +0800
committernetchild <netchild@FreeBSD.org>2012-01-21 05:25:59 +0800
commit96ab6bbaff8c8b317fec81eb93cb9ee4404d0b65 (patch)
tree338409df5fb68989b7c77a3b0a991b805e573e19 /net
parent833a60d71650d8300db9ce029c4433d6601d6c24 (diff)
downloadfreebsd-ports-gnome-96ab6bbaff8c8b317fec81eb93cb9ee4404d0b65.tar.gz
freebsd-ports-gnome-96ab6bbaff8c8b317fec81eb93cb9ee4404d0b65.tar.zst
freebsd-ports-gnome-96ab6bbaff8c8b317fec81eb93cb9ee4404d0b65.zip
This a port of the nss_ldap libraries for linux.
You'll probably need this if your system users in a LDAP directory are complaining their linux programs won't run, and errors on the console say "getpwuid_r(): failed due to unknown user id". PR: ports/164113 Submitted by: rskinner port_maintainer@herveybayaustralia.com.au Minor modifications (no license install, srpm checksum) by: netchild Note: the license framework does not seem to DTRT with linux ports
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/linux-f10-nss_ldap/Makefile78
-rw-r--r--net/linux-f10-nss_ldap/distinfo.i3864
-rw-r--r--net/linux-f10-nss_ldap/pkg-descr6
-rw-r--r--net/linux-f10-nss_ldap/pkg-message6
-rw-r--r--net/linux-f10-nss_ldap/pkg-plist5
6 files changed, 100 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index fe13e1731fbb..1dce08377a06 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -344,6 +344,7 @@
SUBDIR += linneighborhood
SUBDIR += linphone
SUBDIR += linphone-base
+ SUBDIR += linux-f10-nss_ldap
SUBDIR += linux-f10-openldap
SUBDIR += linux-nx-client
SUBDIR += linuxigd
diff --git a/net/linux-f10-nss_ldap/Makefile b/net/linux-f10-nss_ldap/Makefile
new file mode 100644
index 000000000000..9d6626aa4f68
--- /dev/null
+++ b/net/linux-f10-nss_ldap/Makefile
@@ -0,0 +1,78 @@
+# New ports collection makefile for: linux-f10-nss_ldap
+# Date created: 2012-01-04
+# Whom: rskinner port_maintainer@herveybayaustralia.com.au
+#
+# $FreeBSD$
+#
+
+PORTNAME= nss_ldap
+PORTVERSION= ${NSS_LDAP_VERSION}
+CATEGORIES= net linux
+MASTER_SITES= ftp://ftp.pbone.net/mirror/archive.fedoraproject.org/fedora/linux/updates/testing/10/i386/ \
+ http://archives.fedoraproject.org/pub/archive/fedora/linux/updates/testing/10/i386/ \
+ http://herveybayaustralia.com.au/ports/distfiles/
+PKGNAMEPREFIX= linux-f10-
+DISTNAME= ${PORTNAME}-${NSS_LDAP_VERSION}-${RPMVERSION}
+
+MAINTAINER= port_maintainer@herveybayaustralia.com.au
+COMMENT= RFC 2307 NSS Module (Linux Fedora 10)
+
+LICENSE= GPLv2
+NO_LICENSES_INSTALL=yes # license framework does not rm the "share" directory
+
+NSS_LDAP_VERSION=264
+
+USE_LINUX_RPM= yes
+USE_LINUX_PREFIX=yes
+LINUX_DIST_VER= 10
+RPMVERSION= 6.fc10
+USE_LDCONFIG= yes
+
+DOCSDIR= ${PREFIX}/usr/share/doc/${PORTNAME}-${NSS_LDAP_VERSION}
+
+MANPREFIX= ${PREFIX}/usr/share
+MANCOMPRESSED= no
+MAN5= nss_ldap.5.gz
+
+.if defined(WITH_PAM)
+PLIST_SUB+= PAM=""
+MAN5+= pam_ldap.5.gz
+.else
+PLIST_SUB+= PAM="@comment "
+.endif
+
+PORTDOCS=*
+
+pre-fetch:
+.if !defined(WITH_PAM)
+ @${ECHO_MSG} "Use WITH_PAM if you require more advanced ldap support in the linuxulator"
+.endif
+
+post-extract:
+ @if [ -f ${WRKDIR}/etc/ldap.conf ]; then \
+ ${MV} ${WRKDIR}/etc/ldap.conf ${WRKDIR}/etc/ldap.conf.dist; \
+ fi
+.if !defined(WITH_PAM)
+ @if [ -f ${WRKDIR}/lib/security/pam_ldap.so ]; then \
+ ${RM} -rf ${WRKDIR}/lib/; \
+ fi
+ @if [ -f ${WRKDIR}/usr/share/doc/nss_ldap-264/COPYING.pam_ldap ]; then \
+ ${RM} ${WRKDIR}/usr/share/doc/nss_ldap-264/*.pam*; \
+ ${RM} -rf ${WRKDIR}/usr/share/doc/nss_ldap-264/pam.d; \
+ fi
+ @if [ -f ${WRKDIR}/usr/share/man/man5/pam_ldap.5.gz ]; then \
+ ${RM} ${WRKDIR}/usr/share/man/man5/pam_ldap.5.gz; \
+ fi
+.else
+.if defined(NOPORTDOCS)
+ @if [ -d ${WRKDIR}/usr/share/doc/nss_ldap-264/pam.d ]; then \
+ ${RM} -rf ${WRKDIR}/usr/share/doc/nss_ldap-264/pam.d/; \
+ fi
+.endif
+.endif
+
+post-install:
+ @${RM} ${PREFIX}/GPLv2 # somehow installed by LICENSE framework
+ @${CAT} ${PKGMESSAGE};
+
+.include <bsd.port.mk>
diff --git a/net/linux-f10-nss_ldap/distinfo.i386 b/net/linux-f10-nss_ldap/distinfo.i386
new file mode 100644
index 000000000000..e506f07601a4
--- /dev/null
+++ b/net/linux-f10-nss_ldap/distinfo.i386
@@ -0,0 +1,4 @@
+SHA256 (rpm/i386/fedora/10/nss_ldap-264-6.fc10.i386.rpm) = 38fa8ac3fd79e15b0dde58f6a105e115ab5ba1166109b60ecd6b7905effaad3b
+SIZE (rpm/i386/fedora/10/nss_ldap-264-6.fc10.i386.rpm) = 721887
+SHA256 (rpm/i386/fedora/10/nss_ldap-264-6.fc10.src.rpm) = ea0a99777950996514709abc9a4927a1e470a9e31d171df9ee86fea601376882
+SIZE (rpm/i386/fedora/10/nss_ldap-264-6.fc10.src.rpm) = 463793
diff --git a/net/linux-f10-nss_ldap/pkg-descr b/net/linux-f10-nss_ldap/pkg-descr
new file mode 100644
index 000000000000..692209472daf
--- /dev/null
+++ b/net/linux-f10-nss_ldap/pkg-descr
@@ -0,0 +1,6 @@
+This a port of the nss_ldap libraries for linux.
+
+You'll probably need this if your system users in a LDAP
+directory are complaining their linux programs won't run,
+and errors on the console say "getpwuid_r(): failed due
+to unknown user id".
diff --git a/net/linux-f10-nss_ldap/pkg-message b/net/linux-f10-nss_ldap/pkg-message
new file mode 100644
index 000000000000..67abea657353
--- /dev/null
+++ b/net/linux-f10-nss_ldap/pkg-message
@@ -0,0 +1,6 @@
+###########################################################################
+
+At a minimum you need to link your ldap.conf to /compat/linux/etc/ or set
+/compat/linux/etc/ldap.conf to suit your network environment.
+
+###########################################################################
diff --git a/net/linux-f10-nss_ldap/pkg-plist b/net/linux-f10-nss_ldap/pkg-plist
new file mode 100644
index 000000000000..829a81397242
--- /dev/null
+++ b/net/linux-f10-nss_ldap/pkg-plist
@@ -0,0 +1,5 @@
+usr/lib/libnss_ldap.so.2
+usr/lib/libnss_ldap.so
+usr/lib/libnss_ldap-264.so
+etc/ldap.conf.dist
+%%PAM%%lib/security/pam_ldap.so