aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2007-07-08 23:05:27 +0800
committernaddy <naddy@FreeBSD.org>2007-07-08 23:05:27 +0800
commit99a108e1c147a10aeb879f38a49d6fc077b876d4 (patch)
treec766fe92f29249ee85efc85fe53e1c7b9cf1c083 /net
parentb78b5d99b1782ae29e1728176fe887e867d9fc5e (diff)
downloadfreebsd-ports-gnome-99a108e1c147a10aeb879f38a49d6fc077b876d4.tar.gz
freebsd-ports-gnome-99a108e1c147a10aeb879f38a49d6fc077b876d4.tar.zst
freebsd-ports-gnome-99a108e1c147a10aeb879f38a49d6fc077b876d4.zip
Use LOG_NTP syslog facility.
PR: 114191 Submitted by: Robert Archer <freebsd@deathbeforedecaf.net>
Diffstat (limited to 'net')
-rw-r--r--net/openntpd/Makefile1
-rw-r--r--net/openntpd/files/patch-log.c25
2 files changed, 26 insertions, 0 deletions
diff --git a/net/openntpd/Makefile b/net/openntpd/Makefile
index bddc94b93f69..5a6e6abc3a62 100644
--- a/net/openntpd/Makefile
+++ b/net/openntpd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openntpd
PORTVERSION= 3.9p1
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= net
MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenNTPD/ \
diff --git a/net/openntpd/files/patch-log.c b/net/openntpd/files/patch-log.c
new file mode 100644
index 000000000000..95cb3fbb0f51
--- /dev/null
+++ b/net/openntpd/files/patch-log.c
@@ -0,0 +1,25 @@
+
+$FreeBSD$
+
+--- log.c.orig
++++ log.c
+@@ -28,6 +28,10 @@
+
+ #include "ntpd.h"
+
++#ifndef LOG_NTP
++#define LOG_NTP LOG_DAEMON
++#endif
++
+ int debug;
+
+ void logit(int, const char *, ...);
+@@ -40,7 +44,7 @@
+ debug = n_debug;
+
+ if (!debug)
+- openlog(__progname, LOG_PID | LOG_NDELAY, LOG_DAEMON);
++ openlog(__progname, LOG_PID | LOG_NDELAY, LOG_NTP);
+
+ tzset();
+ }