aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-12-06 05:53:22 +0800
committerpav <pav@FreeBSD.org>2009-12-06 05:53:22 +0800
commita6a90ffcd96ba0c3a7b8d11467238748a1f53624 (patch)
tree0dd675bfd49c61029461ed8b2c5340a7763ab491 /net
parentbf4f8c8aeffec7598f09cb6afca7a6ce8ff6eda1 (diff)
downloadfreebsd-ports-gnome-a6a90ffcd96ba0c3a7b8d11467238748a1f53624.tar.gz
freebsd-ports-gnome-a6a90ffcd96ba0c3a7b8d11467238748a1f53624.tar.zst
freebsd-ports-gnome-a6a90ffcd96ba0c3a7b8d11467238748a1f53624.zip
- Fix depobj after recent mpich2 update
Reported by: pointyhat - While here, remove support for nonexistant mpich1 port
Diffstat (limited to 'net')
-rw-r--r--net/ruby-mpi/Makefile14
1 files changed, 3 insertions, 11 deletions
diff --git a/net/ruby-mpi/Makefile b/net/ruby-mpi/Makefile
index 4ec671bdc0bb..eebb5a824189 100644
--- a/net/ruby-mpi/Makefile
+++ b/net/ruby-mpi/Makefile
@@ -17,21 +17,13 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby binding of MPI (Message Passing Interface)
-BUILD_DEPENDS= ${LOCALBASE}/mpich${MPICH_VER}/lib/libmpich.a:${PORTSDIR}/net/mpich${MPICH_VER}
-RUN_DEPENDS= ${LOCALBASE}/mpich${MPICH_VER}/lib/libmpich.a:${PORTSDIR}/net/mpich${MPICH_VER}
+BUILD_DEPENDS= ${LOCALBASE}/lib/libmpich.a:${PORTSDIR}/net/mpich2
+RUN_DEPENDS= ${LOCALBASE}/lib/libmpich.a:${PORTSDIR}/net/mpich2
USE_BZIP2= yes
USE_RUBY= yes
HAS_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-mpi-path=${LOCALBASE}/mpich${MPICH_VER}
-
-.if defined(WITH_MPICH1)
-USE_FORTRAN= yes
-FORTRANLIBDIR2= `${DIRNAME} \`${FC} -print-libgcc-file-name\``/../../../
-CONFIGURE_ENV+= LDFLAGS="-L${FORTRANLIBDIR2} -lgfortran"
-.else
-MPICH_VER= 2
-.endif
+CONFIGURE_ARGS+= --with-mpi-path=${LOCALBASE}/mpich2
MAN1= mpi_ruby.1
MAN3= MPI_Comm.3 MPI_Exception.3 MPI_Group.3 MPI_Keyval.3 MPI_Op.3 MPI_Request.3 \