aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2012-03-15 19:45:48 +0800
committersem <sem@FreeBSD.org>2012-03-15 19:45:48 +0800
commita835797695bd080453947adbef2d9abf936b47e3 (patch)
tree3b746aad1f245c49683fffa2ae4b27bfa76c66bc /net
parentc6d3eea700ff862984cd5dcbc4293675f7d2c87f (diff)
downloadfreebsd-ports-gnome-a835797695bd080453947adbef2d9abf936b47e3.tar.gz
freebsd-ports-gnome-a835797695bd080453947adbef2d9abf936b47e3.tar.zst
freebsd-ports-gnome-a835797695bd080453947adbef2d9abf936b47e3.zip
- Add patches to fix two crash dumps
Submitted by: Boris Lytochkin <lytboris_at_yandex-team.ru> Feature safe: Yes
Diffstat (limited to 'net')
-rw-r--r--net/irrd/Makefile1
-rw-r--r--net/irrd/files/patch-config_file.c11
-rw-r--r--net/irrd/files/patch-database.c16
3 files changed, 28 insertions, 0 deletions
diff --git a/net/irrd/Makefile b/net/irrd/Makefile
index 9ac87c58fd4b..8a2cafa87b27 100644
--- a/net/irrd/Makefile
+++ b/net/irrd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= irrd
PORTVERSION= 2.3.10
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= http://www.irrd.net/
DISTNAME= ${PORTNAME}${PORTVERSION}
diff --git a/net/irrd/files/patch-config_file.c b/net/irrd/files/patch-config_file.c
new file mode 100644
index 000000000000..52723b198ac9
--- /dev/null
+++ b/net/irrd/files/patch-config_file.c
@@ -0,0 +1,11 @@
+--- lib/config/config_file.c.orig 2009-03-25 00:38:11.000000000 +0300
++++ lib/config/config_file.c 2011-06-24 17:09:08.000000000 +0400
+@@ -772,7 +772,7 @@
+ Deref_Prefix (prefix);
+ return (1);
+ }
+- if (prefix_compare2 (UII->prefix, prefix) != 0) {
++ if ( UII->prefix == NULL || prefix_compare2 (UII->prefix, prefix) != 0) {
+ set_uii (UII, UII_ADDR, prefix, 0);
+ listen_uii2 (NULL);
+ }
diff --git a/net/irrd/files/patch-database.c b/net/irrd/files/patch-database.c
new file mode 100644
index 000000000000..fc32c929eb34
--- /dev/null
+++ b/net/irrd/files/patch-database.c
@@ -0,0 +1,16 @@
+--- programs/IRRd/database.c~ 2009-03-25 00:21:26.000000000 +0300
++++ programs/IRRd/database.c 2012-03-15 10:53:03.000000000 +0400
+@@ -59,9 +59,11 @@
+
+ db->radix_v4 = New_Radix (32);
+ db->radix_v6 = New_Radix (128);
+- fclose (db->db_fp);
+
+- db->db_fp = NULL;
++ if (db->db_fp) {
++ fclose (db->db_fp);
++ db->db_fp = NULL;
++ }
+ }
+
+