aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsylvio <sylvio@FreeBSD.org>2010-02-03 07:29:24 +0800
committersylvio <sylvio@FreeBSD.org>2010-02-03 07:29:24 +0800
commitaa44f89135ff08d8e89efda12962a4a3697b180d (patch)
treeabb8ab63bf2fe4a3373ca4579e07382552bbf69b /net
parent0db731e86b96c25dcbc9af23bc8d90a0872f33a4 (diff)
downloadfreebsd-ports-gnome-aa44f89135ff08d8e89efda12962a4a3697b180d.tar.gz
freebsd-ports-gnome-aa44f89135ff08d8e89efda12962a4a3697b180d.tar.zst
freebsd-ports-gnome-aa44f89135ff08d8e89efda12962a4a3697b180d.zip
- Removed dependencies of wget
- Add extra files of Makefile.am into Makefile - Change distinfo - BUMP PORTREVISION Approved by: miwi (mentor)
Diffstat (limited to 'net')
-rw-r--r--net/ntop/Makefile23
-rw-r--r--net/ntop/distinfo15
-rw-r--r--net/ntop/files/patch-Makefile.am81
-rw-r--r--net/ntop/pkg-plist2
4 files changed, 111 insertions, 10 deletions
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index d1f9fe209f6a..c50b39cba7f4 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -7,20 +7,26 @@
PORTNAME= ntop
PORTVERSION= 3.3.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
+MASTER_SITES= http://www.ntop.org/trac/export/4103/trunk/ntop/3rd_party/ \
+ SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
+DISTFILES= etter.finger.os.gz \
+ GeoIPASNum.dat.gz \
+ GeoLiteCity.dat.gz \
+ oui.txt.gz \
+ specialMAC.txt.gz \
+ ${PORTNAME}-${PORTVERSION}.tar.gz
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}.tar.gz
MAINTAINER= sylvio@FreeBSD.org
COMMENT= Network monitoring tool with command line and web interfaces
-BUILD_DEPENDS= rrdtool>=1.2:${PORTSDIR}/databases/rrdtool \
- ${LOCALBASE}/bin/wget:${PORTSDIR}/ftp/wget \
- geoiplookup:${PORTSDIR}/net/GeoIP
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm \
event-1.4:${PORTSDIR}/devel/libevent
+BUILD_DEPENDS= rrdtool>=1.2:${PORTSDIR}/databases/rrdtool \
+ geoiplookup:${PORTSDIR}/net/GeoIP
RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz \
- ${LOCALBASE}/bin/wget:${PORTSDIR}/ftp/wget \
${LOCALBASE}/lib/X11/fonts/URW/a010013l.afm:${PORTSDIR}/x11-fonts/urwfonts
BROKEN= does not build
@@ -93,6 +99,11 @@ CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include/libxml2 \
post-extract:
@${RM} ${WRKSRC}/configureextra/FREEBSD
+ @${CP} ${_DISTDIR}/etter.finger.os.gz ${WRKSRC}
+ @${CP} ${_DISTDIR}/GeoIPASNum.dat.gz ${WRKSRC}
+ @${CP} ${_DISTDIR}/GeoLiteCity.dat.gz ${WRKSRC}
+ @${CP} ${_DISTDIR}/oui.txt.gz ${WRKSRC}
+ @${CP} ${_DISTDIR}/specialMAC.txt.gz ${WRKSRC}
pre-configure:
@cd ${WRKSRC} && ${SETENV} ${SCRIPTS_ENV} ${SH} autogen.sh --noconfig
diff --git a/net/ntop/distinfo b/net/ntop/distinfo
index 77e9c712baa1..e2fbdce90272 100644
--- a/net/ntop/distinfo
+++ b/net/ntop/distinfo
@@ -1,3 +1,18 @@
+MD5 (etter.finger.os.gz) = cc7bf111369e4111089b86ad75953c79
+SHA256 (etter.finger.os.gz) = f4ef41faad479f47080696032a90b695807ce9a28dbb0d2a215f54c870fa9471
+SIZE (etter.finger.os.gz) = 18394
+MD5 (GeoIPASNum.dat.gz) = b34900f4783e2efddacbf8bf260c1dad
+SHA256 (GeoIPASNum.dat.gz) = c39a86798e64c6773da17a7e6afcea8da98292a4ee2b755369bb046a14aac38b
+SIZE (GeoIPASNum.dat.gz) = 1203026
+MD5 (GeoLiteCity.dat.gz) = 94d0975210023c802ccb1f6ec0727b19
+SHA256 (GeoLiteCity.dat.gz) = b92dad48943b388e73e542b5f895850d4de4d78d8f3ecaaa85214bd46ded6930
+SIZE (GeoLiteCity.dat.gz) = 26285561
+MD5 (oui.txt.gz) = f1309510af2e852ee1fa8ed1909c0fa1
+SHA256 (oui.txt.gz) = 5534fe672f920f8b05bb044b1c36e60f154bb58415d147b2e52276eb167f74eb
+SIZE (oui.txt.gz) = 598418
+MD5 (specialMAC.txt.gz) = 4a52a90c7db969712eaac5b048d3f3b1
+SHA256 (specialMAC.txt.gz) = 8ac344327ffca8617e0c9b25b646f0da1adf9c5a0a0f3e6ad5e8335666627d07
+SIZE (specialMAC.txt.gz) = 749
MD5 (ntop-3.3.10.tar.gz) = 6e2ffa90d5f935c8f03d88a5dd19a866
SHA256 (ntop-3.3.10.tar.gz) = aa18ba3acb564d707521deaa2655f61f5b617d98d4fb5a014553f3fa123f123a
SIZE (ntop-3.3.10.tar.gz) = 3235500
diff --git a/net/ntop/files/patch-Makefile.am b/net/ntop/files/patch-Makefile.am
index e5ec90c30bcb..1ac086c0e581 100644
--- a/net/ntop/files/patch-Makefile.am
+++ b/net/ntop/files/patch-Makefile.am
@@ -1,13 +1,20 @@
--- Makefile.am.orig 2009-04-17 17:27:57.000000000 -0300
-+++ Makefile.am 2009-09-15 13:07:19.000000000 -0300
-@@ -76,9 +76,7 @@
++++ Makefile.am 2010-01-22 21:18:51.000000000 -0200
+@@ -70,15 +70,13 @@
+
+ ETTER_PASSIVE_FILE = etter.finger.os
+ ETTER_PASSIVE = $(ETTER_PASSIVE_FILE).gz
+-ETTER_PASSIVE_DOWNLOAD_FROM = "http://ettercap.cvs.sourceforge.net/ettercap/ettercap_ng/share"
+-ETTER_PASSIVE_DOWNLOAD_PARMS = "rev=HEAD"
+
NTOPDATA = ntop-cert.pem \
$(ETTER_PASSIVE) \
oui.txt.gz \
-- specialMAC.txt.gz \
+ specialMAC.txt.gz \
- GeoIPASNum.dat \
- GeoLiteCity.dat
-+ specialMAC.txt.gz
++ GeoIPASNum.dat.gz \
++ GeoLiteCity.dat.gz
NTOPHTML = html html/*.js html/*.html html/*.gif html/*.jpg html/*.ico html/*.png \
html/*.css html/*.dtd \
@@ -28,3 +35,69 @@
@if ! test -d $(DESTDIR)/$(datadir)/ntop; then \
$(top_srcdir)/mkinstalldirs $(DESTDIR)/$(datadir)/ntop; \
touch $(DESTDIR)/$(datadir)/ntop/warnuser; \
+@@ -376,21 +371,6 @@
+ @echo ""
+ @echo ""
+ @echo -n "Preparing "
+- @if test -f oui.txt; then \
+- rm -rf oui.txt; \
+- fi
+- @if test -f oui.txt.gz.old; then \
+- rm -rf oui.txt.gz.old; \
+- fi;
+- @mv oui.txt.gz oui.txt.gz.old
+- @echo "(old oui.txt.gz file is now oui.txt.gz.old)"
+- @echo ""
+- @wget -c http://standards.ieee.org/regauth/oui/oui.txt
+- @gzip oui.txt
+- @echo ""
+- @echo ""
+- @echo -n "Old file lines were: "
+- @gunzip -c oui.txt.gz.old | wc -l
+ @echo -n "New file lines are: "
+ @gunzip -c oui.txt.gz | wc -l
+ @echo ""
+@@ -400,7 +380,7 @@
+
+ # download the Novell SAP Protocol information table
+ dnsapt:
+- @(cd Internet; wget -c http://www.iana.org/assignments/novell-sap-numbers)
++ @(cd Internet; fetch http://www.iana.org/assignments/novell-sap-numbers)
+
+ # download the passive ethernet fingerprint database
+ dnetter:
+@@ -409,34 +389,6 @@
+ @echo "Preparing "
+ @echo ""
+
+- @if test -f $(ETTER_PASSIVE).old; then \
+- echo "...Deleting prior file, $(ETTER_PASSIVE).old..."; \
+- rm -rf $(ETTER_PASSIVE).old; \
+- fi;
+- @if test -f $(ETTER_PASSIVE); then \
+- echo "...Moving current $(ETTER_PASSIVE) to $(ETTER_PASSIVE).old"; \
+- mv $(ETTER_PASSIVE) $(ETTER_PASSIVE).old; \
+- fi;
+- @for file in $(ETTER_PASSIVE) $(ETTER_PASSIVE).gz \
+- $(ETTER_PASSIVE_FILE) $(ETTER_PASSIVE_FILE).gz; do \
+- if test -f $$file; then \
+- echo "...Deleting prior file, $$file..."; \
+- rm -rf $$file; \
+- fi; \
+- done
+- @echo ""
+- @echo "...Downloading new file..."
+- @wget -O $(ETTER_PASSIVE_FILE) \
+- $(ETTER_PASSIVE_DOWNLOAD_FROM)/$(ETTER_PASSIVE_FILE)?$(ETTER_PASSIVE_DOWNLOAD_PARMS)
+- @echo ""
+- @echo "gziping downloaded file..."
+- @gzip $(ETTER_PASSIVE_FILE)
+- @echo ""
+- @echo ""
+- @if test -f $(ETTER_PASSIVE).old; then \
+- echo -n "Old file lines were: "; \
+- gunzip -c $(ETTER_PASSIVE).old | wc -l; \
+- fi;
+ @echo -n "New file lines are: "
+ @gunzip -c $(ETTER_PASSIVE) | wc -l
+ @echo ""
diff --git a/net/ntop/pkg-plist b/net/ntop/pkg-plist
index f8e65af44969..908b967b4fae 100644
--- a/net/ntop/pkg-plist
+++ b/net/ntop/pkg-plist
@@ -1,4 +1,6 @@
bin/ntop
+etc/ntop/GeoIPASNum.dat.gz
+etc/ntop/GeoLiteCity.dat.gz
etc/ntop/ntop-cert.pem
etc/ntop/etter.finger.os.gz
etc/ntop/oui.txt.gz