aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2013-06-09 06:16:58 +0800
committermarcus <marcus@FreeBSD.org>2013-06-09 06:16:58 +0800
commitab1073a9807831cdbbfe127400298d74912e335e (patch)
treef2c10b1877d57bf14ebbb9c7d1ab6a2229bd4f37 /net
parentc84507042d45ebc708751e8f22e0779700135c44 (diff)
downloadfreebsd-ports-gnome-ab1073a9807831cdbbfe127400298d74912e335e.tar.gz
freebsd-ports-gnome-ab1073a9807831cdbbfe127400298d74912e335e.tar.zst
freebsd-ports-gnome-ab1073a9807831cdbbfe127400298d74912e335e.zip
Update to 1.10.0.
Diffstat (limited to 'net')
-rw-r--r--net/wireshark/Makefile5
-rw-r--r--net/wireshark/distinfo4
-rw-r--r--net/wireshark/files/patch-epan_Makefile.in19
-rw-r--r--net/wireshark/pkg-plist21
4 files changed, 33 insertions, 16 deletions
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index e1fb2c7335ce..09b99a66f0cd 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME?= wireshark
-PORTVERSION= 1.8.7
+PORTVERSION= 1.10.0
CATEGORIES= net ipv6
MASTER_SITES= http://www.wireshark.org/download/src/ \
http://ftp.uni-kl.de/pub/wireshark/src/ \
@@ -41,7 +41,8 @@ DESKTOP_ENTRIES= "Wireshark" "Network Protocol Analyzer" \
WIRESHARK_LIBS=
-.for x in capinfos editcap mergecap rawshark text2pcap dftest randpkt
+.for x in capinfos editcap mergecap rawshark text2pcap dftest randpkt \
+ reordercap
.if defined(LITE)
PLIST_SUB+= ${x:U}="@comment $x not installed"
CONFIGURE_ARGS+= --enable-$x=no
diff --git a/net/wireshark/distinfo b/net/wireshark/distinfo
index 59ed5e3b061d..30fa64d05228 100644
--- a/net/wireshark/distinfo
+++ b/net/wireshark/distinfo
@@ -1,2 +1,2 @@
-SHA256 (wireshark-1.8.7.tar.bz2) = 5c7e429c1e410289b49d65a2e635e00c0becdcb56fe703a1d3e7b5e275fca842
-SIZE (wireshark-1.8.7.tar.bz2) = 24273700
+SHA256 (wireshark-1.10.0.tar.bz2) = 1f4b377ba6284a51797bcc437aa2918bfaeb5d30908cd6194bd09f7054c65add
+SIZE (wireshark-1.10.0.tar.bz2) = 27101631
diff --git a/net/wireshark/files/patch-epan_Makefile.in b/net/wireshark/files/patch-epan_Makefile.in
index 4281e1d35469..0d9f0ad04e64 100644
--- a/net/wireshark/files/patch-epan_Makefile.in
+++ b/net/wireshark/files/patch-epan_Makefile.in
@@ -1,11 +1,10 @@
---- epan/Makefile.in.orig 2010-08-29 18:19:28.000000000 -0400
-+++ epan/Makefile.in 2010-09-04 17:19:36.000000000 -0400
-@@ -746,6 +746,8 @@ INCLUDES = -I$(srcdir)/.. -I$(srcdir)/$(
- $(LIBGNUTLS_CFLAGS) $(LIBGCRYPT_CFLAGS) $(LIBSMI_CFLAGS) \
- $(LIBGEOIP_CFLAGS)
-
+--- epan/Makefile.in.orig 2013-06-05 13:27:48.000000000 -0400
++++ epan/Makefile.in 2013-06-08 17:55:04.000000000 -0400
+@@ -111,6 +111,7 @@ target_triplet = @target@
+ DIST_COMMON = $(srcdir)/../Makefile.am.inc $(srcdir)/Makefile.am \
+ $(srcdir)/Makefile.common $(srcdir)/Makefile.in \
+ $(srcdir)/doxygen.cfg.in
+LIBS = @LUA_LIBS@
-+
- @HAVE_WARNINGS_AS_ERRORS_TRUE@AM_NON_GENERATED_CFLAGS = -Werror
-
- #Since code generated by lex may trigger gcc warnings, we are now generating two
+ @HAVE_WARNINGS_AS_ERRORS_TRUE@am__append_1 = -Werror
+ EXTRA_PROGRAMS = reassemble_test$(EXEEXT)
+ subdir = epan
diff --git a/net/wireshark/pkg-plist b/net/wireshark/pkg-plist
index b369797c09d1..caa3d8378e6f 100644
--- a/net/wireshark/pkg-plist
+++ b/net/wireshark/pkg-plist
@@ -6,17 +6,18 @@ bin/dumpcap
%%MERGECAP%%
%%RANDPKT%%
%%RAWSHARK%%
+%%REORDERCAP%%
bin/tshark
%%TEXT2PCAP%%
lib/libwireshark.la
lib/libwireshark.so
-lib/libwireshark.so.2
+lib/libwireshark.so.3
lib/libwiretap.la
lib/libwiretap.so
lib/libwiretap.so.3
lib/libwsutil.la
lib/libwsutil.so
-lib/libwsutil.so.2
+lib/libwsutil.so.3
lib/wireshark/plugins/%%PORTVERSION%%/asn1.la
lib/wireshark/plugins/%%PORTVERSION%%/asn1.so
lib/wireshark/plugins/%%PORTVERSION%%/docsis.la
@@ -43,6 +44,8 @@ lib/wireshark/plugins/%%PORTVERSION%%/wimax.la
lib/wireshark/plugins/%%PORTVERSION%%/wimax.so
lib/wireshark/plugins/%%PORTVERSION%%/wimaxasncp.la
lib/wireshark/plugins/%%PORTVERSION%%/wimaxasncp.so
+lib/wireshark/plugins/%%PORTVERSION%%/wimaxmacphy.la
+lib/wireshark/plugins/%%PORTVERSION%%/wimaxmacphy.so
%%DATADIR%%/AUTHORS-SHORT
%%DATADIR%%/COPYING
%%DATADIR%%/capinfos.html
@@ -54,8 +57,12 @@ lib/wireshark/plugins/%%PORTVERSION%%/wimaxasncp.so
%%LUA%%%%DATADIR%%/dtd_gen.lua
%%DATADIR%%/dumpcap.html
%%DATADIR%%/diameter/AlcatelLucent.xml
+%%DATADIR%%/diameter/ChinaTelecom.xml
%%DATADIR%%/diameter/Cisco.xml
%%DATADIR%%/diameter/Ericsson.xml
+%%DATADIR%%/diameter/Nokia.xml
+%%DATADIR%%/diameter/NokiaSiemensNetworks.xml
+%%DATADIR%%/diameter/SKT.xml
%%DATADIR%%/diameter/TGPPGmb.xml
%%DATADIR%%/diameter/TGPPRx.xml
%%DATADIR%%/diameter/TGPPS9.xml
@@ -99,7 +106,10 @@ lib/wireshark/plugins/%%PORTVERSION%%/wimaxasncp.so
%%DATADIR%%/manuf
%%DATADIR%%/mergecap.html
%%DATADIR%%/pdml2html.xsl
+%%DATADIR%%/profiles/Bluetooth/colorfilters
+%%DATADIR%%/profiles/Classic/colorfilters
%%DATADIR%%/radius/README.radius_dictionary
+%%DATADIR%%/radius/custom.includes
%%DATADIR%%/radius/dictionary
%%DATADIR%%/radius/dictionary.3com
%%DATADIR%%/radius/dictionary.3gpp
@@ -208,9 +218,12 @@ lib/wireshark/plugins/%%PORTVERSION%%/wimaxasncp.so
%%DATADIR%%/radius/dictionary.rfc4849
%%DATADIR%%/radius/dictionary.rfc5090
%%DATADIR%%/radius/dictionary.rfc5176
+%%DATADIR%%/radius/dictionary.rfc5447
%%DATADIR%%/radius/dictionary.rfc5580
%%DATADIR%%/radius/dictionary.rfc5607
%%DATADIR%%/radius/dictionary.rfc5904
+%%DATADIR%%/radius/dictionary.rfc6519
+%%DATADIR%%/radius/dictionary.rfc6572
%%DATADIR%%/radius/dictionary.riverstone
%%DATADIR%%/radius/dictionary.roaringpenguin
%%DATADIR%%/radius/dictionary.shasta
@@ -242,6 +255,7 @@ lib/wireshark/plugins/%%PORTVERSION%%/wimaxasncp.so
%%DATADIR%%/radius/dictionary.zyxel
%%DATADIR%%/randpkt.html
%%DATADIR%%/rawshark.html
+%%DATADIR%%/reordercap.html
%%DATADIR%%/services
%%DATADIR%%/smi_modules
%%DATADIR%%/tshark.html
@@ -258,6 +272,9 @@ lib/wireshark/plugins/%%PORTVERSION%%/wimaxasncp.so
@dirrm %%DATADIR%%/wimaxasncp
@dirrm %%DATADIR%%/tpncp
@dirrm %%DATADIR%%/radius
+@dirrm %%DATADIR%%/profiles/Classic
+@dirrm %%DATADIR%%/profiles/Bluetooth
+@dirrm %%DATADIR%%/profiles
@dirrm %%DATADIR%%/help
@dirrm %%DATADIR%%/dtds
@dirrm %%DATADIR%%/diameter