aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2013-08-04 23:57:40 +0800
committerehaupt <ehaupt@FreeBSD.org>2013-08-04 23:57:40 +0800
commitb3b342f91393b003114d0e6d9666fe489c979ae0 (patch)
tree8c74ca66e7869fb61d35495d6f566002c608ade2 /net
parent071f0e103ea6c2f6c73931189ba1dfb6c812f48b (diff)
downloadfreebsd-ports-gnome-b3b342f91393b003114d0e6d9666fe489c979ae0.tar.gz
freebsd-ports-gnome-b3b342f91393b003114d0e6d9666fe489c979ae0.tar.zst
freebsd-ports-gnome-b3b342f91393b003114d0e6d9666fe489c979ae0.zip
Change the clang detector to use a pattern match instead of a conditional
define and always test. This fixes build on 9-STABLE and saves some shell commands. PR: 181007 Submitted by: "r4721@tormail.org" <r4721@tormail.org>
Diffstat (limited to 'net')
-rw-r--r--net/socat/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/net/socat/Makefile b/net/socat/Makefile
index 81cc7f7f9d51..307017f3ae7e 100644
--- a/net/socat/Makefile
+++ b/net/socat/Makefile
@@ -33,11 +33,9 @@ CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
.endif
-.if(${OSVERSION} >= 1000024)
-CCISCLANG!= ${CC} --version | ${HEAD} -1 | ${GREP} 'clang'
-.endif
+CCISCLANG!= ${CC} --version
-.if ${CC} == clang || !empty(CCISCLANG)
+.if !empty(CCISCLANG:M*clang*)
CFLAGS+= -Wno-unused-comparison
.endif