aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorvd <vd@FreeBSD.org>2007-01-10 14:47:24 +0800
committervd <vd@FreeBSD.org>2007-01-10 14:47:24 +0800
commitb6c3eacf1b737b730f8316022a2a2ad9f69e28c3 (patch)
treed43aa3fa2b2532498695eb7c567008fa97be94ce /net
parentead4f99b361a7273bd5f401d5914a5a5ec2b680d (diff)
downloadfreebsd-ports-gnome-b6c3eacf1b737b730f8316022a2a2ad9f69e28c3.tar.gz
freebsd-ports-gnome-b6c3eacf1b737b730f8316022a2a2ad9f69e28c3.tar.zst
freebsd-ports-gnome-b6c3eacf1b737b730f8316022a2a2ad9f69e28c3.zip
* Use USE_RC_SUBR instead of custom hacks which did not seem to work correctly
* Fix typo in the startup script Reported by: Wojciech Puchar <wojtek@tensor.3miasto.net> (on ports@)
Diffstat (limited to 'net')
-rw-r--r--net/mpd/Makefile12
-rw-r--r--net/mpd/files/mpd.in (renamed from net/mpd/files/mpd.sh)8
-rw-r--r--net/mpd/pkg-plist1
3 files changed, 8 insertions, 13 deletions
diff --git a/net/mpd/Makefile b/net/mpd/Makefile
index 6375bf4ee244..1c81374b9494 100644
--- a/net/mpd/Makefile
+++ b/net/mpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mpd
PORTVERSION= 3.18
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= archie
@@ -23,17 +23,11 @@ MANCOMPRESSED= maybe
USE_OPENSSL= yes
MAKE_ENV= COPTS="${COPTS} -I${OPENSSLINC}" LDADD="${LDADD} -L${OPENSSLLIB}"
-.include <bsd.port.pre.mk>
+USE_RC_SUBR= mpd
pre-build:
@${ECHO}
@${ECHO} "Use WITH_OPENSSL_PORT=yes if you use OPENSSL from ports"
@${ECHO}
-post-install:
- @${SED} -e "s=%%RC_SUBR%%=${RC_SUBR}=" \
- -e "s=%%PREFIX%%=${PREFIX}=" \
- < ${FILESDIR}/mpd.sh > ${WRKSRC}/mpd.sh
- @${INSTALL_SCRIPT} ${WRKSRC}/mpd.sh ${PREFIX}/etc/rc.d/mpd.sh
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/mpd/files/mpd.sh b/net/mpd/files/mpd.in
index 1e57ace8b2aa..2168bb71edda 100644
--- a/net/mpd/files/mpd.sh
+++ b/net/mpd/files/mpd.in
@@ -1,17 +1,19 @@
#!/bin/sh
#
-# $FreeBSD$
+# $FreeBSD: /tmp/pcvs/ports/net/mpd/files/Attic/mpd.in,v 1.1 2007-01-10 06:47:24 vd Exp $
#
# PROVIDE: mpd
# REQUIRE: NETWORKING syslogd
#
-# Add the following line to /etc/rc.conf to enable mpd:
+# Add the following line to /etc/rc.conf[.local] to enable mpd:
#
# mpd_enable="YES"
#
+# You can also set mpd_flags to any flags you want. The default is "-b".
+#
mpd_flags="${mpd_flags:--b}"
-mpd_enable="${mpd_enable-NO}"
+mpd_enable="${mpd_enable:-NO}"
. %%RC_SUBR%%
diff --git a/net/mpd/pkg-plist b/net/mpd/pkg-plist
index 905b9cc7c5cc..a57f67f3340c 100644
--- a/net/mpd/pkg-plist
+++ b/net/mpd/pkg-plist
@@ -2,7 +2,6 @@ etc/mpd/mpd.conf.sample
etc/mpd/mpd.links.sample
etc/mpd/mpd.secret.sample
etc/mpd/mpd.script.sample
-etc/rc.d/mpd.sh
sbin/mpd
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/mpd.ps