aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-02-28 19:21:56 +0800
committeredwin <edwin@FreeBSD.org>2004-02-28 19:21:56 +0800
commitbb4498df85810fc9bf6e611d349523ed560eccf4 (patch)
tree92ca71f6c2f966fb4fd515d1c647beaa69f7a9e4 /net
parent247a03d8d7b66451f4a94fcda2730d22a1f31625 (diff)
downloadfreebsd-ports-gnome-bb4498df85810fc9bf6e611d349523ed560eccf4.tar.gz
freebsd-ports-gnome-bb4498df85810fc9bf6e611d349523ed560eccf4.tar.zst
freebsd-ports-gnome-bb4498df85810fc9bf6e611d349523ed560eccf4.zip
Fix problems which where there during running of the program:
- checked on 4.8 - checked on 5.2.1 with standard libpcap - checked on 5.2.1 with net/libpcap Commands checked: - ngrep -d fxp1 - ngrep -d fxp1 port 80 - ngrep -d fxp1 GET port 80
Diffstat (limited to 'net')
-rw-r--r--net/ngrep/Makefile10
-rw-r--r--net/ngrep/files/patch5-configure37
-rw-r--r--net/ngrep/files/patch5-ngrep19
-rw-r--r--net/ngrep/pkg-plist2
4 files changed, 4 insertions, 64 deletions
diff --git a/net/ngrep/Makefile b/net/ngrep/Makefile
index 5b4b981985b1..570c5fefc128 100644
--- a/net/ngrep/Makefile
+++ b/net/ngrep/Makefile
@@ -8,7 +8,7 @@
PORTNAME= ngrep
PORTVERSION= 1.40.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,18 +18,16 @@ COMMENT= Network grep
WRKSRC= ${WRKDIR}/ngrep
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-pcre --with-restart
+CONFIGURE_ARGS= --with-pcre --without-restart
ALL_TARGET= ngrep
+
MAN8= ngrep.8
+PLIST_FILES= bin/ngrep
PORTDOCS= BUGS CHANGES README README.pcre USAGE
.include <bsd.port.pre.mk>
-.if ${OSVERSION} > 501110
-EXTRA_PATCHES= ${PATCHDIR}/patch5-configure ${PATCHDIR}/patch5-ngrep
-.endif
-
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/net/ngrep/files/patch5-configure b/net/ngrep/files/patch5-configure
deleted file mode 100644
index 7e1d18edb8ec..000000000000
--- a/net/ngrep/files/patch5-configure
+++ /dev/null
@@ -1,37 +0,0 @@
---- configure.orig Sat Nov 8 15:49:02 2003
-+++ configure Sat Nov 8 15:49:54 2003
-@@ -1978,9 +1978,9 @@
-
- else
- echo "$ac_t""no" 1>&6
--echo $ac_n "checking for pcap_yyrestart in -lpcap""... $ac_c" 1>&6
--echo "configure:1983: checking for pcap_yyrestart in -lpcap" >&5
--ac_lib_var=`echo pcap'_'pcap_yyrestart | sed 'y%./+-%__p_%'`
-+echo $ac_n "checking for pcapyyrestart in -lpcap""... $ac_c" 1>&6
-+echo "configure:1983: checking for pcapyyrestart in -lpcap" >&5
-+ac_lib_var=`echo pcap'_'pcapyyrestart | sed 'y%./+-%__p_%'`
- if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
- echo $ac_n "(cached) $ac_c" 1>&6
- else
-@@ -1992,10 +1992,10 @@
- /* Override any gcc2 internal prototype to avoid an error. */
- /* We use char because int might match the return type of a gcc2
- builtin and then its argument prototype would still apply. */
--char pcap_yyrestart();
-+char pcapyyrestart();
-
- int main() {
--pcap_yyrestart()
-+pcapyyrestart()
- ; return 0; }
- EOF
- if { (eval echo configure:2002: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
-@@ -2014,7 +2014,7 @@
- if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
- echo "$ac_t""yes" 1>&6
- cat >> confdefs.h <<\EOF
--#define PCAP_RESTART pcap_yyrestart
-+#define PCAP_RESTART pcapyyrestart
- EOF
-
- else
diff --git a/net/ngrep/files/patch5-ngrep b/net/ngrep/files/patch5-ngrep
deleted file mode 100644
index 44c4a094ee01..000000000000
--- a/net/ngrep/files/patch5-ngrep
+++ /dev/null
@@ -1,19 +0,0 @@
---- ngrep.c.orig Mon Dec 31 14:11:00 2001
-+++ ngrep.c Sat Nov 8 15:50:53 2003
-@@ -62,6 +62,7 @@
-
- #include "ngrep.h"
-
-+extern FILE *pcapyyin;
-
- static char rcsver[] = "$Revision: 1.23 $";
-
-@@ -232,7 +233,7 @@
- filter = get_filter(&argv[optind-1]);
-
- #ifdef NEED_RESTART
-- PCAP_RESTART();
-+ PCAP_RESTART(pcapyyin);
- #endif
- if (pcap_compile(pd, &pcapfilter, filter, 0, mask.s_addr)) {
- pcap_perror(pd, "pcap compile");
diff --git a/net/ngrep/pkg-plist b/net/ngrep/pkg-plist
deleted file mode 100644
index 0d52ecd4cf73..000000000000
--- a/net/ngrep/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-@comment $FreeBSD$
-bin/ngrep