aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2013-04-26 18:44:28 +0800
committerak <ak@FreeBSD.org>2013-04-26 18:44:28 +0800
commitbe0532aa1927751208f2697351ec6365d64f46e3 (patch)
treee5e83d3ba0442c1c2f0b99c843428b36a8eb003d /net
parent1b4e8ae3fa9398a48e6c4797e41a32870c88ed6c (diff)
downloadfreebsd-ports-gnome-be0532aa1927751208f2697351ec6365d64f46e3.tar.gz
freebsd-ports-gnome-be0532aa1927751208f2697351ec6365d64f46e3.tar.zst
freebsd-ports-gnome-be0532aa1927751208f2697351ec6365d64f46e3.zip
- Convert USE_GETTEXT to USES (part 4)
Approved by: portmgr (bapt)
Diffstat (limited to 'net')
-rw-r--r--net/net6/Makefile2
-rw-r--r--net/samba4/Makefile3
-rw-r--r--net/smb4k-kde4/Makefile3
-rw-r--r--net/tigervnc/Makefile2
-rw-r--r--net/vinagre/Makefile3
5 files changed, 5 insertions, 8 deletions
diff --git a/net/net6/Makefile b/net/net6/Makefile
index 9cfc1c601771..f4010d49aee6 100644
--- a/net/net6/Makefile
+++ b/net/net6/Makefile
@@ -24,7 +24,7 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.else
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/net/samba4/Makefile b/net/samba4/Makefile
index 7ea3cb1ec02d..0b96c48a3341 100644
--- a/net/samba4/Makefile
+++ b/net/samba4/Makefile
@@ -73,8 +73,7 @@ USE_PERL5_BUILD= yes
USE_GCC= 4.2+
USE_PYTHON= yes
USE_ICONV= yes
-USE_GETTEXT= yes
-USES= pkgconfig
+USES= pkgconfig gettext
USE_LDCONFIG= ${SAMBA4_LIBDIR}
PKGCONFIGDIR?= ${PREFIX}/libdata/pkgconfig
diff --git a/net/smb4k-kde4/Makefile b/net/smb4k-kde4/Makefile
index 1cf3ec240793..61722f1f8809 100644
--- a/net/smb4k-kde4/Makefile
+++ b/net/smb4k-kde4/Makefile
@@ -21,8 +21,7 @@ RUN_DEPENDS= sudo:${PORTSDIR}/security/sudo \
SAMBA_PORT?= net/samba36
-USES= cmake
-USE_GETTEXT= yes
+USES= cmake gettext
USE_BZIP2= yes
USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/kde4
USE_KDE4= kdehier kdeprefix kdelibs automoc4 runtime
diff --git a/net/tigervnc/Makefile b/net/tigervnc/Makefile
index 990ddaecb402..08e4be327768 100644
--- a/net/tigervnc/Makefile
+++ b/net/tigervnc/Makefile
@@ -62,7 +62,7 @@ CMAKE_ARGS+= -DENABLE_GNUTLS=0
.endif
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
CMAKE_ARGS+= -DENABLE_NLS=1
PLIST_SUB+= NLS=""
.else
diff --git a/net/vinagre/Makefile b/net/vinagre/Makefile
index e33d0548a1e0..144625d09eea 100644
--- a/net/vinagre/Makefile
+++ b/net/vinagre/Makefile
@@ -21,8 +21,7 @@ LIB_DEPENDS= gtk-vnc-1.0:${PORTSDIR}/net/gtk-vnc \
CONFLICTS= vinagre-3.[0-9]*
USE_BZIP2= yes
-USE_GETTEXT= yes
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= gnomeprefix intlhack vte gconf2 gnomedocutils gnomepanel
USE_GMAKE= yes
GNU_CONFIGURE= yes