aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-06-05 16:20:24 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-06-05 16:20:24 +0800
commitbf622b2e3467f98671368db8bd1a327337b8fc29 (patch)
tree3971a01d892f31e7b55bbc74fac5024a221340b3 /net
parent0697d4f59eaad6b74212dfec46fd36c6b09f2dc9 (diff)
downloadfreebsd-ports-gnome-bf622b2e3467f98671368db8bd1a327337b8fc29.tar.gz
freebsd-ports-gnome-bf622b2e3467f98671368db8bd1a327337b8fc29.tar.zst
freebsd-ports-gnome-bf622b2e3467f98671368db8bd1a327337b8fc29.zip
- Stagify
- Use new LIB_DEPENDS syntax - Fix plist (@exec order and don't remove /var/db) Approved by: portmgr blanket
Diffstat (limited to 'net')
-rw-r--r--net/ntop/Makefile17
-rw-r--r--net/ntop/pkg-plist4
2 files changed, 7 insertions, 14 deletions
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index c3ae6bde85e0..f093158f2aa2 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -3,15 +3,15 @@
PORTNAME= ntop
PORTVERSION= 5.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Stable
MAINTAINER= sylvio@FreeBSD.org
COMMENT= Network monitoring tool with command line and web interfaces
-LIB_DEPENDS= gdbm.4:${PORTSDIR}/databases/gdbm \
- event-1.4:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= libgdbm.so:${PORTSDIR}/databases/gdbm \
+ libevent-1.4.so:${PORTSDIR}/devel/libevent
BUILD_DEPENDS= rrdtool>=1.2:${PORTSDIR}/databases/rrdtool \
subversion>=1.7.0:${PORTSDIR}/devel/subversion \
dot:${PORTSDIR}/graphics/graphviz \
@@ -35,8 +35,6 @@ CONFIGURE_ARGS= --localstatedir=${DBDIR} \
--with-gdbm-root=${LOCALBASE} \
--with-zlib-root=/usr
-MAN8= ntop.8
-
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CPPFLAGS+= -I${LOCALBASE}/include
@@ -52,19 +50,18 @@ XMLDUMP_DESC= Enable XML Dump support
JUMBO_FRAMES_DESC= Jumbo Frames. Experimental.
MAKO_DESC= Install py-mako for Host Map, Region View
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPCAP_PORT}
-LIB_DEPENDS+= pcap.1:${PORTSDIR}/net/libpcap
+LIB_DEPENDS+= libpcap.so:${PORTSDIR}/net/libpcap
CONFIGURE_ARGS+= --with-pcap-root=${LOCALBASE}
.else
CONFIGURE_ARGS+= --with-pcap-root=/usr
.endif
.if ${PORT_OPTIONS:MXMLDUMP}
-LIB_DEPENDS+= gdome.8:${PORTSDIR}/textproc/gdome2
+LIB_DEPENDS+= libgdome.so:${PORTSDIR}/textproc/gdome2
CPPFLAGS+= -I${LOCALBASE}/include/libxml2 \
-I${LOCALBASE}/include/libxml2/libxml \
-I${LOCALBASE}/include/libgdome \
@@ -91,8 +88,4 @@ pre-configure:
pre-install:
@cd ${WRKSRC} && ${GMAKE} dnetter
-post-install:
- @${MKDIR} ${DBDIR}/ntop
- @${CHOWN} -R nobody:nobody ${DBDIR}/ntop
-
.include <bsd.port.post.mk>
diff --git a/net/ntop/pkg-plist b/net/ntop/pkg-plist
index 892fc6d93f69..8b18c78b4c03 100644
--- a/net/ntop/pkg-plist
+++ b/net/ntop/pkg-plist
@@ -23,6 +23,7 @@ lib/libsflowPlugin.so
lib/ntop/plugins/netflowPlugin.so
lib/ntop/plugins/rrdPlugin.so
lib/ntop/plugins/sflowPlugin.so
+man/man8/ntop.8.gz
%%DATADIR%%/html/Google_Maps_Marker.png
%%DATADIR%%/html/JSCookMenu.js
%%DATADIR%%/html/Risk_high.gif
@@ -508,7 +509,6 @@ lib/ntop/plugins/sflowPlugin.so
@dirrm %%DATADIR%%/html/img_inquisitor
@dirrm %%DATADIR%%/html
@dirrm %%DATADIR%%
-@exec chown -R nobody:nobody %%DBDIR%%/ntop
@exec mkdir -p %%DBDIR%%/ntop
-@unexec rmdir %%DBDIR%% 2>/dev/null || true
+@exec chown -R nobody:nobody %%DBDIR%%/ntop
@unexec rmdir %%DBDIR%%/ntop 2>/dev/null || true