aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2006-09-08 05:38:57 +0800
committerbrooks <brooks@FreeBSD.org>2006-09-08 05:38:57 +0800
commitc92cc9c6b3dcdcd7d10614d55f61e859259331d1 (patch)
tree417c713a8bc816bb3cfa148420f7be709a29ac1f /net
parent8633de4e2b7c458d51423b5ea4f2cf94a6d1b925 (diff)
downloadfreebsd-ports-gnome-c92cc9c6b3dcdcd7d10614d55f61e859259331d1.tar.gz
freebsd-ports-gnome-c92cc9c6b3dcdcd7d10614d55f61e859259331d1.tar.zst
freebsd-ports-gnome-c92cc9c6b3dcdcd7d10614d55f61e859259331d1.zip
The globus build requires GNU tar (or at least a tar named gtar) so add
an appropriate BUILD_DEPEND. Create a variable, TMPBINDIR, to hold ${WRKDIR}/tmpdir to keep things consistant. Remove a useless comment.
Diffstat (limited to 'net')
-rw-r--r--net/globus4/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/net/globus4/Makefile b/net/globus4/Makefile
index 894f8dc45b3c..c724b6eb2f82 100644
--- a/net/globus4/Makefile
+++ b/net/globus4/Makefile
@@ -20,6 +20,7 @@ EXTRACT_ONLY= ${INSTALLER}
MAINTAINER= brooks@FreeBSD.org
COMMENT= Grid computing toolkit
+BUILD_DEPENDS= gtar:${PORTSDIR}/archivers/gtar
RUN_DEPENDS= ${LOCALBASE}/bin/sudo:${PORTSDIR}/security/sudo
INSTALLER= ${DISTNAME}${EXTRACT_SUFX}
@@ -41,12 +42,12 @@ GLOBUS_LOCATION=${TARGETDIR}/${GLOBUS_BASE}
TMP_GLOBUS_LOCATION= ${WRKDIR}/globus
TMP_GLOBUS_ENV= GLOBUS_LOCATION=${TMP_GLOBUS_LOCATION} \
GPT_LOCATION=${TMP_GLOBUS_LOCATION} \
- PATH=${WRKDIR}/tmpbin:${PATH} \
+ PATH=${TMPBINDIR}:${PATH} \
LD_LIBRARY_PATH=${TMP_GLOBUS_LOCATION}/lib
+TMPBINDIR= ${WRKDIR}/tmpbin
CONFIGURE_ARGS= --prefix=${TMP_GLOBUS_LOCATION} ${CONFIGURE_TARGET}
CONFIGURE_ENV+= ${TMP_GLOBUS_ENV}
-# WARNING: this only works because we do the install ourselves
MAKE_ENV+= ${TMP_GLOBUS_ENV}
PLIST_SUB+= BASE_FLAVOR=${BASE_FLAVOR} \
@@ -111,9 +112,9 @@ pre-configure:
pre-build:
${MKDIR} ${WRKSRC}/gpt/packaging_tools/etc/gpt
- ${MKDIR} ${WRKDIR}/tmpbin
- ${LN} -s `which gmake` ${WRKDIR}/tmpbin/make || ${TRUE}
- ls -l ${WRKDIR}/tmpbin
+ ${MKDIR} ${TMPBINDIR}
+ ${LN} -s `which gmake` ${TMPBINDIR}/make || ${TRUE}
+ ls -l ${TMPBINDIR}
post-build:
.for _B in ${UPDATE_BUNDLES}