aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorandreas <andreas@FreeBSD.org>2004-06-12 01:33:32 +0800
committerandreas <andreas@FreeBSD.org>2004-06-12 01:33:32 +0800
commitc96d17255587d90027de9bf69e70111e0c79bcc4 (patch)
tree83ba60475f8571fc92edada7ef28ca5b1ca23ee5 /net
parent57dba93592ceacde736ec6348866d47986a9e3fe (diff)
downloadfreebsd-ports-gnome-c96d17255587d90027de9bf69e70111e0c79bcc4.tar.gz
freebsd-ports-gnome-c96d17255587d90027de9bf69e70111e0c79bcc4.tar.zst
freebsd-ports-gnome-c96d17255587d90027de9bf69e70111e0c79bcc4.zip
- 1st ack packet got a random packetnumber, but should be 0.
- Packets > 32768 have not been acked anymore because of counter overflow with files > 16 MB. Changed 'short' to 'unsigned short' Author has been notified, but it seems utftpd isnt maintained actively anymore. So a hot fix here in the ports collection. Thanks to Joerg for fixing this bug. Submitted by: joerg@FreeBSD.org
Diffstat (limited to 'net')
-rw-r--r--net/utftpd/Makefile2
-rw-r--r--net/utftpd/files/patch-utftpd_recv.c20
2 files changed, 21 insertions, 1 deletions
diff --git a/net/utftpd/Makefile b/net/utftpd/Makefile
index 3723e9c7f32e..fd3f87d7744c 100644
--- a/net/utftpd/Makefile
+++ b/net/utftpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= utftpd
PORTVERSION= 0.2.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://www.ohse.de/uwe/releases/
diff --git a/net/utftpd/files/patch-utftpd_recv.c b/net/utftpd/files/patch-utftpd_recv.c
new file mode 100644
index 000000000000..97e4e0928898
--- /dev/null
+++ b/net/utftpd/files/patch-utftpd_recv.c
@@ -0,0 +1,20 @@
+--- utftpd_recv.c.orig Mon Nov 1 10:02:32 1999
++++ utftpd_recv.c Fri Jun 11 16:37:25 2004
+@@ -69,7 +69,7 @@
+ struct sigaction old_sa;
+ const char *errortext;
+ size_t sendlength;
+- short got_blockno;
++ unsigned short got_blockno;
+ short got_opcode;
+ int is_final=0;
+
+@@ -82,6 +82,7 @@
+
+ blockno=1;
+ got=flags->segsize+TFTP_OFFSET;
++ flags->sendbuf.hdr->th_block = htons(0);
+ sendlength=flags->first_packet_length+TFTP_OFFSET;
+
+ while (1) {
+