aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorscheidell <scheidell@FreeBSD.org>2012-06-16 18:03:48 +0800
committerscheidell <scheidell@FreeBSD.org>2012-06-16 18:03:48 +0800
commitd3ab18e94111191271f2afd538a756cd42365bf6 (patch)
treeee4b4d042d8ce3a3e60e9ee2b730cb536d4c04eb /net
parent35b346e00f3e8dd7e33f8e227bf31fad1340096c (diff)
downloadfreebsd-ports-gnome-d3ab18e94111191271f2afd538a756cd42365bf6.tar.gz
freebsd-ports-gnome-d3ab18e94111191271f2afd538a756cd42365bf6.tar.zst
freebsd-ports-gnome-d3ab18e94111191271f2afd538a756cd42365bf6.zip
- Update to version 2.2 [1]
- Leftovers, missing a couple of PLIST_SUB entries [2] PR: ports/168933 Submitted by: Goran Tal <goran.tal@gmail.com> [1] Reviewed by: scheidell@ (me) [2]
Diffstat (limited to 'net')
-rw-r--r--net/gnu-dico/Makefile22
-rw-r--r--net/gnu-dico/distinfo4
-rw-r--r--net/gnu-dico/files/dicod.sh.in2
-rw-r--r--net/gnu-dico/pkg-plist22
4 files changed, 43 insertions, 7 deletions
diff --git a/net/gnu-dico/Makefile b/net/gnu-dico/Makefile
index 9af07f22a0d9..e695f05189c0 100644
--- a/net/gnu-dico/Makefile
+++ b/net/gnu-dico/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= dico
-PORTVERSION= 2.1
-PORTREVISION= 2
+PORTVERSION= 2.2
CATEGORIES= net textproc
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -28,7 +27,9 @@ CONFIGURE_ARGS= --localstatedir=/var
OPTIONS= PYTHON "With PYTHON support" on \
GUILE "With GUILE support" on \
+ PCRE "With PCRE support" on \
GSASL "With GSASL support" off \
+ PAM "With PAM support" off \
LDAP "With LDAP support" off
.include <bsd.port.options.mk>
@@ -49,6 +50,14 @@ CONFIGURE_ARGS+=--without-guile
PLIST_SUB+= GUILE="@comment "
.endif
+.if defined(WITH_PCRE)
+LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre
+PLIST_SUB+= PCRE=""
+.else
+CONFIGURE_ARGS+=--without-pcre
+PLIST_SUB+= PCRE="@comment "
+.endif
+
.if defined(WITH_GSASL)
LIB_DEPENDS+= gsasl.16:${PORTSDIR}/security/gsasl
CONFIGURE_ARGS+=--with-gsasl
@@ -56,6 +65,14 @@ CONFIGURE_ARGS+=--with-gsasl
CONFIGURE_ARGS+=--without-gsasl
.endif
+.if defined(WITH_PAM)
+PLIST_SUB+= PAM=""
+CONFIGURE_ARGS+=--enable-pam
+.else
+PLIST_SUB+= PAM="@comment "
+CONFIGURE_ARGS+=--disable-pam
+.endif
+
.if defined(WITH_LDAP)
USE_OPENLDAP= yes
PLIST_SUB+= LDAP=""
@@ -79,7 +96,6 @@ SUB_FILES+= pkg-message
USE_RC_SUBR= dicod.sh
post-patch:
- @${REINPLACE_CMD} 's/ENODATA/EIO/' ${WRKSRC}/lib/utf8.c
@${REINPLACE_CMD} 's/@bindir@/@sbindir@/' ${WRKSRC}/dicod/Makefile.in
@${REINPLACE_CMD} 's/(bindir)..dir/&\/gdico/' ${WRKSRC}/dico/Makefile.in
@${REINPLACE_CMD} '/INSTALL.*charset/d' ${WRKSRC}/gnu/Makefile.in
diff --git a/net/gnu-dico/distinfo b/net/gnu-dico/distinfo
index 9148958f1473..1b0632168792 100644
--- a/net/gnu-dico/distinfo
+++ b/net/gnu-dico/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dico-2.1.tar.xz) = 9a909beaa26aaf96e80c5c313835265f34b347bcaf41409f479a21a569068c43
-SIZE (dico-2.1.tar.xz) = 1201836
+SHA256 (dico-2.2.tar.xz) = c474931e4e6f31fcff247f181d48448f18be4091750843536840f472809ef212
+SIZE (dico-2.2.tar.xz) = 1445224
diff --git a/net/gnu-dico/files/dicod.sh.in b/net/gnu-dico/files/dicod.sh.in
index 3c849d9a08eb..f18a48cba93c 100644
--- a/net/gnu-dico/files/dicod.sh.in
+++ b/net/gnu-dico/files/dicod.sh.in
@@ -10,7 +10,7 @@
dicod_enable=${dicod_enable-"NO"}
-. %%RC_SUBR%%
+. /etc/rc.subr
name=dicod
rcvar=dicod_enable
diff --git a/net/gnu-dico/pkg-plist b/net/gnu-dico/pkg-plist
index 1a3265c8a281..9879037c5e52 100644
--- a/net/gnu-dico/pkg-plist
+++ b/net/gnu-dico/pkg-plist
@@ -10,6 +10,7 @@ include/dico/markup.h
include/dico/parseopt.h
include/dico/strat.h
include/dico/stream.h
+include/dico/tokenize.h
include/dico/types.h
include/dico/udb.h
include/dico/url.h
@@ -19,15 +20,30 @@ include/dico/xlat.h
lib/dico/dictorg.a
lib/dico/dictorg.la
lib/dico/dictorg.so
+lib/dico/echo.a
+lib/dico/echo.la
+lib/dico/echo.so
+lib/dico/gcide.a
+lib/dico/gcide.la
+lib/dico/gcide.so
%%GUILE%%lib/dico/guile.a
%%GUILE%%lib/dico/guile.la
%%GUILE%%lib/dico/guile.so
%%LDAP%%lib/dico/ldap.a
%%LDAP%%lib/dico/ldap.la
%%LDAP%%lib/dico/ldap.so
+lib/dico/nprefix.a
+lib/dico/nprefix.la
+lib/dico/nprefix.so
lib/dico/outline.a
lib/dico/outline.la
lib/dico/outline.so
+%%PAM%%lib/dico/pam.a
+%%PAM%%lib/dico/pam.la
+%%PAM%%lib/dico/pam.so
+%%PCRE%%lib/dico/pcre.a
+%%PCRE%%lib/dico/pcre.la
+%%PCRE%%lib/dico/pcre.so
%%PYTHON%%lib/dico/python.a
%%PYTHON%%lib/dico/python.la
%%PYTHON%%lib/dico/python.so
@@ -37,13 +53,17 @@ lib/dico/stratall.so
lib/dico/substr.a
lib/dico/substr.la
lib/dico/substr.so
+lib/dico/word.a
+lib/dico/word.la
+lib/dico/word.so
lib/libdico.a
lib/libdico.la
lib/libdico.so
lib/libdico.so.1
+libexec/idxgcide
sbin/dicod
%%DATADIR%%/%%PORTVERSION%%/include/pp-setup
-%%DATADIR%%/gjdict.xbm
+%%NLS%%share/locale/fi/LC_MESSAGES/dico.mo
%%NLS%%share/locale/pl/LC_MESSAGES/dico.mo
%%NLS%%share/locale/uk/LC_MESSAGES/dico.mo
@dirrm share/dico/%%PORTVERSION%%/include