aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsylvio <sylvio@FreeBSD.org>2012-06-06 05:35:50 +0800
committersylvio <sylvio@FreeBSD.org>2012-06-06 05:35:50 +0800
commitd3d99049d0d4d2b44b27b68190c9228a6ec86edc (patch)
tree1e9dc731b09e828f7970ee93775079ac3cd129fb /net
parent1a8f2e296a0bd0f241d72bf2bd306250d074c5c2 (diff)
downloadfreebsd-ports-gnome-d3d99049d0d4d2b44b27b68190c9228a6ec86edc.tar.gz
freebsd-ports-gnome-d3d99049d0d4d2b44b27b68190c9228a6ec86edc.tar.zst
freebsd-ports-gnome-d3d99049d0d4d2b44b27b68190c9228a6ec86edc.zip
- Fixed port
- Removed BROKEN - Add patch file: files/patch-random.cc - Pass maintainership to submitter PR: ports/168672 Submitted by: Masaki TAGAWA <masaki@club.kyutech.ac.jp>
Diffstat (limited to 'net')
-rw-r--r--net/nam/Makefile12
-rw-r--r--net/nam/files/patch-random.cc14
2 files changed, 19 insertions, 7 deletions
diff --git a/net/nam/Makefile b/net/nam/Makefile
index 6753f2e5fa04..042bae1fa207 100644
--- a/net/nam/Makefile
+++ b/net/nam/Makefile
@@ -7,26 +7,24 @@
PORTNAME= nam
PORTVERSION= 1.12
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= http://www.isi.edu/nsnam/dist/
DISTNAME= nam-src-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= masaki@club.kyutech.ac.jp
COMMENT= Animation tool for network simulation traces
BUILD_DEPENDS= ${LOCALBASE}/lib/libtclcl.a:${PORTSDIR}/devel/tclcl
LIB_DEPENDS= otcl.1:${PORTSDIR}/lang/otcl
-BROKEN= does not configure
-
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_XORG= xmu
GNU_CONFIGURE= yes
-CXXFLAGS+= -I${LOCALBASE}/include/tclcl
-CONFIGURE_ARGS= --with-tcl-ver=8.4 --with-tk-ver=8.4
-MAKE_ARGS= CCOPT="${CXXFLAGS}"
+CONFIGURE_ARGS= --with-tcl-ver=${TCL_VER} --with-tk-ver=${TK_VER} --x-libraries=${LOCALBASE}/lib --x-includes=${LOCALBASE}/include
+USE_GMAKE= yes
+USE_TK= 85+
ALL_TARGET= ${PORTNAME}
MAN1= nam.1
diff --git a/net/nam/files/patch-random.cc b/net/nam/files/patch-random.cc
new file mode 100644
index 000000000000..c51bd3192e5f
--- /dev/null
+++ b/net/nam/files/patch-random.cc
@@ -0,0 +1,14 @@
+--- random.cc.org 2006-09-27 04:28:19.000000000 +0900
++++ random.cc 2012-06-04 19:23:10.000000000 +0900
+@@ -50,8 +50,11 @@
+ RANDOM_RETURN_TYPE
+ random() GCC_THROW
+ {
++ return (long)Random::uniform();
++ /*
+ printf("random() called in nam.\nRandom is not portable, please use Random::uniform() instead.\n");
+ abort();
++ */
+ }
+
+ #endif /* !WIN32 */ \ No newline at end of file