aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-04-07 07:51:08 +0800
committeredwin <edwin@FreeBSD.org>2003-04-07 07:51:08 +0800
commitd50b1935b34bdf4dd6245342dab18d4e901c02e5 (patch)
treee14e392aa7b12e555545ca08470789c13a1ccca4 /net
parentd4269d9e13e17fb264e20f10c395659217f31a03 (diff)
downloadfreebsd-ports-gnome-d50b1935b34bdf4dd6245342dab18d4e901c02e5.tar.gz
freebsd-ports-gnome-d50b1935b34bdf4dd6245342dab18d4e901c02e5.tar.zst
freebsd-ports-gnome-d50b1935b34bdf4dd6245342dab18d4e901c02e5.zip
net/openldap20 doesn't work if db3 and db4 are installed
Compile it. Try to run it. It won't. ktracing /usr/local/libexec/slapd -d 0 and confirming with ldd shows that it compiles with db3's headers (as specified by the port makefile) but links with /usr/local/lib/libdb4 (if present...as it is on my system). PR: ports/38744 Submitted by: Faried Nawaz <fn@hungry.org>
Diffstat (limited to 'net')
-rw-r--r--net/openldap20-server/Makefile8
-rw-r--r--net/openldap20/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/net/openldap20-server/Makefile b/net/openldap20-server/Makefile
index eb4c85044eeb..c988e37b73f7 100644
--- a/net/openldap20-server/Makefile
+++ b/net/openldap20-server/Makefile
@@ -25,7 +25,13 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Open source LDAP client and server software
+.if exists(${LOCALBASE}/lib/libdb4.a)
+DB_CFLAGS= -I${LOCALBASE}/include/db4
+LIB_DEPENDS= db41:${PORTSDIR}/databases/db4
+.else
+DB_CFLAGS= -I${LOCALBASE}/include/db3
LIB_DEPENDS= db3.3:${PORTSDIR}/databases/db3
+.endif
USE_AUTOCONF_VER=213
USE_LIBTOOL= yes
@@ -48,7 +54,7 @@ CONFIGURE_ARGS+= --enable-wrappers
# math.h uses _REENTRANT and stdio.h uses _THREAD_SAFE, so define both.
CPPFLAGS+= -D_REENTRANT ${PTHREAD_CFLAGS} \
-I${LOCALBASE}/include \
- -I${LOCALBASE}/include/db3
+ ${DB_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib
.if defined(WITH_SASL)
diff --git a/net/openldap20/Makefile b/net/openldap20/Makefile
index eb4c85044eeb..c988e37b73f7 100644
--- a/net/openldap20/Makefile
+++ b/net/openldap20/Makefile
@@ -25,7 +25,13 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Open source LDAP client and server software
+.if exists(${LOCALBASE}/lib/libdb4.a)
+DB_CFLAGS= -I${LOCALBASE}/include/db4
+LIB_DEPENDS= db41:${PORTSDIR}/databases/db4
+.else
+DB_CFLAGS= -I${LOCALBASE}/include/db3
LIB_DEPENDS= db3.3:${PORTSDIR}/databases/db3
+.endif
USE_AUTOCONF_VER=213
USE_LIBTOOL= yes
@@ -48,7 +54,7 @@ CONFIGURE_ARGS+= --enable-wrappers
# math.h uses _REENTRANT and stdio.h uses _THREAD_SAFE, so define both.
CPPFLAGS+= -D_REENTRANT ${PTHREAD_CFLAGS} \
-I${LOCALBASE}/include \
- -I${LOCALBASE}/include/db3
+ ${DB_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib
.if defined(WITH_SASL)