aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2014-06-14 19:11:11 +0800
committeroliver <oliver@FreeBSD.org>2014-06-14 19:11:11 +0800
commitd519d98e225b737f5412b820e4d377c1b63ae5ea (patch)
treeeb17a7cf77ca4f745833b81b429301de982410da /net
parent5201fda09675aab0c18d1c3b75db08d2689c91a1 (diff)
downloadfreebsd-ports-gnome-d519d98e225b737f5412b820e4d377c1b63ae5ea.tar.gz
freebsd-ports-gnome-d519d98e225b737f5412b820e4d377c1b63ae5ea.tar.zst
freebsd-ports-gnome-d519d98e225b737f5412b820e4d377c1b63ae5ea.zip
mark as BROKEN (Does not compile with clang)
Diffstat (limited to 'net')
-rw-r--r--net/cyphesis/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/net/cyphesis/Makefile b/net/cyphesis/Makefile
index c66c4bd6de18..a7acd0f77457 100644
--- a/net/cyphesis/Makefile
+++ b/net/cyphesis/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= SF/worldforge/${PORTNAME}%20%28server%29/${PORTVERSION}
MAINTAINER= oliver@FreeBSD.org
COMMENT= Server for WorldForge games
+LICENSE= GPLv2
+
LIB_DEPENDS= libAtlas-0.6.so:${PORTSDIR}/devel/atlas-devel \
libvarconf-1.0.so:${PORTSDIR}/devel/varconf \
libwfmath-1.0.so:${PORTSDIR}/math/wfmath \
@@ -20,6 +22,8 @@ LIB_DEPENDS= libAtlas-0.6.so:${PORTSDIR}/devel/atlas-devel \
CONFIGURE_ARGS= --with-python=${LOCALBASE}
+BROKEN= Does not compile with clang
+
GNU_CONFIGURE= yes
USE_BZIP2= yes
USES= gmake pathfix pkgconfig compiler:c++11-lib
@@ -61,8 +65,8 @@ post-install:
.for file in README COPYING AUTHORS THANKS NEWS ChangeLog TODO FIXME
@${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-.for file in acorn.xml basic.xml cyphesis.vconf mason.xml werewolf.xml
- @${INSTALL_DATA} ${WRKSRC}/data/${file} ${STAGEDIR}${DOCSDIR}/conf
+.for xmlfile in acorn.xml basic.xml cyphesis.vconf mason.xml werewolf.xml
+ @${INSTALL_DATA} ${WRKSRC}/data/${xmlfile} ${STAGEDIR}${DOCSDIR}/conf
.endfor
.endif