aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorroger <roger@FreeBSD.org>2000-11-22 21:53:23 +0800
committerroger <roger@FreeBSD.org>2000-11-22 21:53:23 +0800
commitd76bd62505f121e87a9d3b06e378e190e5ce103f (patch)
tree179a6992602ad17ca6340c5d097965f4a26ce56b /net
parent3cd85297b2da7566fd704068b0542ec3d50855ba (diff)
downloadfreebsd-ports-gnome-d76bd62505f121e87a9d3b06e378e190e5ce103f.tar.gz
freebsd-ports-gnome-d76bd62505f121e87a9d3b06e378e190e5ce103f.tar.zst
freebsd-ports-gnome-d76bd62505f121e87a9d3b06e378e190e5ce103f.zip
Add OpenMCU - a H323 Multipoint Control Unit.
The MCU allows multiple people to talk to each at the same time if they are using H323 based Video Conferencing programs or using H323 based Internet Phone applications. Normally H323 applications can support 1 to 1 calls. Only video is supported at this time. No video yet. This is another spin off from the OpenH323 project. http://www.openh323.org
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/openmcu/Makefile34
-rw-r--r--net/openmcu/distinfo1
-rw-r--r--net/openmcu/pkg-comment1
-rw-r--r--net/openmcu/pkg-descr10
-rw-r--r--net/openmcu/pkg-plist1
6 files changed, 48 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 0a7c8648e64f..465657cc45e1 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -175,6 +175,7 @@
SUBDIR += openh323
SUBDIR += openldap
SUBDIR += openldap2
+ SUBDIR += openmcu
SUBDIR += p0f
SUBDIR += p5-Archie
SUBDIR += p5-Mon
diff --git a/net/openmcu/Makefile b/net/openmcu/Makefile
new file mode 100644
index 000000000000..9000cd731203
--- /dev/null
+++ b/net/openmcu/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: openmcu
+# Date created: Wed Nov 22 08:57:55 GMT 2000
+# Whom: Roger Hardiman <roger@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openmcu
+PORTVERSION= cvs.20001122
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= roger
+
+MAINTAINER= roger@FreeBSD.org
+
+BUILD_DEPENDS= /nonexistent:${PORTSDIR}/net/openh323:build
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+NOCLEANDEPENDS= yes
+
+USE_NEWGCC= yes
+USE_BISON= yes
+USE_GMAKE= yes
+ALL_TARGET= opt
+MAKE_ENV= PWLIBDIR=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/pwlib \
+ OPENH323DIR=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/openh323
+THE_MACHTYPE= ${ARCH:S/i386/x86/}
+MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${THE_MACHTYPE} OSRELEASE=${OSVERSION} CPLUS=${CXX}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/obj_${OPSYS}_${THE_MACHTYPE}_r/openmcu ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/openmcu/distinfo b/net/openmcu/distinfo
new file mode 100644
index 000000000000..6243576dbb79
--- /dev/null
+++ b/net/openmcu/distinfo
@@ -0,0 +1 @@
+MD5 (openmcu-cvs.20001122.tar.gz) = 3d35e8ee9dd4ccd24917463cdc27ab17
diff --git a/net/openmcu/pkg-comment b/net/openmcu/pkg-comment
new file mode 100644
index 000000000000..27e85f0d940a
--- /dev/null
+++ b/net/openmcu/pkg-comment
@@ -0,0 +1 @@
+The MCU Multipoint Conference Unit lets several people to take part in a H323 Video Conference or Audio call
diff --git a/net/openmcu/pkg-descr b/net/openmcu/pkg-descr
new file mode 100644
index 000000000000..43e91d00e21f
--- /dev/null
+++ b/net/openmcu/pkg-descr
@@ -0,0 +1,10 @@
+OpenMCU is a H323 Multipoint Conference Unit.
+
+It allows several people to take part in the same Video Conference or
+Internet Phone Call (VoIP) when using program using the H323 protocols.
+
+Applications using H323 include OpenH323, OhPhone and Microsoft's NetMeeting.
+
+It makes use of PWLib and the OpenH323 stack from Equivalence Ltd Pty
+
+WWW: http://www.openh323.org/
diff --git a/net/openmcu/pkg-plist b/net/openmcu/pkg-plist
new file mode 100644
index 000000000000..0d2bffe9cf84
--- /dev/null
+++ b/net/openmcu/pkg-plist
@@ -0,0 +1 @@
+bin/openmcu